CVE-2006-2839
CVSS6.4
发布时间 :2006-06-06 16:06:00
修订时间 :2011-03-07 21:37:06
NMCO    

[原文]Directory traversal vulnerability in PG Problem Editor module (PGProblemEditor.pm) in WeBWorK Online Homework Delivery System 2.2.0 and earlier allows remote attackers to read and write files outside of the templates directory.


[CNNVD]WeBWorK Online Homework Delivery System PG Problem Editor模块(PGProblemEditor.pm) 目录遍历漏洞(CNNVD-200606-162)

        WeBWorK Online Homework Delivery System 2.2.0及更早版本中的PG Problem Editor模块(PGProblemEditor.pm)存在目录遍历漏洞,远程攻击者可读取和写在模板目录之外的文件。

- CVSS (基础分值)

CVSS分值: 6.4 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-2839
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-2839
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200606-162
(官方数据源) CNNVD

- 其它链接及资源

http://secunia.com/advisories/20405
(VENDOR_ADVISORY)  SECUNIA  20405
http://www.vupen.com/english/advisories/2006/2086
(UNKNOWN)  VUPEN  ADV-2006-2086
http://sourceforge.net/mailarchive/forum.php?thread_id=10201693&forum_id=43257
(UNKNOWN)  CONFIRM  http://sourceforge.net/mailarchive/forum.php?thread_id=10201693&forum_id=43257
http://devel.webwork.rochester.edu/twiki/bin/view/Webwork/WeBWorKRelease2pt2pt1
(UNKNOWN)  CONFIRM  http://devel.webwork.rochester.edu/twiki/bin/view/Webwork/WeBWorKRelease2pt2pt1
http://xforce.iss.net/xforce/xfdb/26975
(UNKNOWN)  XF  webwork-pgproblemeditor-security-bypass(26975)

- 漏洞信息

WeBWorK Online Homework Delivery System PG Problem Editor模块(PGProblemEditor.pm) 目录遍历漏洞
中危 路径遍历
2006-06-06 00:00:00 2006-11-03 00:00:00
远程  
        WeBWorK Online Homework Delivery System 2.2.0及更早版本中的PG Problem Editor模块(PGProblemEditor.pm)存在目录遍历漏洞,远程攻击者可读取和写在模板目录之外的文件。

- 公告与补丁

        

- 漏洞信息

25938
WeBWorK PGProblemEditor.pm Traversal Arbitrary File Manipulation
Input Manipulation
Vendor Verified

- 漏洞描述

Unknown or Incomplete

- 时间线

2006-05-31 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 2.2.1 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站