CVE-2006-2837
CVSS4.3
发布时间 :2006-06-06 16:06:00
修订时间 :2011-03-07 21:37:06
NMCO    

[原文]Cross-site scripting (XSS) vulnerability in Techno Dreams Guest Book allows remote attackers to inject arbitrary web script or HTML via certain comment fields in the "Sign Our GuestBook" page, probably the x_Comments parameter to guestbookadd.asp.


[CNNVD]Techno Dreams Guest Book Comment Field 跨站脚本攻击(XSS)漏洞(CNNVD-200606-156)

        Techno Dreams Guest Book存在跨站脚本攻击(XSS)漏洞,远程攻击者可通过在"注册我们的留言簿"页的特定评论字段(可能是传给guestbookadd.asp的x_Comments参数)来注入任意Web脚本或HTML。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-2837
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-2837
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200606-156
(官方数据源) CNNVD

- 其它链接及资源

http://www.vupen.com/english/advisories/2006/2079
(UNKNOWN)  VUPEN  ADV-2006-2079
http://secunia.com/advisories/20403
(VENDOR_ADVISORY)  SECUNIA  20403
http://colander.altervista.org/advisory/TDGuestBook.txt
(UNKNOWN)  MISC  http://colander.altervista.org/advisory/TDGuestBook.txt
http://www.securityfocus.com/bid/18210
(UNKNOWN)  BID  18210

- 漏洞信息

Techno Dreams Guest Book Comment Field 跨站脚本攻击(XSS)漏洞
中危 跨站脚本
2006-06-06 00:00:00 2006-11-03 00:00:00
远程  
        Techno Dreams Guest Book存在跨站脚本攻击(XSS)漏洞,远程攻击者可通过在"注册我们的留言簿"页的特定评论字段(可能是传给guestbookadd.asp的x_Comments参数)来注入任意Web脚本或HTML。

- 公告与补丁

        补丁安装方法:
        1. 手工安装补丁包:
        首先,使用下面的命令来下载补丁软件:
        # wget url(url是补丁下载链接地址)
        然后,使用下面的命令来安装补丁:
        # dpkg -i file.deb (file是相应的补丁名)
        2. 使用apt-get自动安装补丁包:
         首先,使用下面的命令更新内部数据库:
         # apt-get update
         然后,使用下面的命令安装更新软件包:
         # apt-get upgrade
        RedHat
        ------
        http://www.debian.org/security/2006/dsa-1090
        Gentoo
        ------
        Gentoo已经为此发布了一个安全公告(GLSA-200606-09)以及相应补丁:
        GLSA-200606-09:SpamAssassin: Execution of arbitrary code
        链接:
        http://security.gentoo.org/glsa/glsa-200606-09.xml
        所有SpamAssassin用户都应升级到最新版本:
        # emerge --sync
        # emerge --ask --oneshot --verbose ">=mail-filter/spamassassin-3.1.3"
        SpamAssassin
        ------------
        目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:
        * SpamAssassin Mail-SpamAssassin-3.0.6.tar.gz
        http://apache.mirror.rafal.ca/spamassassin/source/Mail-SpamAssassin-3.0.6.tar.gz
        * SpamAssassin Mail-SpamAssassin-3.1.3.tar.gz
        http://apache.mirror.rafal.ca/spamassassin/source/Mail-SpamAssassin-3.1.3.tar.gz
        

- 漏洞信息

25945
Techno Dreams Guest Book Comment XSS
Remote / Network Access Input Manipulation
Loss of Integrity

- 漏洞描述

Unknown or Incomplete

- 时间线

2006-05-04 Unknow
2006-05-04 Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站