CVE-2006-2830
CVSS7.5
发布时间 :2006-06-05 16:06:00
修订时间 :2011-03-07 21:37:05
NMCO    

[原文]Buffer overflow in TIBCO Rendezvous before 7.5.1, TIBCO Runtime Agent (TRA) before 5.4, and Hawk before 4.6.1 allows remote attackers to cause a denial of service and possibly execute arbitrary code via the HTTP administrative interface.


[CNNVD]TIBCO Rendezvous HTTP接口 缓冲区溢出漏洞(CNNVD-200606-115)

        TIBCO Rendezvous是一套帮助用户快速构建和部署大规模分布式应用的中间件。
        TIBCO Rendezvous守护程序组件在处理通过HTTP管理接口接收到的某些请求时存在缓冲区溢出漏洞。在基于Unix的系统上,成功的攻击会导致以调用守护程序用户的权限(user id 0也就是root除外)执行任意代码。如果守护程序是由user id 0调用的,则成功攻击会导致user id 65534(nobody)权限的访问。在基于Windows的系统上,成功攻击会导致以调用守护程序用户的权限执行任意代码。如果守护程序组件安装为系统服务,就会导致系统权限访问。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:tibco:runtime_agent:5.3
cpe:/a:tibco:rendezvous:7.5.1
cpe:/a:tibco:hawk:4.6.1

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-2830
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-2830
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200606-115
(官方数据源) CNNVD

- 其它链接及资源

http://www.kb.cert.org/vuls/id/999884
(PATCH)  CERT-VN  VU#999884
http://www.tibco.com/resources/mk/rendezvous_security_advisory.txt
(VENDOR_ADVISORY)  CONFIRM  http://www.tibco.com/resources/mk/rendezvous_security_advisory.txt
http://secunia.com/advisories/20452
(VENDOR_ADVISORY)  SECUNIA  20452
http://www.vupen.com/english/advisories/2006/2155
(UNKNOWN)  VUPEN  ADV-2006-2155
http://www.securityfocus.com/bid/18301
(UNKNOWN)  BID  18301
http://securitytracker.com/id?1016145
(UNKNOWN)  SECTRACK  1016145
http://xforce.iss.net/xforce/xfdb/26939
(UNKNOWN)  XF  tibco-rendezvous-admin-bo(26939)

- 漏洞信息

TIBCO Rendezvous HTTP接口 缓冲区溢出漏洞
高危 缓冲区溢出
2006-06-05 00:00:00 2006-11-03 00:00:00
远程  
        TIBCO Rendezvous是一套帮助用户快速构建和部署大规模分布式应用的中间件。
        TIBCO Rendezvous守护程序组件在处理通过HTTP管理接口接收到的某些请求时存在缓冲区溢出漏洞。在基于Unix的系统上,成功的攻击会导致以调用守护程序用户的权限(user id 0也就是root除外)执行任意代码。如果守护程序是由user id 0调用的,则成功攻击会导致user id 65534(nobody)权限的访问。在基于Windows的系统上,成功攻击会导致以调用守护程序用户的权限执行任意代码。如果守护程序组件安装为系统服务,就会导致系统权限访问。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复这个安全问题,补丁下载链接:
        http://www.tibco.com/software/messaging/rendezvous.jsp

- 漏洞信息

26155
TIBCO Rendezvous Multiple Products HTTP Administrative Interface Remote Overflow
Remote / Network Access Input Manipulation
Loss of Integrity Upgrade
Vendor Verified

- 漏洞描述

- 时间线

2006-06-05 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 7.5.1 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站