CVE-2006-2762
CVSS6.4
发布时间 :2006-06-01 21:02:00
修订时间 :2011-03-07 21:36:58
NMCOS    

[原文]PHP remote file inclusion vulnerability in includes/config.php in WebCalendar 1.0.3 allows remote attackers to execute arbitrary PHP code via a URL in the includedir parameter, which is remotely accessed in an fopen call whose results are used to define a user_inc setting that is used in an include_once call.


[CNNVD]WebCalendar config.php PHP远程文件包含漏洞(CNNVD-200606-041)

        WebCalendar 1.0.3中的includes/config.php存在PHP远程文件包含漏洞,远程攻击者可通过在includedir参数中的URL(fopen调用中远程访问它,调用的结果是用来定义user_inc设置,该设置用于include_once调用中)来执行任意PHP代码。

- CVSS (基础分值)

CVSS分值: 6.4 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-2762
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-2762
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200606-041
(官方数据源) CNNVD

- 其它链接及资源

http://www.vupen.com/english/advisories/2006/2067
(UNKNOWN)  VUPEN  ADV-2006-2067
http://securitytracker.com/id?1016179
(UNKNOWN)  SECTRACK  1016179
http://secunia.com/advisories/20367
(VENDOR_ADVISORY)  SECUNIA  20367
http://www.securityfocus.com/bid/18175
(UNKNOWN)  BID  18175
http://www.securityfocus.com/archive/1/archive/1/436263/100/0/threaded
(UNKNOWN)  BUGTRAQ  20060607 Re: WebCalendar-1.0.3 reading of any files
http://www.securityfocus.com/archive/1/435379
(UNKNOWN)  BUGTRAQ  20060530 WebCalendar-1.0.3 reading of any files
http://www.osvdb.org/25842
(UNKNOWN)  OSVDB  25842
http://www.debian.org/security/2006/dsa-1096
(UNKNOWN)  DEBIAN  DSA-1096
http://securityreason.com/securityalert/1019
(UNKNOWN)  SREASON  1019
http://secunia.com/advisories/20542
(UNKNOWN)  SECUNIA  20542

- 漏洞信息

WebCalendar config.php PHP远程文件包含漏洞
中危 输入验证
2006-06-01 00:00:00 2006-06-01 00:00:00
远程  
        WebCalendar 1.0.3中的includes/config.php存在PHP远程文件包含漏洞,远程攻击者可通过在includedir参数中的URL(fopen调用中远程访问它,调用的结果是用来定义user_inc设置,该设置用于include_once调用中)来执行任意PHP代码。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复这个安全问题,补丁下载链接:
        k5n WebCalendar 1.0
        WebCalendar WebCalendar-1.0.4.tar.gz
        http://prdownloads.sourceforge.net/webcalendar/WebCalendar-1.0.4.tar.g
        z?download
        k5n WebCalendar 1.0 RC3
        WebCalendar WebCalendar-1.0.4.tar.gz
        http://prdownloads.sourceforge.net/webcalendar/WebCalendar-1.0.4.tar.g
        z?download
        k5n WebCalendar 1.0 RC1
        WebCalendar WebCalendar-1.0.4.tar.gz
        http://prdownloads.sourceforge.net/webcalendar/WebCalendar-1.0.4.tar.g
        z?download
        k5n WebCalendar 1.0 rc2
        WebCalendar WebCalendar-1.0.4.tar.gz
        http://prdownloads.sourceforge.net/webcalendar/WebCalendar-1.0.4.tar.g
        z?download
        k5n WebCalendar 1.0.1
        WebCalendar WebCalendar-1.0.4.tar.gz
        http://prdownloads.sourceforge.net/webcalendar/WebCalendar-1.0.4.tar.g
        z?download
        k5n WebCalendar 1.0.2
        WebCalendar WebCalendar-1.0.4.tar.gz
        http://prdownloads.sourceforge.net/webcalendar/WebCalendar-1.0.4.tar.g
        z?download
        k5n WebCalendar 1.0.3
        WebCalendar WebCalendar-1.0.4.tar.gz
        http://prdownloads.sourceforge.net/webcalendar/WebCalendar-1.0.4.tar.g
        z?download

- 漏洞信息

25842
WebCalendar index.php includedir Function Remote File Inclusion
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

WebCalendar contains a flaw that may allow a remote attacker to execute arbitrary commands. The issue is due to includes/config.php not properly sanitizing user input supplied to the 'includedir' variable. This may allow an attacker to include a file from a remote host that contains arbitrary commands which will be executed by the vulnerable script. This can be exploited further to disclose the content of arbitrary files by including a malicious settings.php file which overwrites the "user_inc" variable and will allow arbitrary local file disclosure.

- 时间线

2006-05-30 Unknow
2006-05-30 Unknow

- 解决方案

Upgrade to version 1.0.4 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

- 漏洞信息

WebCalendar Index.PHP Information Disclosure Vulnerability
Input Validation Error 18175
Yes No
2006-05-31 12:00:00 2006-06-13 05:21:00
socsam@linuxmail.org is credited with the discovery of this vulnerability.

- 受影响的程序版本

k5n WebCalendar 1.0.3
k5n WebCalendar 1.0.2
k5n WebCalendar 1.0.1
k5n WebCalendar 1.0 RC3
k5n WebCalendar 1.0 rc2
k5n WebCalendar 1.0 RC1
k5n WebCalendar 1.0
k5n WebCalendar 0.9.45
- Debian Linux 3.1 sparc
- Debian Linux 3.1 s/390
- Debian Linux 3.1 s/390
- Debian Linux 3.1 ppc
- Debian Linux 3.1 ppc
- Debian Linux 3.1 mipsel
- Debian Linux 3.1 mipsel
- Debian Linux 3.1 mips
- Debian Linux 3.1 mips
- Debian Linux 3.1 m68k
- Debian Linux 3.1 m68k
- Debian Linux 3.1 ia-64
- Debian Linux 3.1 ia-64
- Debian Linux 3.1 ia-32
- Debian Linux 3.1 ia-32
- Debian Linux 3.1 hppa
- Debian Linux 3.1 hppa
- Debian Linux 3.1 arm
- Debian Linux 3.1 arm
- Debian Linux 3.1 alpha
- Debian Linux 3.1 alpha
- Debian Linux 3.1
- Debian Linux 3.1
Debian Linux 3.1 sparc
Debian Linux 3.1 s/390
Debian Linux 3.1 ppc
Debian Linux 3.1 mipsel
Debian Linux 3.1 mips
Debian Linux 3.1 m68k
Debian Linux 3.1 ia-64
Debian Linux 3.1 ia-32
Debian Linux 3.1 hppa
Debian Linux 3.1 arm
Debian Linux 3.1 amd64
Debian Linux 3.1 alpha
Debian Linux 3.1
k5n WebCalendar 1.0.4

- 不受影响的程序版本

k5n WebCalendar 1.0.4

- 漏洞讨论

WebCalendar is prone to an information-disclosure vulnerability. This issue is due to a failure in the application to properly sanitize user-supplied input.

An attacker can exploit this vulnerability to retrieve the contents of arbitrary files from the vulnerable system in the context of the affected application. Information obtained may aid attackers in further attacks.

WebCalendar version 1.0.3 is vulnerable; other versions may be affected.

- 漏洞利用

This vulnerability may be exploited with a web client.

- 解决方案

The vendor has released version 1.0.4 to address this issue.

Please see the referenced vendor advisories for further information.


k5n WebCalendar 1.0

k5n WebCalendar 1.0 RC3

k5n WebCalendar 1.0 RC1

k5n WebCalendar 1.0 rc2

k5n WebCalendar 1.0.1

k5n WebCalendar 1.0.2

k5n WebCalendar 1.0.3

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站