发布时间 :2006-06-01 06:02:00
修订时间 :2008-09-05 17:05:20

[原文]SQL injection vulnerability in the do_mysql_query function in core.php for Open Searchable Image Catalogue (OSIC) before allows remote attackers to inject arbitrary SQL commands via multiple vectors, as demonstrated by the (1) type parameter in adminfunctions.php and the (2) catalogue_id parameter in editcatalogue.php.

[CNNVD]Open Searchable Image Catalogue core.php do_mysql_query函数 SQL注入漏洞(CNNVD-200606-042)

        Open Searchable Image Catalogue (OSIC)的core.php中的do_mysql_query函数存在SQL注入漏洞,远程攻击者可通过多个向量来注入任意SQL命令,如使用在adminfunctions.php中的(1)type参数和在editcatalogue.php中的(2)catalogue_id参数。

- CVSS (基础分值)

CVSS分值: 6.4 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(UNKNOWN)  BID  18169
(UNKNOWN)  BUGTRAQ  20060530 Open Searchable Image Catalogue: XSS and SQL Injection Vulnerabilities
(UNKNOWN)  XF  osic-adminfunctions-editcatalogue-sql-inj(26968)

- 漏洞信息

Open Searchable Image Catalogue core.php do_mysql_query函数 SQL注入漏洞
中危 SQL注入
2006-06-01 00:00:00 2006-06-01 00:00:00
        Open Searchable Image Catalogue (OSIC)的core.php中的do_mysql_query函数存在SQL注入漏洞,远程攻击者可通过多个向量来注入任意SQL命令,如使用在adminfunctions.php中的(1)type参数和在editcatalogue.php中的(2)catalogue_id参数。

- 公告与补丁

        Open Searchable Image Catalogue OSIC 0.7
        Open Searchable Image Catalogue osic-

- 漏洞信息

Open Searchable Image Catalogue core.php do_mysql_query Function SQL Injection
Remote / Network Access Information Disclosure, Input Manipulation
Loss of Confidentiality, Loss of Integrity

- 漏洞描述

Open Searchable Image Catalogue contains a flaw that may allow an attacker to carry out an SQL injection attack. The issue is due to the core.php script not properly sanitizing user-supplied input to the do_mysql_query function. This function is used in many scripts and can be exploited via the 'type' parameter in adminfunctions.php and the 'catalogue_id' parameter in editcatalogue.php. This may allow an attacker to inject or manipulate SQL queries in the back-end database.

- 时间线

2006-05-30 Unknow
Unknow Unknow

- 解决方案

Upgrade to version or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者