CVE-2006-2742
CVSS7.5
发布时间 :2006-06-01 06:02:00
修订时间 :2011-03-07 21:36:56
NMCOP    

[原文]SQL injection vulnerability in Drupal 4.6.x before 4.6.7 and 4.7.0 allows remote attackers to execute arbitrary SQL commands via the (1) count and (2) from variables to (a) database.mysql.inc, (b) database.pgsql.inc, and (c) database.mysqli.inc.


[CNNVD]Drupal 多个SQL注入漏洞(CNNVD-200606-005)

        Drupal 4.6.x的4.6.7之前和4.7.0版本存在SQL注入漏洞,远程攻击者可通过传给(a)database.mysql.inc,(b)database.pgsql.inc和(c)database.mysqli.inc的(1)count和(2)from变量来执行任意SQL命令。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:drupal:drupal:4.6.6
cpe:/a:drupal:drupal:4.6.0
cpe:/a:drupal:drupal:4.6.1
cpe:/a:drupal:drupal:4.6.3
cpe:/a:drupal:drupal:4.7.0
cpe:/a:drupal:drupal:4.6
cpe:/a:drupal:drupal:4.6.5
cpe:/a:drupal:drupal:4.6.2
cpe:/a:drupal:drupal:4.6.4

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-2742
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-2742
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200606-005
(官方数据源) CNNVD

- 其它链接及资源

http://xforce.iss.net/xforce/xfdb/26654
(PATCH)  XF  drupal-database-sql-injection(26654)
http://secunia.com/advisories/20140
(VENDOR_ADVISORY)  SECUNIA  20140
http://drupal.org/node/65357
(VENDOR_ADVISORY)  CONFIRM  http://drupal.org/node/65357
http://www.vupen.com/english/advisories/2006/1975
(UNKNOWN)  VUPEN  ADV-2006-1975
http://www.securityfocus.com/bid/18245
(UNKNOWN)  BID  18245
http://www.securityfocus.com/archive/1/archive/1/435790/100/0/threaded
(UNKNOWN)  BUGTRAQ  20060602 [DRUPAL-SA-2006-005] Drupal 4.6.7 / 4.7.1 fixes SQL injection issue
http://www.debian.org/security/2006/dsa-1125
(UNKNOWN)  DEBIAN  DSA-1125
http://secunia.com/advisories/21244
(UNKNOWN)  SECUNIA  21244

- 漏洞信息

Drupal 多个SQL注入漏洞
高危 SQL注入
2006-06-01 00:00:00 2006-06-01 00:00:00
远程  
        Drupal 4.6.x的4.6.7之前和4.7.0版本存在SQL注入漏洞,远程攻击者可通过传给(a)database.mysql.inc,(b)database.pgsql.inc和(c)database.mysqli.inc的(1)count和(2)from变量来执行任意SQL命令。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复这个安全问题,补丁下载链接:
        Drupal Drupal 4.5.3
        Debian drupal_4.5.3-6.1sarge1_all.debDebian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/d/drupal/drupal_4.5.3-6.1
        sarge1_all.deb

- 漏洞信息 (F48640)

Debian Linux Security Advisory 1125-1 (PacketStormID:F48640)
2006-07-28 00:00:00
Debian  debian.org
advisory,remote,web,arbitrary,vulnerability
linux,debian
CVE-2006-2742,CVE-2006-2743,CVE-2006-2831,CVE-2006-2832,CVE-2006-2833
[点击下载]

Debian Security Advisory 1125-1 - Several remote vulnerabilities have been discovered in the Drupal web site platform, which may lead to the execution of arbitrary web scripts.

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

- --------------------------------------------------------------------------
Debian Security Advisory DSA 1125-1                    security@debian.org
http://www.debian.org/security/                         Moritz Muehlenhoff
July 26th, 2006                         http://www.debian.org/security/faq
- --------------------------------------------------------------------------

Package        : drupal
Vulnerability  : several
Problem-Type   : remote
Debian-specific: no
CVE ID         : CVE-2006-2742 CVE-2006-2743 CVE-2006-2831 CVE-2006-2832 CVE-2006-2833
Debian Bug     : 368835

Several remote vulnerabilities have been discovered in the Drupal web site
platform, which may lead to the execution of arbitrary web script. The
Common Vulnerabilities and Exposures project identifies the following
problems:

CVE-2006-2742

    A SQL injection vulnerability has been discovered in the "count" and
    "from" variables of the database interface.

CVE-2006-2743

    Multiple file extensions were handled incorrectly if Drupal ran on
    Apache with mod_mime enabled.

CVE-2006-2831

    A variation of CVE-2006-2743 was adressed as well.

CVE-2006-2832

    A Cross-Site-Scripting vulnerability in the upload module has been
    discovered.

CVE-2006-2833

    A Cross-Site-Scripting vulnerability in the taxonomy module has been
    discovered.

For the stable distribution (sarge) these problems have been fixed in
version 4.5.3-6.1sarge1.

For the unstable distribution (sid) these problems have been fixed in
version 4.5.8-1.1.

We recommend that you upgrade your drupal packages.


Upgrade Instructions
- --------------------

wget url
        will fetch the file for you
dpkg -i file.deb
        will install the referenced file.

If you are using the apt-get package manager, use the line for
sources.list as given below:

apt-get update
        will update the internal database
apt-get upgrade
        will install corrected packages

You may use an automated update by adding the resources from the
footer to the proper configuration.


Debian GNU/Linux 3.1 alias sarge
- --------------------------------

  Source archives:

    http://security.debian.org/pool/updates/main/d/drupal/drupal_4.5.3-6.1sarge1.dsc
      Size/MD5 checksum:      625 8323ad6164c5beb6e9c7631272fbaee8
    http://security.debian.org/pool/updates/main/d/drupal/drupal_4.5.3-6.1sarge1.diff.gz
      Size/MD5 checksum:    83802 35863480a9da96adbe6731b014d204c8
    http://security.debian.org/pool/updates/main/d/drupal/drupal_4.5.3.orig.tar.gz
      Size/MD5 checksum:   471540 bf093c4c8aca7bba62833ea1df35702f

  Architecture independent components:

    http://security.debian.org/pool/updates/main/d/drupal/drupal_4.5.3-6.1sarge1_all.deb
      Size/MD5 checksum:   506884 e4cdba2730662752d8f83fc101ab58a5


  These files will probably be moved into the stable distribution on
  its next update.

- ---------------------------------------------------------------------------------
For apt-get: deb http://security.debian.org/ stable/updates main
For dpkg-ftp: ftp://security.debian.org/debian-security dists/stable/updates/main
Mailing list: debian-security-announce@lists.debian.org
Package info: `apt-cache show <pkg>' and http://packages.debian.org/<pkg>
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.3 (GNU/Linux)

iD8DBQFEx9wrXm3vHE4uyloRAsWtAKDoQf4DhL4eqpPLmDuifZ/Rh4h61gCggvrQ
zwceOEHQ/r/GyRU2L5X9vd8=
=V7nw
-----END PGP SIGNATURE-----

    

- 漏洞信息

25908
Drupal database.mysql.inc Multiple Parameter SQL Injection
Remote / Network Access Information Disclosure, Input Manipulation
Loss of Confidentiality, Loss of Integrity

- 漏洞描述

Unknown or Incomplete

- 时间线

2006-05-18 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 4.6.7, 4.7.1 or higher, as it has been reported to fix this vulnerability. In addition, Drupal has released a patch for some older versions.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站