CVE-2006-2693
CVSS7.1
发布时间 :2006-05-31 06:06:00
修订时间 :2011-03-07 21:36:47
NMCO    

[原文]Directory traversal vulnerability in admin/admin_hacks_list.php in Nivisec Hacks List 1.20 and earlier for phpBB, when register_globals is enabled, allows remote attackers to read arbitrary files via a ".." in the phpEx parameter.


[CNNVD]phpBB Nivisec Hacks List模块 目录遍历漏洞(CNNVD-200605-574)

        phpBB是一种用PHP语言实现的基于Web的开放源码论坛程序,使用较为广泛。它支持多种数据库作为后端,如Oracle、MSSQL、MySql、PostGres等等。
        phpBB的实现上存在输入验证漏洞,远程攻击者可能利用此漏洞读取系统文件造成信息泄露。
        phpBB的admin/admin_hacks_list.php文件中没有正确过滤phpEx变量,允许远程攻击者向phpBB.board_config[default_lang]包含任意本地文件。漏洞代码在admin_hacks_list.php的30-37行:
        30: if( !empty($setmodules) )
        31: {
        32: include($phpbb_root_path . 'language/lang_' .
        $board_config['default_lang'] . '/lang_admin_hacks_list.' . $phpEx);
        33: $filename = basename(__FILE__);
        34: $module['General']['Hacks_List'] = $filename;
        35:
        36: return;
        37: }
        
        

- CVSS (基础分值)

CVSS分值: 7.1 [严重(HIGH)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: NONE [不会对系统完整性产生影响]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: NETWORK [攻击者不需要获取内网访问权或本地访问权]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-2693
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-2693
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200605-574
(官方数据源) CNNVD

- 其它链接及资源

http://www.vupen.com/english/advisories/2006/2034
(UNKNOWN)  VUPEN  ADV-2006-2034
http://www.securityfocus.com/bid/18162
(UNKNOWN)  BID  18162
http://www.securityfocus.com/archive/1/archive/1/435285/100/0/threaded
(UNKNOWN)  BUGTRAQ  20060528 Advisory: phpBB 2.x (admin/admin_hacks_list.php) Local InclusionVulnerability.
http://www.nukedx.com/?viewdoc=37
(VENDOR_ADVISORY)  MISC  http://www.nukedx.com/?viewdoc=37
http://www.nivisec.com/article.php?l=vi&ar=15
(UNKNOWN)  CONFIRM  http://www.nivisec.com/article.php?l=vi&ar=15
http://secunia.com/advisories/20359
(VENDOR_ADVISORY)  SECUNIA  20359
http://xforce.iss.net/xforce/xfdb/26840
(UNKNOWN)  XF  nivisechackslist-phpex-file-include(26840)

- 漏洞信息

phpBB Nivisec Hacks List模块 目录遍历漏洞
高危 路径遍历
2006-05-31 00:00:00 2006-12-06 00:00:00
远程  
        phpBB是一种用PHP语言实现的基于Web的开放源码论坛程序,使用较为广泛。它支持多种数据库作为后端,如Oracle、MSSQL、MySql、PostGres等等。
        phpBB的实现上存在输入验证漏洞,远程攻击者可能利用此漏洞读取系统文件造成信息泄露。
        phpBB的admin/admin_hacks_list.php文件中没有正确过滤phpEx变量,允许远程攻击者向phpBB.board_config[default_lang]包含任意本地文件。漏洞代码在admin_hacks_list.php的30-37行:
        30: if( !empty($setmodules) )
        31: {
        32: include($phpbb_root_path . 'language/lang_' .
        $board_config['default_lang'] . '/lang_admin_hacks_list.' . $phpEx);
        33: $filename = basename(__FILE__);
        34: $module['General']['Hacks_List'] = $filename;
        35:
        36: return;
        37: }
        
        

- 公告与补丁

        目前厂商还没有提供补丁或者升级程序,建议使用此软件的用户随时关注厂商的主页以获取最新版本:
        http://www.phpbb.com/

- 漏洞信息

25822
Nivisec Hacks List for phpBB admin_hacks_list.php phpEx Parameter Traversal Arbitrary File Access
Remote / Network Access Input Manipulation

- 漏洞描述

Unknown or Incomplete

- 时间线

2006-05-28 Unknow
2006-05-28 Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站