CVE-2006-2688
CVSS6.4
发布时间 :2006-05-31 06:06:00
修订时间 :2011-03-07 21:36:46
NMCO    

[原文]SQL injection vulnerability in the employees node (class.employee.inc) in Achievo 1.1.0 and earlier and 1.2 and earlier allows remote attackers to execute arbitrary SQL commands via the atkselector parameter.


[CNNVD]Achievo Class.employee.inc SQL注入漏洞(CNNVD-200605-556)

        Achievo 1.1.0中的employees节点(class.employee.inc)存在SQL注入漏洞。远程攻击者可以借助atkselector 参数执行任意SQL指令。

- CVSS (基础分值)

CVSS分值: 6.4 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:achievo:achievo:1.2.0
cpe:/a:achievo:achievo:1.1.0

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-2688
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-2688
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200605-556
(官方数据源) CNNVD

- 其它链接及资源

http://www.achievo.org/download/releasenotes/1_2_1
(PATCH)  CONFIRM  http://www.achievo.org/download/releasenotes/1_2_1
http://secunia.com/advisories/20327
(VENDOR_ADVISORY)  SECUNIA  20327
http://www.vupen.com/english/advisories/2006/2053
(UNKNOWN)  VUPEN  ADV-2006-2053
http://bugzilla.achievo.org/show_bug.cgi?id=624
(UNKNOWN)  CONFIRM  http://bugzilla.achievo.org/show_bug.cgi?id=624
http://xforce.iss.net/xforce/xfdb/26755
(UNKNOWN)  XF  achievo-atkselector-sql-injection(26755)
http://www.securityfocus.com/bid/18171
(UNKNOWN)  BID  18171
http://www.osvdb.org/25811
(UNKNOWN)  OSVDB  25811

- 漏洞信息

Achievo Class.employee.inc SQL注入漏洞
中危 SQL注入
2006-05-31 00:00:00 2006-05-31 00:00:00
远程  
        Achievo 1.1.0中的employees节点(class.employee.inc)存在SQL注入漏洞。远程攻击者可以借助atkselector 参数执行任意SQL指令。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复这个安全问题,补丁下载链接:
        Achievo Achievo 1.2
        Achievo achievo-stable-1.2.1.tar.gz
        http://www.achievo.org/files/achievo-stable-1.2.1.tar.gz
        Achievo Achievo 1.1
        Achievo achievo-stable-1.2.1.tar.gz
        http://www.achievo.org/files/achievo-stable-1.2.1.tar.gz

- 漏洞信息

25811
Achievo class.employee.inc atkselector Parameter SQL Injection
Remote / Network Access Information Disclosure, Input Manipulation
Loss of Confidentiality, Loss of Integrity
Exploit Unknown Vendor Verified

- 漏洞描述

Achievo contains a flaw that may allow an attacker to carry out an SQL injection attack. The issue is due to the class.employee.inc script not properly sanitizing user-supplied input to the 'atkselector' variable. This may allow an attacker to inject or manipulate SQL queries in the back-end database.

- 时间线

2006-05-29 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 1.2.1 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站