CVE-2006-2675
CVSS5.1
发布时间 :2006-05-30 17:02:00
修订时间 :2008-09-10 16:19:06
NMCO    

[原文]PHP remote file inclusion vulnerability in ubbt.inc.php in UBBThreads 5.x and 6.x allows remote attackers to execute arbitrary PHP code via a URL in the (1) thispath or (2) configdir parameters.


[CNNVD]UBBThreads ubbt.inc.php 多个文件包含漏洞(CNNVD-200605-534)

        UBB.threads是一款由PHP编写的WEB论坛应用程序,支持多种数据库系统,可使用在多种Unix和Linux操作系统下。
        UBB.threads对用户请求的处理上存在输入验证漏洞,远程攻击者可能利用此漏洞注入PHP代码,在服务器上以Web进程权限执行任意命令。
        UBB.threads的addpost_newpoll.php脚本没有对thispath变量值做充分的过滤检查,远程攻击者可能利用漏洞变星值插入" http:// "这样的远程引用字串,使服务器包含远程服务器上的PHP脚本代码进行执行,从而以Web进程权限在系统上执行任意命令。

- CVSS (基础分值)

CVSS分值: 5.1 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: HIGH [漏洞利用存在特定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:ubbcentral:ubb.threads:6.2
cpe:/a:ubbcentral:ubb.threads:6.1
cpe:/a:ubbcentral:ubb.threads:6.2.2
cpe:/a:ubbcentral:ubb.threads:6.4.3
cpe:/a:ubbcentral:ubb.threads:6.3
cpe:/a:ubbcentral:ubb.threads:6.5.3
cpe:/a:ubbcentral:ubb.threads:5.0
cpe:/a:ubbcentral:ubb.threads:6.4.4
cpe:/a:ubbcentral:ubb.threads:6.5.1.1
cpe:/a:ubbcentral:ubb.threads:5.5.1
cpe:/a:ubbcentral:ubb.threads:6.5.1
cpe:/a:ubbcentral:ubb.threads:6.4
cpe:/a:ubbcentral:ubb.threads:6.5.2_beta2
cpe:/a:ubbcentral:ubb.threads:6.5.2
cpe:/a:ubbcentral:ubb.threads:6.2.3
cpe:/a:ubbcentral:ubb.threads:3.4
cpe:/a:ubbcentral:ubb.threads:3.5
cpe:/a:ubbcentral:ubb.threads:6.0.1
cpe:/a:ubbcentral:ubb.threads:6.3.1
cpe:/a:ubbcentral:ubb.threads:6.4.2
cpe:/a:ubbcentral:ubb.threads:6.5
cpe:/a:ubbcentral:ubb.threads:6.1.1
cpe:/a:ubbcentral:ubb.threads:6.0.3
cpe:/a:ubbcentral:ubb.threads:6.0.2
cpe:/a:ubbcentral:ubb.threads:6.2.1
cpe:/a:ubbcentral:ubb.threads:6.4.1
cpe:/a:ubbcentral:ubb.threads:6.0

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-2675
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-2675
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200605-534
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/archive/1/archive/1/435288/100/0/threaded
(VENDOR_ADVISORY)  BUGTRAQ  20060528 Advisory: UBBThreads 5.x,6.x Multiple File InclusionVulnerabilities.
http://xforce.iss.net/xforce/xfdb/26866
(UNKNOWN)  XF  ubbthreads-ubbtinc-file-include(26866)
http://securityreason.com/securityalert/985
(UNKNOWN)  SREASON  985

- 漏洞信息

UBBThreads ubbt.inc.php 多个文件包含漏洞
中危 输入验证
2006-05-30 00:00:00 2006-05-31 00:00:00
远程  
        UBB.threads是一款由PHP编写的WEB论坛应用程序,支持多种数据库系统,可使用在多种Unix和Linux操作系统下。
        UBB.threads对用户请求的处理上存在输入验证漏洞,远程攻击者可能利用此漏洞注入PHP代码,在服务器上以Web进程权限执行任意命令。
        UBB.threads的addpost_newpoll.php脚本没有对thispath变量值做充分的过滤检查,远程攻击者可能利用漏洞变星值插入" http:// "这样的远程引用字串,使服务器包含远程服务器上的PHP脚本代码进行执行,从而以Web进程权限在系统上执行任意命令。

- 公告与补丁

        目前厂商还没有提供补丁或者升级程序,建议使用此软件的用户随时关注厂商的主页以获取最新版本:
        http://www.infopop.com/products/ubbthreads/index.html

- 漏洞信息

26121
UBB.threads ubbt.inc.php GLOBALS[thispath] Parameter Remote File Inclusion
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

Unknown or Incomplete

- 时间线

2006-05-27 2006-05-27
2006-05-27 Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站