发布时间 :2006-05-25 21:06:00
修订时间 :2011-03-07 21:36:35

[原文]Cross-site scripting (XSS) vulnerability in includes/Sanitizer.php in the variable handler in MediaWiki 1.6.x before r14349 allows remote attackers to inject arbitrary Javascript via unspecified vectors, possibly involving the usage of the | (pipe) character.

[CNNVD]MediaWiki variable handler Sanitizer.php 跨站脚本攻击(XSS)漏洞(CNNVD-200605-496)

        MediaWiki 的variable handler中的 includes/Sanitizer.php存在跨站脚本攻击(XSS)漏洞。远程攻击者可以借助可能与|(竖线)字符的使用有关的未明向量,注入任意Javascript。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:mediawiki:mediawiki:1.6.5MediaWiki 1.6.5

- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(PATCH)  MLIST  [Wikitech-l] 20060523 MediaWiki 1.6.5 JavaScript Execution Vulnerability # 2
(UNKNOWN)  VUPEN  ADV-2006-1926
(UNKNOWN)  MLIST  [Wikitech-l] 20060523 MediaWiki 1.6.5 JavaScript Execution Vulnerability # 2
(UNKNOWN)  XF  mediawiki-unspecified-handler-xss(26646)

- 漏洞信息

MediaWiki variable handler Sanitizer.php 跨站脚本攻击(XSS)漏洞
中危 跨站脚本
2006-05-25 00:00:00 2006-05-26 00:00:00
        MediaWiki 的variable handler中的 includes/Sanitizer.php存在跨站脚本攻击(XSS)漏洞。远程攻击者可以借助可能与|(竖线)字符的使用有关的未明向量,注入任意Javascript。

- 公告与补丁


- 漏洞信息

MediaWiki Parser Unspecified XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Unknown Vendor Verified

- 漏洞描述

MediaWiki contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate unspecified variables upon submission to unspecified script(s). This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2006-05-23 Unknow
2006-05-23 Unknow

- 解决方案

Upgrade to version 1.6.6 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者