CVE-2006-2539
CVSS3.5
发布时间 :2006-05-22 19:10:00
修订时间 :2011-03-07 21:36:28
NMCO    

[原文]Sybase EAServer 5.0 for HP-UX Itanium, 5.2 for IBM AIX, HP-UX PA-RISC, Linux x86, and Sun Solaris SPARC, and 5.3 for Sun Solaris SPARC does not properly protect passwords when they are being entered via the GUI, which allows local users to obtain the cleartext passwords via the getSelectedText function in javax.swing.JPasswordField component.


[CNNVD]Sybase EAServer JPasswordField口令 信息泄露漏洞(CNNVD-200605-419)

        Sybase EAServer是高性能、可伸缩、安全、开放的应用服务器,适用于使用多层架构的电子门户和互联商务解决方案。
        在UNIX和LINUX平台上的J2EE或Java GUI应用程序中使用口令字段时存在安全漏洞。
        1 如果用户在GUI应用程序的口令提示对话框中输入了口令但没有点击"确定"或"输入"的话,就会保持口令对话框一直打开,因此其他可以物理访问机器的用户就可以访问所输入的口令。通过远程控制软件访问机器的用户也可以访问该口令。
        2 如果GUI应用程序允许使用JPasswordField UI组件存储、检索或共享口令信息的话,则即使所存储的口令是加密的并储存在受到保护的操作系统文件中,拥有合适访问级别的用户也可以在使用相同的GUI应用程序时浏览明文口令。

- CVSS (基础分值)

CVSS分值: 3.5 [轻微(LOW)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: HIGH [漏洞利用存在特定的访问条件]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: SINGLE_INSTANCE [--]

- CPE (受影响的平台与产品)

cpe:/a:sybase:easerver:5.0Sybase EAServer 5.0
cpe:/a:sybase:easerver:5.3Sybase EAServer 5.3
cpe:/a:sybase:easerver:5.2Sybase EAServer 5.2

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-2539
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-2539
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200605-419
(官方数据源) CNNVD

- 其它链接及资源

http://www.sybase.com/detail?id=1040665
(PATCH)  CONFIRM  http://www.sybase.com/detail?id=1040665
http://www.securityfocus.com/bid/18036
(PATCH)  BID  18036
http://secunia.com/advisories/20145
(VENDOR_ADVISORY)  SECUNIA  20145
http://xforce.iss.net/xforce/xfdb/26567
(UNKNOWN)  XF  sybase-easerver-jpasswordfield-obtain-info(26567)
http://www.vupen.com/english/advisories/2006/1869
(UNKNOWN)  VUPEN  ADV-2006-1869

- 漏洞信息

Sybase EAServer JPasswordField口令 信息泄露漏洞
低危 访问验证错误
2006-05-22 00:00:00 2007-06-26 00:00:00
本地  
        Sybase EAServer是高性能、可伸缩、安全、开放的应用服务器,适用于使用多层架构的电子门户和互联商务解决方案。
        在UNIX和LINUX平台上的J2EE或Java GUI应用程序中使用口令字段时存在安全漏洞。
        1 如果用户在GUI应用程序的口令提示对话框中输入了口令但没有点击"确定"或"输入"的话,就会保持口令对话框一直打开,因此其他可以物理访问机器的用户就可以访问所输入的口令。通过远程控制软件访问机器的用户也可以访问该口令。
        2 如果GUI应用程序允许使用JPasswordField UI组件存储、检索或共享口令信息的话,则即使所存储的口令是加密的并储存在受到保护的操作系统文件中,拥有合适访问级别的用户也可以在使用相同的GUI应用程序时浏览明文口令。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复这个安全问题,补丁下载链接:
        http://downloads.sybase.com/

- 漏洞信息

25661
Sybase EAServer javax.swing.JPasswordField Password Disclosure
Vendor Verified

- 漏洞描述

Unknown or Incomplete

- 时间线

2006-05-18 Unknow
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站