发布时间 :2006-05-22 18:02:00
修订时间 :2008-09-05 17:04:47

[原文]PHP remote file inclusion vulnerability in classified_right.php in phpBazar 2.1.0 and earlier allows remote attackers to execute arbitrary PHP code via a URL in the language_dir parameter.

[CNNVD]phpBazar classified_right.php 远程文件包含漏洞(CNNVD-200605-420)


- CVSS (基础分值)

CVSS分值: 6.4 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(UNKNOWN)  BID  18052
(UNKNOWN)  BUGTRAQ  20060520 phpBazar <= 2.1.0 Multiple vulnerabilites
(UNKNOWN)  XF  phpbazar-classifiedright-file-include(26618)

- 漏洞信息

phpBazar classified_right.php 远程文件包含漏洞
中危 输入验证
2006-05-22 00:00:00 2006-05-23 00:00:00

- 公告与补丁


- 漏洞信息

phpBazar classified_right.php language_dir Parameter Remote File Inclusion
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

phpBazar contains a flaw that may allow a remote attacker to execute arbitrary commands. The issue is due to classified_right.php not properly sanitizing user input supplied to the 'language_dir' variable. This may allow an attacker to include a file from a remote host that contains arbitrary commands which will be executed by the vulnerable script.

- 时间线

2006-05-20 Unknow
2006-05-20 Unknow

- 解决方案

Currently, there are no known upgrades, patches, or workarounds available to correct this issue.

- 相关参考

- 漏洞作者

- 漏洞信息

PHPBazar Classified_right.PHP Remote File Include Vulnerability
Input Validation Error 18052
Yes No
2006-05-20 12:00:00 2007-07-06 07:17:00
PHP Emperor is credited with the discovery of this vulnerability.

- 受影响的程序版本

SmartISoft phpBazar 2.1

- 漏洞讨论

phpBazar is prone to a remote file-include vulnerability. This issue is due to a failure in the application to properly sanitize user-supplied input.

An attacker can exploit this issue to include an arbitrary remote file containing malicious PHP code and execute it in the context of the webserver process. This may allow the attacker to compromise the application and the underlying system; other attacks are also possible.

- 漏洞利用

Attackers may exploit this issue through a browser.

- 解决方案

Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or if you are aware of more recent information, please mail us at:

- 相关参考