CVE-2006-2458
CVSS4.0
发布时间 :2006-05-18 19:02:00
修订时间 :2011-03-07 21:36:14
NMCOES    

[原文]Multiple heap-based buffer overflows in Libextractor 0.5.13 and earlier allow remote attackers to execute arbitrary code via (1) the asf_read_header function in the ASF plugin (plugins/asfextractor.c), and (2) the parse_trak_atom function in the QT plugin (plugins/qtextractor.c).


[CNNVD]Libextractor 本地堆溢出漏洞(CNNVD-200605-333)

        libextractor函数库允许搜索不同文件格式的元数据。
        libextractor中存在多基于堆溢出漏洞,本地攻击者可能利用此漏洞在机器上执行任意指令。
        

- CVSS (基础分值)

CVSS分值: 4 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: HIGH [漏洞利用存在特定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-2458
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-2458
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200605-333
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/18021
(PATCH)  BID  18021
http://www.securityfocus.com/archive/1/archive/1/434288/100/0/threaded
(PATCH)  BUGTRAQ  20060517 Two heap overflow in libextractor 0.5.13 (rev 2832)
http://securitytracker.com/id?1016118
(PATCH)  SECTRACK  1016118
http://secunia.com/advisories/20150
(VENDOR_ADVISORY)  SECUNIA  20150
http://www.vupen.com/english/advisories/2006/1848
(UNKNOWN)  VUPEN  ADV-2006-1848
http://xforce.iss.net/xforce/xfdb/26532
(UNKNOWN)  XF  libextractor-qtextractor-bo(26532)
http://xforce.iss.net/xforce/xfdb/26531
(UNKNOWN)  XF  libextractor-asfextractor-bo(26531)
http://www.novell.com/linux/security/advisories/2006-06-02.html
(UNKNOWN)  SUSE  SUSE-SR:2006:012
http://www.gentoo.org/security/en/glsa/glsa-200605-14.xml
(UNKNOWN)  GENTOO  GLSA-200605-14
http://www.debian.org/security/2006/dsa-1081
(UNKNOWN)  DEBIAN  DSA-1081
http://securityreason.com/securityalert/916
(UNKNOWN)  SREASON  916
http://secunia.com/advisories/20457
(UNKNOWN)  SECUNIA  20457
http://secunia.com/advisories/20326
(UNKNOWN)  SECUNIA  20326
http://secunia.com/advisories/20160
(UNKNOWN)  SECUNIA  20160
http://gnunet.org/libextractor/
(UNKNOWN)  CONFIRM  http://gnunet.org/libextractor/

- 漏洞信息

Libextractor 本地堆溢出漏洞
中危 缓冲区溢出
2006-05-18 00:00:00 2013-01-08 00:00:00
远程  
        libextractor函数库允许搜索不同文件格式的元数据。
        libextractor中存在多基于堆溢出漏洞,本地攻击者可能利用此漏洞在机器上执行任意指令。
        

- 公告与补丁

        目前厂商已经发布了升级补丁以修复这个安全问题,补丁下载链接:
        http://www.debian.org/security/2005/dsa-1081

- 漏洞信息 (1801)

libextractor <= 0.5.13 Multiple Heap Overflow PoC Exploits (EDBID:1801)
multiple dos
2006-05-17 Verified
0 Luigi Auriemma
N/A [点击下载]
# libextractor <= 0.5.13 Multiple Heap Overflow PoC Exploits

http://www.exploit-db.com/sploits/05172006-libextho.zip

# milw0rm.com [2006-05-17]
		

- 漏洞信息

25663
libextractor asfextractor asf_read_header() Function Overflow
Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

Unknown or Incomplete

- 时间线

2006-05-17 Unknow
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Libextractor Multiple Heap Buffer Overflow Vulnerabilities
Boundary Condition Error 18021
Yes No
2006-05-17 12:00:00 2006-11-28 08:20:00
Luigi Auriemma <aluigi@autistici.org> discovered these vulnerabilities.

- 受影响的程序版本

S.u.S.E. Linux Professional 10.0 OSS
S.u.S.E. Linux Professional 10.1
S.u.S.E. Linux Personal 10.0 OSS
S.u.S.E. Linux Personal 10.1
libextractor libextractor 0.5.13
Gentoo Linux
Debian Linux 3.1 sparc
Debian Linux 3.1 s/390
Debian Linux 3.1 ppc
Debian Linux 3.1 mipsel
Debian Linux 3.1 mips
Debian Linux 3.1 m68k
Debian Linux 3.1 ia-64
Debian Linux 3.1 ia-32
Debian Linux 3.1 hppa
Debian Linux 3.1 arm
Debian Linux 3.1 amd64
Debian Linux 3.1 alpha
Debian Linux 3.1
libextractor libextractor 0.5.14

- 不受影响的程序版本

libextractor libextractor 0.5.14

- 漏洞讨论

The libextractor library is affected by multiple buffer-overflow vulnerabilities. The software fails to perform sufficient boundary checks of user-supplied input before copying it to insufficiently sized memory buffers.

An attacker exploits these issues by enticing a vulnerable user to open a malformed file using an application that employs libextractor.

This issue allows attackers to execute arbitrary machine code in the context of applications that use the affected library, aiding them in the remote compromise of affected computers.

Version 0.5.13 of libextractor is vulnerable to these issues; other versions may also be affected.

- 漏洞利用

The following proof-of-concept exploit code is available:

- 解决方案

The vendor has released libextractor 0.5.14 to address these issues.

Please see the referenced vendor advisories for further information.


libextractor libextractor 0.5.13

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站