CVE-2006-2431
CVSS4.3
发布时间 :2006-05-17 06:06:00
修订时间 :2011-05-09 00:00:00
NMCOS    

[原文]Cross-site scripting (XSS) vulnerability in the 500 Internal Server Error page on the SOAP port (8880/tcp) in IBM WebSphere Application Server 5.0.2 and earlier, 5.1.x before 5.1.1.12, and 6.0.2 up to 6.0.2.7, allows remote attackers to inject arbitrary web script or HTML via the URI, which is contained in a FAULTACTOR element on this page. NOTE: some sources have reported the element as "faultfactor," but this is likely erroneous.


[CNNVD]IBM WebSphere 500 Internal Server Error 跨站脚本攻击漏洞(CNNVD-200605-313)

        IBM WebSphere Application Server 5.0.2 及之前版本, 5.1.1.12之前的5.1.x , 以及6.0.2到6.0.2.7版本的 SOAP端口(8880/tcp) 上的500 Internal Server Error 页中存在跨站脚本攻击漏洞。远程攻击者可以借助该页的FAULTACTOR元素中包含的URI,注入任意Web脚本或HTML 。注意: 某些来源称该元素为"faultfactor" ,但这很可能不正确。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: NETWORK [攻击者不需要获取内网访问权或本地访问权]
身份认证: NONE [漏洞利用无需身份认证]

- CWE (弱点类目)

CWE-79 [在Web页面生成时对输入的转义处理不恰当(跨站脚本)]

- CPE (受影响的平台与产品)

cpe:/a:ibm:websphere_application_server:5.1.0IBM WebSphere Application Server 5.1.0
cpe:/a:ibm:websphere_application_server:5.1.0.4IBM WebSphere Application Server 5.1.0.4
cpe:/a:ibm:websphere_application_server:5.0.2IBM WebSphere Application Server 5.0.2
cpe:/a:ibm:websphere_application_server:6.0.2.2IBM WebSphere Application Server 6.0.2.2
cpe:/a:ibm:websphere_application_server:6.0.2.3IBM WebSphere Application Server 6.0.2.3
cpe:/a:ibm:websphere_application_server:6.0.2.6IBM WebSphere Application Server 6.0.2.6
cpe:/a:ibm:websphere_application_server:5.1.1.1IBM WebSphere Application Server 5.1.1.1
cpe:/a:ibm:websphere_application_server:6.0.2IBM WebSphere Application Server 6.0.2
cpe:/a:ibm:websphere_application_server:5.1.0.3IBM WebSphere Application Server 5.1.0.3
cpe:/a:ibm:websphere_application_server:6.0.2.7IBM WebSphere Application Server 6.0.2.7
cpe:/a:ibm:websphere_application_server:5.1.0.5IBM WebSphere Application Server 5.1.0.5
cpe:/a:ibm:websphere_application_server:5.0.1IBM WebSphere Application Server 5.0.1
cpe:/a:ibm:websphere_application_server:5.1.0.2IBM WebSphere Application Server 5.1.0.2
cpe:/a:ibm:websphere_application_server:5.1.1.11IBM WebSphere Application Server 5.1.1.11
cpe:/a:ibm:websphere_application_server:6.0.2.1IBM WebSphere Application Server 6.0.2.1
cpe:/a:ibm:websphere_application_server:6.0.2.4IBM WebSphere Application Server 6.0.2.4
cpe:/a:ibm:websphere_application_server:5.1.1IBM WebSphere Application Server 5.1.1
cpe:/a:ibm:websphere_application_server:5.1.1.10IBM WebSphere Application Server 5.1.1.10
cpe:/a:ibm:websphere_application_server:6.0.2.5IBM WebSphere Application Server 6.0.2.5
cpe:/a:ibm:websphere_application_server:5.0.0IBM WebSphere Application Server 5.0.0

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-2431
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-2431
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200605-313
(官方数据源) CNNVD

- 其它链接及资源

http://www-1.ibm.com/support/search.wss?rs=0&q=PK16602&apar=only
(PATCH)  AIXAPAR  PK16602
http://www-1.ibm.com/support/docview.wss?rs=180&uid=swg24012163
(PATCH)  CONFIRM  http://www-1.ibm.com/support/docview.wss?rs=180&uid=swg24012163
http://www-1.ibm.com/support/docview.wss?rs=180&uid=swg24012064
(PATCH)  CONFIRM  http://www-1.ibm.com/support/docview.wss?rs=180&uid=swg24012064
http://www-1.ibm.com/support/docview.wss?rs=0&dc=DB550&q1=PK16492&uid=swg1PK22416&loc=en_US&cs=utf-8&lang=
(PATCH)  AIXAPAR  PK22416
http://secunia.com/advisories/20032
(VENDOR_ADVISORY)  SECUNIA  20032
http://archives.neohapsis.com/archives/bugtraq/2006-05/0175.html
(PATCH)  BUGTRAQ  20060509 IBM Websphere Application Server Multiple Vulnerabilities
http://xforce.iss.net/xforce/xfdb/30055
(UNKNOWN)  XF  websphere-faultfactor-xss(30055)
http://www.vupen.com/english/advisories/2006/1736
(VENDOR_ADVISORY)  VUPEN  ADV-2006-1736
http://www.securityfocus.com/bid/21018
(UNKNOWN)  BID  21018
http://www.securityfocus.com/archive/1/archive/1/450704/100/0/threaded
(UNKNOWN)  BUGTRAQ  20061106 Cross Site Scripting (XSS) Vulnerability in IBM WebSphere Application Server
http://www.osvdb.org/25371
(UNKNOWN)  OSVDB  25371
http://www.niscc.gov.uk/niscc/docs/re-20061031-00727.pdf?lang=en
(UNKNOWN)  MISC  http://www.niscc.gov.uk/niscc/docs/re-20061031-00727.pdf?lang=en
http://www.attrition.org/pipermail/vim/2006-November/001112.html
(UNKNOWN)  VIM  20061107 Minimizing error cascades in vulnerability information management
http://www-1.ibm.com/support/search.wss?rs=0&q=PK26181&apar=only
(UNKNOWN)  AIXAPAR  PK26181
http://securitytracker.com/id?1017170
(UNKNOWN)  SECTRACK  1017170
http://securityreason.com/securityalert/910
(UNKNOWN)  SREASON  910

- 漏洞信息

IBM WebSphere 500 Internal Server Error 跨站脚本攻击漏洞
中危 跨站脚本
2006-05-17 00:00:00 2007-04-09 00:00:00
远程  
        IBM WebSphere Application Server 5.0.2 及之前版本, 5.1.1.12之前的5.1.x , 以及6.0.2到6.0.2.7版本的 SOAP端口(8880/tcp) 上的500 Internal Server Error 页中存在跨站脚本攻击漏洞。远程攻击者可以借助该页的FAULTACTOR元素中包含的URI,注入任意Web脚本或HTML 。注意: 某些来源称该元素为"faultfactor" ,但这很可能不正确。

- 公告与补丁

        暂无数据

- 漏洞信息

30944
IBM WebSphere Application Server (WAS) SOAP Port Error Message XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Vendor Verified

- 漏洞描述

- 时间线

2006-05-10 Unknow
Unknow Unknow

- 解决方案

Products

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

IBM WebSphere Faultactor Cross-Site Scripting Vulnerability
Input Validation Error 21018
Yes No
2006-11-13 12:00:00 2007-12-18 08:06:00
Nuri Fattah of ProCheckUp Ltd. is credited with the discovery of this vulnerability.

- 受影响的程序版本

IBM Websphere Application Server 6.0

- 漏洞讨论

IBM WebSphere is prone to a cross-site scripting vulnerability because it fails to properly sanitize user-supplied input.

An attacker may leverage this issue to have arbitrary script code execute in the browser of an unsuspecting user in the context of the affected site. This may help the attacker steal cookie-based authentication credentials and launch other attacks.

WebSphere Application Server 6 is vulnerable; other versions may also be affected.

- 漏洞利用

To exploit this issue, an attacker must entice an unsuspecting victim into following a malicious URI.

The following proof of concept is available:

GET /<SCRIPT>alert('Can%20Cross%20Site%20Attack')</SCRIPT> HTTP/1.1

- 解决方案

The vendor has released a patch that addresses this issue. Please see the vendor references for additional information.

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站