CVE-2006-2420
CVSS4.3
发布时间 :2006-05-16 06:02:00
修订时间 :2016-10-17 23:39:54
NMCO    

[原文]Bugzilla 2.20rc1 through 2.20 and 2.21.1, when using RSS 1.0, allows remote attackers to conduct cross-site scripting (XSS) attacks via a title element with HTML encoded sequences such as ">", which are automatically decoded by some RSS readers. NOTE: this issue is not in Bugzilla itself, but rather due to design or documentation inconsistencies within RSS, or implementation vulnerabilities in RSS readers. While this issue normally would not be included in CVE, it is being identified since the Bugzilla developers have addressed it.


[CNNVD]Bugzilla RSS阅读器 跨站脚本(XSS) 攻击(CNNVD-200605-306)

        Bugzilla 2.20rc1到2.20 和 2.21.1在使用RSS 1.0时,可以使远程攻击者借助带有HTML编码的">"等序列的,可由某些RSS阅读器自动解码的标题元素,进行跨站脚本(XSS) 攻击。注意:此问题不在于Bugzilla自身,而是由RSS内的设计或文档不一致,或RSS阅读器中的执行漏洞所致。虽然这种问题一般不纳入CVE,但由于Bugzilla开发者已经作了处理,所以对此进行了认定。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: NETWORK [攻击者不需要获取内网访问权或本地访问权]
身份认证: NONE [漏洞利用无需身份认证]

- CWE (弱点类目)

CWE-79 [在Web页面生成时对输入的转义处理不恰当(跨站脚本)]

- CPE (受影响的平台与产品)

cpe:/a:mozilla:bugzilla:2.20:rc2Mozilla Bugzilla 2.20 rc2
cpe:/a:mozilla:bugzilla:2.21.1Mozilla Bugzilla 2.21.1
cpe:/a:mozilla:bugzilla:2.20:rc1Mozilla Bugzilla 2.20 rc1
cpe:/a:mozilla:bugzilla:2.21Mozilla Bugzilla 2.21
cpe:/a:mozilla:bugzilla:2.20Mozilla Bugzilla 2.20

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-2420
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-2420
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200605-306
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=112818466125484&w=2
(UNKNOWN)  BUGTRAQ  20051001 Security Advisory for Bugzilla 2.18.3, 2.20rc2, and 2.21
http://www.bugzilla.org/security/2.18.4
(VENDOR_ADVISORY)  CONFIRM  http://www.bugzilla.org/security/2.18.4
http://xforce.iss.net/xforce/xfdb/24820
(PATCH)  XF  bugzilla-rss-title-xss(24820)
https://bugzilla.mozilla.org/show_bug.cgi?id=313441
(PATCH)  CONFIRM  https://bugzilla.mozilla.org/show_bug.cgi?id=313441

- 漏洞信息

Bugzilla RSS阅读器 跨站脚本(XSS) 攻击
中危 跨站脚本
2006-05-16 00:00:00 2007-01-24 00:00:00
远程  
        Bugzilla 2.20rc1到2.20 和 2.21.1在使用RSS 1.0时,可以使远程攻击者借助带有HTML编码的">"等序列的,可由某些RSS阅读器自动解码的标题元素,进行跨站脚本(XSS) 攻击。注意:此问题不在于Bugzilla自身,而是由RSS内的设计或文档不一致,或RSS阅读器中的执行漏洞所致。虽然这种问题一般不纳入CVE,但由于Bugzilla开发者已经作了处理,所以对此进行了认定。

- 公告与补丁

        

- 漏洞信息

23379
Bugzilla RSS Feed Title Escaped HTML Script Injection
Vendor Verified

- 漏洞描述

Unknown or Incomplete

- 时间线

2006-02-21 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 2.20.1 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站