CVE-2006-2418
CVSS6.8
发布时间 :2006-05-16 06:02:00
修订时间 :2011-03-07 21:36:10
NMCOP    

[原文]Cross-site scripting (XSS) vulnerabilities in certain versions of phpMyAdmin before 2.8.0.4 allow remote attackers to inject arbitrary web script or HTML via the db parameter in unknown scripts.


[CNNVD]phpMyAdmin 未明跨站脚本攻击(XSS)漏洞(CNNVD-200605-305)

        phpMyAdmin 2.8.0.4之前的某些版本存在跨站脚本攻击(XSS)漏洞。远程攻击者可以借助未知脚本中的db参数,注入任意Web脚本或HTML 。

- CVSS (基础分值)

CVSS分值: 6.8 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: NETWORK [攻击者不需要获取内网访问权或本地访问权]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-2418
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-2418
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200605-305
(官方数据源) CNNVD

- 其它链接及资源

http://xforce.iss.net/xforce/xfdb/26441
(PATCH)  XF  phpmyadmin-db-xss(26441)
http://www.securityfocus.com/bid/17973
(PATCH)  BID  17973
http://www.phpmyadmin.net/home_page/security.php?issue=PMASA-2006-2
(VENDOR_ADVISORY)  CONFIRM  http://www.phpmyadmin.net/home_page/security.php?issue=PMASA-2006-2
http://www.debian.org/security/2006/dsa-1207
(VENDOR_ADVISORY)  DEBIAN  DSA-1207
http://secunia.com/advisories/22781
(VENDOR_ADVISORY)  SECUNIA  22781
http://secunia.com/advisories/20627
(VENDOR_ADVISORY)  SECUNIA  20627
http://secunia.com/advisories/20113
(VENDOR_ADVISORY)  SECUNIA  20113
http://lists.suse.com/archive/suse-security-announce/2006-Jun/0003.html
(PATCH)  SUSE  SUSE-SR:2006:013
http://www.vupen.com/english/advisories/2006/1794
(UNKNOWN)  VUPEN  ADV-2006-1794

- 漏洞信息

phpMyAdmin 未明跨站脚本攻击(XSS)漏洞
中危 跨站脚本
2006-05-16 00:00:00 2007-01-05 00:00:00
远程  
        phpMyAdmin 2.8.0.4之前的某些版本存在跨站脚本攻击(XSS)漏洞。远程攻击者可以借助未知脚本中的db参数,注入任意Web脚本或HTML 。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复这个安全问题,补丁下载链接:
        phpMyAdmin phpMyAdmin 2.8 .1
        phpMyAdmin phpMyAdmin-2.8.0.4.tar.gz
        http://prdownloads.sourceforge.net/phpmyadmin/phpMyAdmin-2.8.0.4.tar.g
        z
        phpMyAdmin phpMyAdmin 2.8 .3
        phpMyAdmin phpMyAdmin-2.8.0.4.tar.gz
        http://prdownloads.sourceforge.net/phpmyadmin/phpMyAdmin-2.8.0.4.tar.g
        z

- 漏洞信息 (F52337)

Debian Linux Security Advisory 1207-2 (PacketStormID:F52337)
2006-11-20 00:00:00
Debian  debian.org
advisory
linux,debian
CVE-2006-1678,CVE-2006-2418,CVE-2005-3621,CVE-2005-3665,CVE-2006-5116
[点击下载]

Debian Security Advisory 1207-2 - The phpmyadmin update in DSA 1207 introduced a regression. This update corrects this flaw.

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

- --------------------------------------------------------------------------
Debian Security Advisory DSA 1207-2                    security@debian.org
http://www.debian.org/security/                         Moritz Muehlenhoff
November 19th, 2006                     http://www.debian.org/security/faq
- --------------------------------------------------------------------------

Package        : phpmyadmin
Vulnerability  : several
Problem-Type   : remote
Debian-specific: no
CVE ID         : CVE-2006-1678 CVE-2006-2418 CVE-2005-3621 CVE-2005-3665 CVE-2006-5116
Debian Bug     : 339437 340438 362567 368082 391090

The phpmyadmin update in DSA 1207 introduced a regression. This update
corrects this flaw. For completeness, the original advisory text below:
 
Several remote vulnerabilities have been discovered in phpMyAdmin, a
program to administrate MySQL over the web. The Common Vulnerabilities
and Exposures project identifies the following problems:

CVE-2005-3621

    CRLF injection vulnerability allows remote attackers to conduct
    HTTP response splitting attacks.

CVE-2005-3665

    Multiple cross-site scripting (XSS) vulnerabilities allow remote
    attackers to inject arbitrary web script or HTML via the (1) HTTP_HOST
    variable and (2) various scripts in the libraries directory that
    handle header generation.

CVE-2006-1678

    Multiple cross-site scripting (XSS) vulnerabilities allow remote
    attackers to inject arbitrary web script or HTML via scripts in the
    themes directory.

CVE-2006-2418

    A cross-site scripting (XSS) vulnerability allows remote attackers
    to inject arbitrary web script or HTML via the db parameter of
    footer.inc.php.

CVE-2006-5116

    A remote attacker could overwrite internal variables through the
    _FILES global variable.

For the stable distribution (sarge) these problems have been fixed in
version 2.6.2-3sarge3.

For the upcoming stable release (etch) and unstable distribution (sid)
these problems have been fixed in version 2.9.0.3-1.

We recommend that you upgrade your phpmyadmin package.

Upgrade Instructions
- --------------------

wget url
        will fetch the file for you
dpkg -i file.deb
        will install the referenced file.

If you are using the apt-get package manager, use the line for
sources.list as given below:

apt-get update
        will update the internal database
apt-get upgrade
        will install corrected packages

You may use an automated update by adding the resources from the
footer to the proper configuration.


Debian GNU/Linux 3.1 alias sarge
- --------------------------------

  Source archives:

    http://security.debian.org/pool/updates/main/p/phpmyadmin/phpmyadmin_2.6.2-3sarge3.dsc
      Size/MD5 checksum:      604 32ee16f4370604bc150d93c5676fface
    http://security.debian.org/pool/updates/main/p/phpmyadmin/phpmyadmin_2.6.2-3sarge3.diff.gz
      Size/MD5 checksum:    38520 f27c4b99bbdb3dc13fb71aef99749247
    http://security.debian.org/pool/updates/main/p/phpmyadmin/phpmyadmin_2.6.2.orig.tar.gz
      Size/MD5 checksum:  2654418 05e33121984824c43d94450af3edf267

  Architecture independent components:

    http://security.debian.org/pool/updates/main/p/phpmyadmin/phpmyadmin_2.6.2-3sarge3_all.deb
      Size/MD5 checksum:  2769182 00f14fb52a14546e92ece84c16cd249f


  These files will probably be moved into the stable distribution on
  its next update.

- ---------------------------------------------------------------------------------
For apt-get: deb http://security.debian.org/ stable/updates main
For dpkg-ftp: ftp://security.debian.org/debian-security dists/stable/updates/main
Mailing list: debian-security-announce@lists.debian.org
Package info: `apt-cache show <pkg>' and http://packages.debian.org/<pkg>
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.5 (GNU/Linux)

iD8DBQFFYFPdXm3vHE4uyloRAgj5AJ4k0NXBlTZgTK+vJTlgPNTEBfeBGgCg61oX
s2aDzIfiBIc0hbLjIGOwEcQ=
=EQpq
-----END PGP SIGNATURE-----

_______________________________________________
Full-Disclosure - We believe in it.
Charter: http://lists.grok.org.uk/full-disclosure-charter.html
Hosted and sponsored by Secunia - http://secunia.com/
    

- 漏洞信息 (F51974)

Debian Linux Security Advisory 1207-1 (PacketStormID:F51974)
2006-11-13 00:00:00
Debian  debian.org
advisory,remote,vulnerability,xss
linux,debian
CVE-2006-1678,CVE-2006-2418,CVE-2005-3621,CVE-2005-3665,CVE-2006-5116
[点击下载]

Debian Security Advisory 1207-1 - Several remote vulnerabilities have been discovered in phpMyAdmin that allow for everything from CRLF injection to cross site scripting.

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

- --------------------------------------------------------------------------
Debian Security Advisory DSA 1207-1                    security@debian.org
http://www.debian.org/security/                         Moritz Muehlenhoff
November 9th, 2006                      http://www.debian.org/security/faq
- --------------------------------------------------------------------------

Package        : phpmyadmin
Vulnerability  : several
Problem-Type   : remote
Debian-specific: no
CVE ID         : CVE-2006-1678 CVE-2006-2418 CVE-2005-3621 CVE-2005-3665 CVE-2006-5116
Debian Bug     : 339437 340438 362567 368082 391090

Several remote vulnerabilities have been discovered in phpMyAdmin, a
program to administrate MySQL over the web. The Common Vulnerabilities
and Exposures project identifies the following problems:

CVE-2005-3621

    CRLF injection vulnerability allows remote attackers to conduct
    HTTP response splitting attacks.

CVE-2005-3665

    Multiple cross-site scripting (XSS) vulnerabilities allow remote
    attackers to inject arbitrary web script or HTML via the (1) HTTP_HOST
    variable and (2) various scripts in the libraries directory that
    handle header generation.

CVE-2006-1678

    Multiple cross-site scripting (XSS) vulnerabilities allow remote
    attackers to inject arbitrary web script or HTML via scripts in the
    themes directory.

CVE-2006-2418

    A cross-site scripting (XSS) vulnerability allows remote attackers
    to inject arbitrary web script or HTML via the db parameter of
    footer.inc.php.

CVE-2006-5116

    A remote attacker could overwrite internal variables through the
    _FILES global variable.

For the stable distribution (sarge) these problems have been fixed in
version 2.6.2-3sarge2.

For the upcoming stable release (etch) and unstable distribution (sid)
these problems have been fixed in version 2.9.0.3-1.

We recommend that you upgrade your phpmyadmin package.

Upgrade Instructions
- --------------------

wget url
        will fetch the file for you
dpkg -i file.deb
        will install the referenced file.

If you are using the apt-get package manager, use the line for
sources.list as given below:

apt-get update
        will update the internal database
apt-get upgrade
        will install corrected packages

You may use an automated update by adding the resources from the
footer to the proper configuration.


Debian GNU/Linux 3.1 alias sarge
- --------------------------------

  Source archives:

    http://security.debian.org/pool/updates/main/p/phpmyadmin/phpmyadmin_2.6.2-3sarge2.dsc
      Size/MD5 checksum:      604 b650978a6bf3102a49350166d186335e
    http://security.debian.org/pool/updates/main/p/phpmyadmin/phpmyadmin_2.6.2-3sarge2.diff.gz
      Size/MD5 checksum:    37905 1d1a6528059d2e0420670e557935967b
    http://security.debian.org/pool/updates/main/p/phpmyadmin/phpmyadmin_2.6.2.orig.tar.gz
      Size/MD5 checksum:  2654418 05e33121984824c43d94450af3edf267

  Architecture independent components:

    http://security.debian.org/pool/updates/main/p/phpmyadmin/phpmyadmin_2.6.2-3sarge2_all.deb
      Size/MD5 checksum:  2768594 73c65fac24493138f7adb9fddf507d7a


  These files will probably be moved into the stable distribution on
  its next update.

- ---------------------------------------------------------------------------------
For apt-get: deb http://security.debian.org/ stable/updates main
For dpkg-ftp: ftp://security.debian.org/debian-security dists/stable/updates/main
Mailing list: debian-security-announce@lists.debian.org
Package info: `apt-cache show <pkg>' and http://packages.debian.org/<pkg>
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.5 (GNU/Linux)

iD8DBQFFU2yCXm3vHE4uyloRAvfHAJwPlDTYreoBSvD3eRnkNkbmluutpQCgmeEl
vc63gwSK1Evd77y3u8hqjkU=
=MNWJ
-----END PGP SIGNATURE-----

    

- 漏洞信息

25563
phpMyAdmin db Parameter XSS
Remote / Network Access Input Manipulation
Loss of Integrity

- 漏洞描述

Unknown or Incomplete

- 时间线

2006-05-15 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 2.8.0.4 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站