CVE-2006-2417
CVSS4.3
发布时间 :2006-05-16 06:02:00
修订时间 :2011-09-13 00:00:00
NMCOS    

[原文]Cross-site scripting (XSS) vulnerability in phpMyAdmin 2.8.0.x before 2.8.0.4 allows remote attackers to inject arbitrary web script or HTML via the theme parameter in unknown scripts. NOTE: the lang parameter is already covered by CVE-2006-2031.


[CNNVD]phpMyAdmin 多个跨站脚本攻击漏洞(CNNVD-200605-296)

        PhpMyAdmin 2.8.0.4之前的2.8.0.x 版本存在跨站脚本攻击(XSS)漏洞。远程攻击者可以借助未知脚本中的theme参数,注入任意Web脚本或HTML 。注:lang参数已在CVE-2006-2031作了说明。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CWE (弱点类目)

CWE-79 [在Web页面生成时对输入的转义处理不恰当(跨站脚本)]

- CPE (受影响的平台与产品)

cpe:/a:phpmyadmin:phpmyadmin:2.8.0.1
cpe:/a:phpmyadmin:phpmyadmin:2.8.0.3
cpe:/a:phpmyadmin:phpmyadmin:2.8.0.2

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-2417
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-2417
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200605-296
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/17973
(PATCH)  BID  17973
http://www.phpmyadmin.net/home_page/security.php?issue=PMASA-2006-2
(VENDOR_ADVISORY)  CONFIRM  http://www.phpmyadmin.net/home_page/security.php?issue=PMASA-2006-2
http://secunia.com/advisories/20113
(VENDOR_ADVISORY)  SECUNIA  20113
http://xforce.iss.net/xforce/xfdb/26444
(UNKNOWN)  XF  phpmyadmin-theme-parameter-xss(26444)
http://www.vupen.com/english/advisories/2006/1794
(VENDOR_ADVISORY)  VUPEN  ADV-2006-1794
http://secunia.com/advisories/20627
(VENDOR_ADVISORY)  SECUNIA  20627
http://lists.suse.com/archive/suse-security-announce/2006-Jun/0003.html
(UNKNOWN)  SUSE  SUSE-SR:2006:013

- 漏洞信息

phpMyAdmin 多个跨站脚本攻击漏洞
中危 跨站脚本
2006-05-16 00:00:00 2006-05-22 00:00:00
远程  
        PhpMyAdmin 2.8.0.4之前的2.8.0.x 版本存在跨站脚本攻击(XSS)漏洞。远程攻击者可以借助未知脚本中的theme参数,注入任意Web脚本或HTML 。注:lang参数已在CVE-2006-2031作了说明。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复这个安全问题,补丁下载链接:
        phpMyAdmin phpMyAdmin 2.8 .1
        phpMyAdmin phpMyAdmin-2.8.0.4.tar.gz
        http://prdownloads.sourceforge.net/phpmyadmin/phpMyAdmin-2.8.0.4.tar.g
        z
        phpMyAdmin phpMyAdmin 2.8 .3
        phpMyAdmin phpMyAdmin-2.8.0.4.tar.gz
        http://prdownloads.sourceforge.net/phpmyadmin/phpMyAdmin-2.8.0.4.tar.g
        z

- 漏洞信息

26316
phpMyAdmin theme Parameter XSS
Remote / Network Access Input Manipulation
Loss of Integrity

- 漏洞描述

Unknown or Incomplete

- 时间线

2006-05-15 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 2.8.0.4 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

phpMyAdmin Index.PHP Multiple Cross-Site Scripting Vulnerabilities
Input Validation Error 17973
Yes No
2006-05-15 12:00:00 2007-01-12 10:30:00
Sven Vetsch/Disenchant is credited with the discovery of these vulnerabilities.

- 受影响的程序版本

SuSE SUSE Linux Enterprise Server 8
+ Linux kernel 2.4.21
+ Linux kernel 2.4.19
SuSE SUSE Linux Enterprise Server 7
+ Linux kernel 2.4.19
S.u.S.E. UnitedLinux 1.0
S.u.S.E. SuSE Linux Standard Server 8.0
S.u.S.E. SuSE Linux School Server for i386
S.u.S.E. SUSE LINUX Retail Solution 8.0
S.u.S.E. SuSE Linux Openexchange Server 4.0
S.u.S.E. SuSE Linux Open-Xchange 4.1
S.u.S.E. SUSE CORE 9 for x86
S.u.S.E. Open-Enterprise-Server 9.0
S.u.S.E. Open-Enterprise-Server 1
S.u.S.E. Office Server
S.u.S.E. Novell Linux Desktop 9.0
S.u.S.E. Novell Linux Desktop 1.0
S.u.S.E. Linux Professional 10.0 OSS
S.u.S.E. Linux Professional 10.0
S.u.S.E. Linux Professional 9.3 x86_64
S.u.S.E. Linux Professional 9.3
S.u.S.E. Linux Professional 9.2 x86_64
S.u.S.E. Linux Professional 9.2
S.u.S.E. Linux Professional 9.1 x86_64
S.u.S.E. Linux Professional 9.1
S.u.S.E. Linux Professional 9.0 x86_64
S.u.S.E. Linux Professional 9.0
S.u.S.E. Linux Professional 8.2
S.u.S.E. Linux Professional 8.2
S.u.S.E. Linux Professional 7.3
S.u.S.E. Linux Professional 10.1
S.u.S.E. Linux Personal 10.0 OSS
S.u.S.E. Linux Personal 9.3 x86_64
S.u.S.E. Linux Personal 9.3
S.u.S.E. Linux Personal 9.2 x86_64
S.u.S.E. Linux Personal 9.2
S.u.S.E. Linux Personal 9.1 x86_64
S.u.S.E. Linux Personal 9.1
S.u.S.E. Linux Personal 9.0 x86_64
S.u.S.E. Linux Personal 9.0
S.u.S.E. Linux Personal 8.2
S.u.S.E. Linux Personal 10.1
S.u.S.E. Linux Openexchange Server
S.u.S.E. Linux Office Server
S.u.S.E. Linux Enterprise Server for S/390 9.0
S.u.S.E. Linux Enterprise Server for S/390
S.u.S.E. Linux Enterprise Server 9
S.u.S.E. Linux Desktop 1.0
S.u.S.E. Linux Database Server 0
S.u.S.E. Linux Connectivity Server
phpMyAdmin phpMyAdmin 2.8 .3
phpMyAdmin phpMyAdmin 2.8 .1
Debian Linux 3.1 sparc
Debian Linux 3.1 s/390
Debian Linux 3.1 ppc
Debian Linux 3.1 mipsel
Debian Linux 3.1 mips
Debian Linux 3.1 m68k
Debian Linux 3.1 ia-64
Debian Linux 3.1 ia-32
Debian Linux 3.1 hppa
Debian Linux 3.1 arm
Debian Linux 3.1 amd64
Debian Linux 3.1 alpha
Debian Linux 3.1
phpMyAdmin phpMyAdmin 2.8 .4

- 不受影响的程序版本

phpMyAdmin phpMyAdmin 2.8 .4

- 漏洞讨论

phpMyAdmin is prone to multiple cross-site scripting vulnerabilities. These issues are due to a failure in the application to properly sanitize user-supplied input.

An attacker may leverage these issues to have arbitrary script code executed in the browser of an unsuspecting user in the context of the affected site. This may help the attacker steal cookie-based authentication credentials and launch other attacks.

Versions prior to 2.8.0.4 are vulnerable; other versions may also be affected.

- 漏洞利用

These issues can be exploited through a web client.

- 解决方案

The vendor has released version 2.8.0.4 to address these issues; please see the reference section for details.


phpMyAdmin phpMyAdmin 2.8 .1

phpMyAdmin phpMyAdmin 2.8 .3

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站