CVE-2006-2327
CVSS6.4
发布时间 :2006-05-11 20:02:00
修订时间 :2011-10-11 00:00:00
NMCO    

[原文]Multiple integer overflows in the DPRPC library (DPRPCNLM.NLM) NDPS/iPrint module in Novell Distributed Print Services in Novell NetWare 6.5 SP3, SP4, and SP5 allow remote attackers to execute arbitrary code via an XDR encoded array with a field that specifies a large number of elements, which triggers the overflows in the ndps_xdr_array function.


[CNNVD]Novell NetWare Distributed 打印服务 DPRPC library NDPS/iPrint模块 整数溢出漏洞(CNNVD-200605-190)

        Novell NetWare 6.5 SP3, SP4和SP5的Novell Distributed Print Services 中的DPRPC library (DPRPCNLM.NLM) NDPS/iPrint模块存在多个整数溢出。远程攻击者可以借助一个XDR编码的数组执行任意代码。该数组含有可指定元素的大值的字段,可触发ndps_xdr_array函数的溢出。

- CVSS (基础分值)

CVSS分值: 6.4 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CWE (弱点类目)

CWE-189 [数值错误]

- CPE (受影响的平台与产品)

cpe:/o:novell:netware:6.5:sp4Novell NetWare 6.5 Service Pack 4
cpe:/o:novell:netware:6.5:sp2Novell NetWare 6.5 Service Pack 2
cpe:/o:novell:netware:6.5:sp1Novell NetWare 6.5 Service Pack 1
cpe:/o:novell:netware:6.5:sp3Novell NetWare 6.5 Service Pack 3
cpe:/o:novell:netware:6.5:sp5Novell NetWare 6.5 Service Pack 5
cpe:/o:novell:netware:6.5:sp1.1b
cpe:/o:novell:netware:6.5Novell NetWare 6.5
cpe:/o:novell:netware:6.5:sp1.1a

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-2327
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-2327
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200605-190
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/17922
(PATCH)  BID  17922
http://www.securityfocus.com/archive/1/archive/1/434017/100/0/threaded
(PATCH)  BUGTRAQ  20060515 Novell NDPS Remote Vulnerability (Server & Client)
http://www.hustlelabs.com/novell_ndps_advisory.pdf
(VENDOR_ADVISORY)  MISC  http://www.hustlelabs.com/novell_ndps_advisory.pdf
http://support.novell.com/cgi-bin/search/searchtid.cgi?/2973700.htm
(PATCH)  CONFIRM  http://support.novell.com/cgi-bin/search/searchtid.cgi?/2973700.htm
http://securitytracker.com/id?1016068
(PATCH)  SECTRACK  1016068
http://xforce.iss.net/xforce/xfdb/26314
(UNKNOWN)  XF  novell-ndps-overflow(26314)
http://www.vupen.com/english/advisories/2006/1740
(VENDOR_ADVISORY)  VUPEN  ADV-2006-1740
http://www.osvdb.org/25433
(UNKNOWN)  OSVDB  25433
http://lists.grok.org.uk/pipermail/full-disclosure/2006-May/046048.html
(UNKNOWN)  FULLDISC  20060515 Novell NDPS Remote Vulnerability (Server & Client)

- 漏洞信息

Novell NetWare Distributed 打印服务 DPRPC library NDPS/iPrint模块 整数溢出漏洞
中危 数字错误
2006-05-11 00:00:00 2006-05-25 00:00:00
远程  
        Novell NetWare 6.5 SP3, SP4和SP5的Novell Distributed Print Services 中的DPRPC library (DPRPCNLM.NLM) NDPS/iPrint模块存在多个整数溢出。远程攻击者可以借助一个XDR编码的数组执行任意代码。该数组含有可指定元素的大值的字段,可触发ndps_xdr_array函数的溢出。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复这个安全问题,补丁下载链接:
        Novell Client 4.91 SP2
        Novell 491psp2_dprpcw32.exe
        http://support.novell.com/servlet/filedownload/sec/ftf/491psp2_dprpcw3
        2.exe
        Novell Netware 6.5 SP3
        Novell dprpc_security.exe
        http://support.novell.com/servlet/filedownload/pub/dprpc_security.exe
        Novell Netware 6.5 SP5
        Novell dprpc_security.exe
        http://support.novell.com/servlet/filedownload/pub/dprpc_security.exe
        Novell Netware 6.5 SP4
        Novell dprpc_security.exe
        http://support.novell.com/servlet/filedownload/pub/dprpc_security.exe

- 漏洞信息

25433
Novell NetWare Distributed Print Services DPRPCNLM.NLM Overflow
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Unknown

- 漏洞描述

A remote overflow exists in Novell NetWare Distributed Print Services. The DPRPCNLM.NLM NDPS/iPrint module fails to properly handle malformed requests resulting in a integer overflow. With a specially crafted request, an attacker can cause the system to crash or possibly execute arbitrary code.

- 时间线

2006-05-08 Unknow
Unknow Unknow

- 解决方案

Currently, there are no known workarounds or upgrades to correct this issue. However, vendor has released a patch dprpc_security.exe to address this vulnerability.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站