CVE-2006-2307
CVSS4.3
发布时间 :2006-05-11 06:02:00
修订时间 :2011-03-07 21:35:55
NMCO    

[原文]Cross-site scripting (XSS) vulnerability in Website Baker CMS before 2.6.4 allows remote attackers to inject arbitrary web script or HTML via a user display name.


[CNNVD]W Website Baker CMS 用户显示名称 跨站脚本攻击(XSS)漏洞(CNNVD-200605-198)

         Website Baker CMS 2.6.4之前版本存在跨站脚本攻击(XSS)漏洞。远程攻击者可以借助用户显示名称,注入任意Web脚本或HTML。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:website_baker:website_baker:2.6
cpe:/a:website_baker:website_baker:2.6.1
cpe:/a:website_baker:website_baker:2.5.2

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-2307
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-2307
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200605-198
(官方数据源) CNNVD

- 其它链接及资源

http://xforce.iss.net/xforce/xfdb/26326
(PATCH)  XF  website-baker-displayname-xss(26326)
http://www.securityfocus.com/bid/17868
(PATCH)  BID  17868
http://secunia.com/advisories/20081
(VENDOR_ADVISORY)  SECUNIA  20081
http://www.vupen.com/english/advisories/2006/1840
(UNKNOWN)  VUPEN  ADV-2006-1840
http://www.securityfocus.com/archive/1/archive/1/434714/100/0/threaded
(UNKNOWN)  BUGTRAQ  20060522 Re: WebsiteBaker CMS lack of sanitizing
http://www.securityfocus.com/archive/1/archive/1/433130/100/0/threaded
(UNKNOWN)  BUGTRAQ  20060506 WebsiteBaker CMS lack of sanitizing
http://securityreason.com/securityalert/889
(UNKNOWN)  SREASON  889

- 漏洞信息

W Website Baker CMS 用户显示名称 跨站脚本攻击(XSS)漏洞
中危 跨站脚本
2006-05-11 00:00:00 2006-05-25 00:00:00
远程  
         Website Baker CMS 2.6.4之前版本存在跨站脚本攻击(XSS)漏洞。远程攻击者可以借助用户显示名称,注入任意Web脚本或HTML。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复这个安全问题,补丁下载链接:
        Website Baker Website Baker 2.5.2
        Website Baker websitebaker-2.6.4.tar.gz
        http://download.websitebaker.org/websitebaker2/stable/2.6.4/websitebak
        er-2.6.4.tar.gz/
        Website Baker Website Baker 2.6
        Website Baker websitebaker-2.6.4.tar.gz
        http://download.websitebaker.org/websitebaker2/stable/2.6.4/websitebak
        er-2.6.4.tar.gz/
        Website Baker Website Baker 2.6.1
        Website Baker websitebaker-2.6.4.tar.gz
        http://download.websitebaker.org/websitebaker2/stable/2.6.4/websitebak
        er-2.6.4.tar.gz/

- 漏洞信息

25559
Website Baker details.php display_name Parameter XSS
Remote / Network Access Input Manipulation
Loss of Integrity Upgrade
Vendor Verified

- 漏洞描述

Website Baker contains a flaw that allows a remote cross-site scripting (XSS) attack. This flaw exists because the application does not validate the 'display_name' parameter upon submission to the 'details.php' script. This may allow a user to create a specially crafted URL that would execute arbitrary script code in a user's browser within the trust relationship between their browser and the server.

- 时间线

2006-05-06 Unknow
2006-05-06 Unknow

- 解决方案

Upgrade to version 2.6.4 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站