CVE-2006-2283
CVSS7.5
发布时间 :2006-05-09 22:14:00
修订时间 :2011-03-07 21:35:52
NMCO    

[原文]Multiple PHP remote file inclusion vulnerabilities in SpiffyJr phpRaid 2.9.5 through 3.0.b3 allow remote attackers to execute arbitrary PHP code via a URL in the phpbb_root_path parameter in (1) auth.php and (2) auth_phpbb when the phpBB portal is enabled, and via a URL in the smf_root_path parameter in (3) auth.php and (4) auth_SMF when the SMF portal is enabled.


[CNNVD]SpiffyJr phpRaid 多个远程文件包含漏洞(CNNVD-200605-176)

        phpRaid是一款流行的魔兽团队管理系统。
        phpRaid实现上存在多个远程文件包含漏洞,远程攻击者可以这些漏洞使phpRaid包含恶意脚本,以Web进程权限执行命令。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:spiffyjr:phpraid:2.9.5
cpe:/a:spiffyjr:phpraid:3.0.b1
cpe:/a:spiffyjr:phpraid:3.0.b3
cpe:/a:spiffyjr:phpraid:3.0.b2

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-2283
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-2283
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200605-176
(官方数据源) CNNVD

- 其它链接及资源

http://www.vupen.com/english/advisories/2006/1726
(UNKNOWN)  VUPEN  ADV-2006-1726
http://www.securityfocus.com/bid/17875
(UNKNOWN)  BID  17875
http://www.securityfocus.com/archive/1/archive/1/433253/100/0/threaded
(UNKNOWN)  BUGTRAQ  20060508 [Kurdish Security # 5] phpRaid Remote File Include [SMF]
http://www.securityfocus.com/archive/1/archive/1/433252/100/0/threaded
(UNKNOWN)  BUGTRAQ  20060508 [Kurdish Security # 4] phpRaid Remote File Include Vulnerability (PHPBB)
http://xforce.iss.net/xforce/xfdb/26346
(UNKNOWN)  XF  phpraid-rootpath-file-include(26346)
http://www.osvdb.org/25358
(UNKNOWN)  OSVDB  25358
http://securityreason.com/securityalert/865
(UNKNOWN)  SREASON  865
http://secunia.com/advisories/20027
(UNKNOWN)  SECUNIA  20027

- 漏洞信息

SpiffyJr phpRaid 多个远程文件包含漏洞
高危 输入验证
2006-05-09 00:00:00 2006-05-10 00:00:00
远程  
        phpRaid是一款流行的魔兽团队管理系统。
        phpRaid实现上存在多个远程文件包含漏洞,远程攻击者可以这些漏洞使phpRaid包含恶意脚本,以Web进程权限执行命令。

- 公告与补丁

        目前厂商还没有提供补丁或者升级程序,建议使用此软件的用户随时关注厂商的主页以获取最新版本:
        http://www.spiffyjr.com/forums/viewtopic.php?t=9

- 漏洞信息

25358
phpRaid auth.php Multiple Parameter Remote File Inclusion
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

phpRaid contains a flaw that may allow a remote attacker to execute arbitrary commands. The issue is due to auth.php not properly sanitizing user input supplied to the 'phpbb_root_path' and 'smf_root_path' variables. This may allow an attacker to include a file from a remote host that contains arbitrary commands which will be executed by the vulnerable script.

- 时间线

2006-05-08 Unknow
2006-05-08 Unknow

- 解决方案

Upgrade to version v3.0.b4 or higher, as it has been reported to fix this vulnerability. In addition, the vendor has released a patch for some older versions.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站