发布时间 :2006-05-09 06:02:00
修订时间 :2008-09-05 17:04:02

[原文]WebCalendar 1.0.1 to 1.0.3 generates different error messages depending on whether or not a username is valid, which allows remote attackers to enumerate valid usernames.

[CNNVD]WebCalendar 出错信息 用户名枚举漏洞(CNNVD-200605-170)

        WebCalendar 1.0.1至1.0.3会根据用户名是否有效产生不同的出错信息,致使远程攻击者枚举有效的用户名。

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: NONE [不会对系统完整性产生影响]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(UNKNOWN)  BID  17853
(UNKNOWN)  BUGTRAQ  20060505 Re: WebCalendar User Account Enumeration Weakness
(UNKNOWN)  BUGTRAQ  20060504 WebCalendar User Account Enumeration Weakness
(UNKNOWN)  XF  webcalendar-user-information-disclosure(26262)

- 漏洞信息

WebCalendar 出错信息 用户名枚举漏洞
中危 设计错误
2006-05-09 00:00:00 2006-05-09 00:00:00
        WebCalendar 1.0.1至1.0.3会根据用户名是否有效产生不同的出错信息,致使远程攻击者枚举有效的用户名。

- 公告与补丁


- 漏洞信息

WebCalendar Login Error Message User Account Enumeration
Remote / Network Access Information Disclosure
Loss of Confidentiality
Exploit Public

- 漏洞描述

WebCalendar contains a flaw that may lead to an unauthorized information disclosure. The issue is triggered when invalid credentials are provided to the application. The application responds with different messages to valid and invalid user name/password combinations, allowing an attacker to enumerate valid user names and resulting in a loss of confidentiality.

- 时间线

2006-05-04 Unknow
2006-05-04 Unknow

- 解决方案

Upgrade to upcoming version 1.1, as the vendor has announced that it will fix this vulnerability. An upgrade will required as there are no known workarounds.

- 相关参考

- 漏洞作者

- 漏洞信息

WebCalendar Username Enumeration Vulnerability
Design Error 17853
Yes No
2006-05-05 12:00:00 2006-07-10 10:58:00
David Maciejak is credited with the discovery of this vulnerability.

- 受影响的程序版本

k5n WebCalendar 1.0.3
k5n WebCalendar 1.0.2
k5n WebCalendar 1.0.1
Debian Linux 3.1 sparc
Debian Linux 3.1 s/390
Debian Linux 3.1 ppc
Debian Linux 3.1 mipsel
Debian Linux 3.1 mips
Debian Linux 3.1 m68k
Debian Linux 3.1 ia-64
Debian Linux 3.1 ia-32
Debian Linux 3.1 hppa
Debian Linux 3.1 arm
Debian Linux 3.1 amd64
Debian Linux 3.1 alpha
Debian Linux 3.1

- 漏洞讨论

WebCalendar is prone to a username-enumeration vulnerability. This issue is due to a design error in the application when verifying user-supplied input.

Attackers may exploit this vulnerability to discern valid usernames. This may aid them in brute-force password cracking or other attacks.

- 漏洞利用

This issue can be exploited with a web client.

- 解决方案

Reports indicate that this issue will be addressed in the upcoming 1.1 version of the application; Symantec has not confirmed this. Please see the references for more information and vendor advisories.

Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at:

- 相关参考