CVE-2006-2223
CVSS5.0
发布时间 :2006-05-05 15:02:00
修订时间 :2011-03-31 00:00:00
NMCOPS    

[原文]RIPd in Quagga 0.98 and 0.99 before 20060503 does not properly implement configurations that (1) disable RIPv1 or (2) require plaintext or MD5 authentication, which allows remote attackers to obtain sensitive information (routing state) via REQUEST packets such as SEND UPDATE.


[CNNVD]Quagga RIPd 多个信息泄露漏洞(CNNVD-200605-100)

        Quagga 0.98和0.99 20060503之前版本中的RIPd不能正确执行(1)禁用RIPv1或(2)要求纯文本或MD5认证的配置,可以使远程攻击者借助诸如SEND UPDATE等REQUEST包获得敏感信息。

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: NONE [不会对系统完整性产生影响]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CWE (弱点类目)

CWE-20 [输入验证不恰当]

- CPE (受影响的平台与产品)

cpe:/a:quagga:quagga:0.99.3Quagga Routing Software Suite 0.99.3
cpe:/a:quagga:quagga:0.98.5Quagga Routing Software Suite 0.98.5

- OVAL (用于检测的技术细节)

oval:org.mitre.oval:def:9985RIPd in Quagga 0.98 and 0.99 before 20060503 does not properly implement configurations that (1) disable RIPv1 or (2) require plaintext or M...
*OVAL详细的描述了检测该漏洞的方法,你可以从相关的OVAL定义中找到更多检测该漏洞的技术细节。

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-2223
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-2223
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200605-100
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/17808
(PATCH)  BID  17808
http://secunia.com/advisories/19910
(VENDOR_ADVISORY)  SECUNIA  19910
http://xforce.iss.net/xforce/xfdb/26243
(UNKNOWN)  XF  quagga-ripv1-information-disclosure(26243)
http://www.ubuntulinux.org/support/documentation/usn/usn-284-1
(UNKNOWN)  UBUNTU  USN-284-1
http://www.securityfocus.com/archive/1/archive/1/432823/100/0/threaded
(UNKNOWN)  BUGTRAQ  20060503 Re: Quagga RIPD unauthenticated route injection
http://www.securityfocus.com/archive/1/archive/1/432822/100/0/threaded
(UNKNOWN)  BUGTRAQ  20060503 Quagga RIPD unauthenticated route table broadcast
http://www.redhat.com/support/errata/RHSA-2006-0533.html
(UNKNOWN)  REDHAT  RHSA-2006:0533
http://www.redhat.com/support/errata/RHSA-2006-0525.html
(UNKNOWN)  REDHAT  RHSA-2006:0525
http://www.osvdb.org/25224
(UNKNOWN)  OSVDB  25224
http://www.novell.com/linux/security/advisories/2006_17_sr.html
(UNKNOWN)  SUSE  SUSE-SR:2006:017
http://www.gentoo.org/security/en/glsa/glsa-200605-15.xml
(UNKNOWN)  GENTOO  GLSA-200605-15
http://www.debian.org/security/2006/dsa-1059
(UNKNOWN)  DEBIAN  DSA-1059
http://securitytracker.com/id?1016204
(UNKNOWN)  SECTRACK  1016204
http://secunia.com/advisories/21159
(VENDOR_ADVISORY)  SECUNIA  21159
http://secunia.com/advisories/20782
(VENDOR_ADVISORY)  SECUNIA  20782
http://secunia.com/advisories/20421
(VENDOR_ADVISORY)  SECUNIA  20421
http://secunia.com/advisories/20420
(VENDOR_ADVISORY)  SECUNIA  20420
http://secunia.com/advisories/20221
(VENDOR_ADVISORY)  SECUNIA  20221
http://secunia.com/advisories/20138
(VENDOR_ADVISORY)  SECUNIA  20138
http://secunia.com/advisories/20137
(VENDOR_ADVISORY)  SECUNIA  20137
http://bugzilla.quagga.net/show_bug.cgi?id=261
(UNKNOWN)  CONFIRM  http://bugzilla.quagga.net/show_bug.cgi?id=261
ftp://patches.sgi.com/support/free/security/advisories/20060602-01-U.asc
(UNKNOWN)  SGI  20060602-01-U

- 漏洞信息

Quagga RIPd 多个信息泄露漏洞
中危 访问验证错误
2006-05-05 00:00:00 2006-05-08 00:00:00
远程  
        Quagga 0.98和0.99 20060503之前版本中的RIPd不能正确执行(1)禁用RIPv1或(2)要求纯文本或MD5认证的配置,可以使远程攻击者借助诸如SEND UPDATE等REQUEST包获得敏感信息。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复这个安全问题,补丁下载链接:
        Quagga Quagga Routing Software Suite 0.97.3
        Ubuntu quagga-doc_0.97.3-1ubuntu1.1_all.debUbuntu 5.04 (Hoary Hedgehog)
        http://security.ubuntu.com/ubuntu/pool/main/q/quagga/quagga-doc_0.97.3
        -1ubuntu1.1_all.deb
        Ubuntu quagga_0.97.3-1ubuntu1.1_amd64.debUbuntu 5.04 (Hoary Hedgehog)
        http://security.ubuntu.com/ubuntu/pool/main/q/quagga/quagga_0.97.3-1ub
        untu1.1_amd64.deb
        Ubuntu quagga_0.97.3-1ubuntu1.1_i386.debUbuntu 5.04 (Hoary Hedgehog)
        http://security.ubuntu.com/ubuntu/pool/main/q/quagga/quagga_0.97.3-1ub
        untu1.1_i386.deb
        Ubuntu quagga_0.97.3-1ubuntu1.1_powerpc.debUbuntu 5.04 (Hoary Hedgehog)
        http://security.ubuntu.com/ubuntu/pool/main/q/quagga/quagga_0.97.3-1ub
        untu1.1_powerpc.deb
        Quagga Quagga Routing Software Suite 0.98.5
        Quagga Fixes for 0.98.x RIPd bugs 261 and 262
        http://bugzilla.quagga.net/attachment.cgi?id=84&action=view
        Quagga Quagga Routing Software Suite 0.99.3
        Quagga Fixes for 0.99.x RIPd bugs 261 and 262
        http://bugzilla.quagga.net/attachment.cgi?id=83&action=view

- 漏洞信息 (F46498)

Debian Linux Security Advisory 1059-1 (PacketStormID:F46498)
2006-05-22 00:00:00
Debian  debian.org
advisory,vulnerability
linux,debian
CVE-2006-2223,CVE-2006-2224,CVE-2006-2276
[点击下载]

Debian Security Advisory 1059-1 - Konstantin Gavrilenko discovered several vulnerabilities in quagga, the BGP/OSPF/RIP routing daemon.

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

- --------------------------------------------------------------------------
Debian Security Advisory DSA 1059-1                    security@debian.org
http://www.debian.org/security/                             Martin Schulze
May 19th, 2006                          http://www.debian.org/security/faq
- --------------------------------------------------------------------------

Package        : quagga
Vulnerability  : several
Problem type   : remote
Debian-specific: no
CVE IDs        : CVE-2006-2223 CVE-2006-2224 CVE-2006-2276
BugTraq ID     : 17808
Debian Bugs    : 365940 366980

Konstantin Gavrilenko discovered several vulnerabilities in quagga,
the BGP/OSPF/RIP routing daemon.  The Common Vulnerabilities and
Exposures project identifies the following problems:

CVE-2006-2223

    Remote attackers may obtain sensitive information via RIPv1
    REQUEST packets even if the quagga has been configured to use MD5
    authentication.

CVE-2006-2224

    Remote attackers could inject arbitrary routes using the RIPv1
    RESPONSE packet even if the quagga has been configured to use MD5
    authentication.

CVE-2006-2276

    Fredrik Widell discovered that local users are can cause a denial
    of service ia a certain sh ip bgp command entered in the telnet
    interface.

The old stable distribution (woody) does not contain quagga packages.

For the stable distribution (sarge) these problems have been fixed in
version 0.98.3-7.2.

For the unstable distribution (sid) these problems have been fixed in
version 0.99.4-1.

We recommend that you upgrade your quagga package.


Upgrade Instructions
- --------------------

wget url
        will fetch the file for you
dpkg -i file.deb
        will install the referenced file.

If you are using the apt-get package manager, use the line for
sources.list as given at the end of this advisory:

apt-get update
        will update the internal database
apt-get upgrade
        will install corrected packages

You may use an automated update by adding the resources from the
footer to the proper configuration.


Debian GNU/Linux 3.1 alias sarge
- --------------------------------

  Source archives:

    http://security.debian.org/pool/updates/main/q/quagga/quagga_0.98.3-7.2.dsc
      Size/MD5 checksum:      725 e985734e8ee31a87ff96f9c9b7291fa5
    http://security.debian.org/pool/updates/main/q/quagga/quagga_0.98.3-7.2.diff.gz
      Size/MD5 checksum:    43801 fe5b28230c268fe7ab141453a82c473c
    http://security.debian.org/pool/updates/main/q/quagga/quagga_0.98.3.orig.tar.gz
      Size/MD5 checksum:  2118348 68be5e911e4d604c0f5959338263356e

  Architecture independent components:

    http://security.debian.org/pool/updates/main/q/quagga/quagga-doc_0.98.3-7.2_all.deb
      Size/MD5 checksum:   488700 c79865480dfe140b106d39111b5379ba

  Alpha architecture:

    http://security.debian.org/pool/updates/main/q/quagga/quagga_0.98.3-7.2_alpha.deb
      Size/MD5 checksum:  1611704 c44bc78a27990ca9d77fe4529c04e42a

  AMD64 architecture:

    http://security.debian.org/pool/updates/main/q/quagga/quagga_0.98.3-7.2_amd64.deb
      Size/MD5 checksum:  1412990 7ab17ec568d3f0e2122677e81db5a2e2

  ARM architecture:

    http://security.debian.org/pool/updates/main/q/quagga/quagga_0.98.3-7.2_arm.deb
      Size/MD5 checksum:  1290442 9a5d285ffe43d8b05c470147c48357d5

  Intel IA-32 architecture:

    http://security.debian.org/pool/updates/main/q/quagga/quagga_0.98.3-7.2_i386.deb
      Size/MD5 checksum:  1191426 a0438042e1935582b66a44f17e62b40b

  Intel IA-64 architecture:

    http://security.debian.org/pool/updates/main/q/quagga/quagga_0.98.3-7.2_ia64.deb
      Size/MD5 checksum:  1829114 9e6e40afc51734c572de0f4e6e2d6519

  HP Precision architecture:

    http://security.debian.org/pool/updates/main/q/quagga/quagga_0.98.3-7.2_hppa.deb
      Size/MD5 checksum:  1447726 4f6d058646cd78f86994eee61359df22

  Motorola 680x0 architecture:

    http://security.debian.org/pool/updates/main/q/quagga/quagga_0.98.3-7.2_m68k.deb
      Size/MD5 checksum:  1159670 1438a6da0f5c0672075438df92e82695

  Big endian MIPS architecture:

    http://security.debian.org/pool/updates/main/q/quagga/quagga_0.98.3-7.2_mips.deb
      Size/MD5 checksum:  1352522 567e463657f21ec64870c1a243012b49

  Little endian MIPS architecture:

    http://security.debian.org/pool/updates/main/q/quagga/quagga_0.98.3-7.2_mipsel.deb
      Size/MD5 checksum:  1355460 3dec77ae54b897882091bb5501b349c7

  PowerPC architecture:

    http://security.debian.org/pool/updates/main/q/quagga/quagga_0.98.3-7.2_powerpc.deb
      Size/MD5 checksum:  1316776 adaa0828d830d7145236ee2f216fe46d

  IBM S/390 architecture:

    http://security.debian.org/pool/updates/main/q/quagga/quagga_0.98.3-7.2_s390.deb
      Size/MD5 checksum:  1401616 41b91f2eb90d26b1482696681552d9cb

  Sun Sparc architecture:

    http://security.debian.org/pool/updates/main/q/quagga/quagga_0.98.3-7.2_sparc.deb
      Size/MD5 checksum:  1287378 3b1624ec028e9f7944edd3fc396b0778


  These files will probably be moved into the stable distribution on
  its next update.

- ---------------------------------------------------------------------------------
For apt-get: deb http://security.debian.org/ stable/updates main
For dpkg-ftp: ftp://security.debian.org/debian-security dists/stable/updates/main
Mailing list: debian-security-announce@lists.debian.org
Package info: `apt-cache show <pkg>' and http://packages.debian.org/<pkg>

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.3 (GNU/Linux)

iD8DBQFEbehrW5ql+IAeqTIRAu1bAJ0YQwvwCvugopyXVBCit2SwrYl+SACdF09d
ELcxVZUFQP8s43SsJQ3mlqo=
=Niwk
-----END PGP SIGNATURE-----

    

- 漏洞信息

25224
Quagga RIPd RIPv1 Request Routing Table Disclosure
Remote / Network Access Information Disclosure
Loss of Confidentiality
Exploit Public Vendor Verified

- 漏洞描述

Quagga contains a flaw that may lead to an unauthorized information disclosure. The issue is triggered when a RIPv1 'SEND UPDATE' request is sent to the 'RIPd' service, even when it is configured to support RIPv2 only. This will also happen when the RIPv2-only service is configued to work with MD5 authentication. The vulnerability will disclose the service's RIP routing table, resulting in a loss of confidentiality.

- 时间线

2006-05-03 Unknow
2006-05-03 Unknow

- 解决方案

Upgrade to version 0.98 release candidate 20060504 or 0.99 release candidate 20060504, respectively, or higher, as it has been reported to fix this vulnerability. It is also possible to correct the flaw by filtering RIPv1 traffic on a need-to-access basis.

- 相关参考

- 漏洞作者

- 漏洞信息

Quagga Information Disclosure and Route Injection Vulnerabilities
Access Validation Error 17808
Yes No
2006-05-03 12:00:00 2006-11-29 09:30:00
Konstantin V. Gavrilenko discovered these vulnerabilities.

- 受影响的程序版本

Ubuntu Ubuntu Linux 5.10 powerpc
Ubuntu Ubuntu Linux 5.10 i386
Ubuntu Ubuntu Linux 5.10 amd64
Ubuntu Ubuntu Linux 5.0 4 powerpc
Ubuntu Ubuntu Linux 5.0 4 i386
Ubuntu Ubuntu Linux 5.0 4 amd64
Trustix Secure Linux 3.0
SuSE SUSE Linux Enterprise Server 10
SuSE SUSE Linux Enterprise Desktop 10
SGI ProPack 3.0 SP6
S.u.S.E. UnitedLinux 1.0
S.u.S.E. SuSE Linux Standard Server 8.0
S.u.S.E. SuSE Linux School Server for i386
S.u.S.E. SUSE LINUX Retail Solution 8.0
S.u.S.E. SuSE Linux Openexchange Server 4.0
S.u.S.E. SuSE Linux Open-Xchange 4.1
S.u.S.E. Open-Enterprise-Server 9.0
S.u.S.E. Open-Enterprise-Server 1
S.u.S.E. Office Server
S.u.S.E. Novell Linux Desktop 9.0
S.u.S.E. Novell Linux Desktop 1.0
S.u.S.E. Linux Professional 10.0 OSS
S.u.S.E. Linux Professional 10.0
S.u.S.E. Linux Professional 9.3 x86_64
S.u.S.E. Linux Professional 9.3
S.u.S.E. Linux Professional 9.2 x86_64
S.u.S.E. Linux Professional 9.2
S.u.S.E. Linux Professional 9.1 x86_64
S.u.S.E. Linux Professional 9.1
S.u.S.E. Linux Professional 10.1
S.u.S.E. Linux Personal 10.0 OSS
S.u.S.E. Linux Personal 9.3 x86_64
S.u.S.E. Linux Personal 9.3
S.u.S.E. Linux Personal 9.2 x86_64
S.u.S.E. Linux Personal 9.2
S.u.S.E. Linux Personal 9.1 x86_64
S.u.S.E. Linux Personal 9.1
S.u.S.E. Linux Personal 10.1
S.u.S.E. Linux Enterprise Server for S/390 9.0
S.u.S.E. Linux Enterprise Server for S/390
S.u.S.E. Linux Enterprise Server 9
RedHat Enterprise Linux WS 4
RedHat Enterprise Linux WS 3
RedHat Enterprise Linux ES 4
RedHat Enterprise Linux ES 3
RedHat Desktop 4.0
RedHat Desktop 3.0
RedHat Advanced Workstation for the Itanium Processor 2.1 IA64
RedHat Advanced Workstation for the Itanium Processor 2.1
Red Hat Enterprise Linux AS 4
Red Hat Enterprise Linux AS 3
Red Hat Enterprise Linux AS 2.1 IA64
Red Hat Enterprise Linux AS 2.1
Quagga Quagga Routing Software Suite 0.99.3
Quagga Quagga Routing Software Suite 0.98.5
Quagga Quagga Routing Software Suite 0.97.3
Gentoo Linux
Debian Linux 3.1 sparc
Debian Linux 3.1 s/390
Debian Linux 3.1 ppc
Debian Linux 3.1 mipsel
Debian Linux 3.1 mips
Debian Linux 3.1 m68k
Debian Linux 3.1 ia-64
Debian Linux 3.1 ia-32
Debian Linux 3.1 hppa
Debian Linux 3.1 arm
Debian Linux 3.1 amd64
Debian Linux 3.1 alpha
Debian Linux 3.1

- 漏洞讨论

Quagga is susceptible to remote information-disclosure and route-injection vulnerabilities. The application fails to properly ensure that required authentication and protocol configuration options are enforced.

These issues allow remote attackers to gain access to potentially sensitive network-routing configuration information and to inject arbitrary routes into the RIP routing table. This may aid malicious users in further attacks against targeted networks.

Quagga versions 0.98.5 and 0.99.3 are vulnerable to these issues; other versions may also be affected.

- 漏洞利用

Attackers can use existing network utilities to exploit these issues. The following commands are sufficient to demonstrate these vulnerabilities.

To exploit the information-disclosure issue:

sendip -p ipv4 -is 192.168.66.102 -p udp -us 520 -ud 520 -p rip -rv 1 -rc 1 -re 0:0:0:0:0:16 192.168.66.111


To exploit the route-injection issue:

sendip -p ipv4 -is 192.168.69.102 -p udp -us 520 -ud 520 -p rip -rv 1 -rc 2 -re 2:0:192.168.36.0:255.255.255.0:0.0.0.0:1 192.168.69.100

- 解决方案

The vendor has released patches to address these issues.

Please see the references for more information and vendor advisories.


Quagga Quagga Routing Software Suite 0.97.3

Quagga Quagga Routing Software Suite 0.98.5

Quagga Quagga Routing Software Suite 0.99.3

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站