CVE-2006-2202
CVSS6.4
发布时间 :2006-05-04 13:06:00
修订时间 :2011-03-07 21:35:32
NMCO    

[原文]SQL injection vulnerability in post.php in Invision Gallery 2.0.6 allows remote attackers to execute arbitrary SQL commands via the album parameter.


[CNNVD]Invision Gallery post.php 远程SQL注入漏洞(CNNVD-200605-073)

        Invision Gallery是一种款流行的基于Web的图像管理系统。
        Invision Gallery实现上存在输入验证漏洞,远程攻击者可能利用此漏洞对服务器执行SQL注入攻击,非授权访问数据库。
        Invision Gallery的modules/gallery/post.php脚本没有对album变量值做充分的检查过滤,远程攻击者可以在变量值中插入SQL语句非授权访问数据,导致数据库破坏或信息泄露。
        

- CVSS (基础分值)

CVSS分值: 6.4 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-2202
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-2202
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200605-073
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/17793
(PATCH)  BID  17793
http://secunia.com/advisories/19948
(VENDOR_ADVISORY)  SECUNIA  19948
http://www.vupen.com/english/advisories/2006/1655
(UNKNOWN)  VUPEN  ADV-2006-1655
http://www.securityfocus.com/archive/1/archive/1/432731/100/0/threaded
(UNKNOWN)  BUGTRAQ  20060502 Invision Gallery 2.0.6 ( SQL Injection )
http://securitytracker.com/id?1016019
(UNKNOWN)  SECTRACK  1016019
http://xforce.iss.net/xforce/xfdb/26224
(UNKNOWN)  XF  invisiongallery-album-sql-injection(26224)
http://www.securityfocus.com/archive/1/archive/1/432952/100/0/threaded
(UNKNOWN)  BUGTRAQ  20060504 Re: Invision Gallery 2.0.6 ( SQL Injection )
http://www.osvdb.org/25231
(UNKNOWN)  OSVDB  25231
http://securityreason.com/securityalert/841
(UNKNOWN)  SREASON  841

- 漏洞信息

Invision Gallery post.php 远程SQL注入漏洞
中危 SQL注入
2006-05-04 00:00:00 2006-05-05 00:00:00
远程  
        Invision Gallery是一种款流行的基于Web的图像管理系统。
        Invision Gallery实现上存在输入验证漏洞,远程攻击者可能利用此漏洞对服务器执行SQL注入攻击,非授权访问数据库。
        Invision Gallery的modules/gallery/post.php脚本没有对album变量值做充分的检查过滤,远程攻击者可以在变量值中插入SQL语句非授权访问数据,导致数据库破坏或信息泄露。
        

- 公告与补丁

        目前厂商已经发布了升级补丁以修复这个安全问题,补丁下载链接:
        http://www.invisionpower.com/ip.dynamic/products/gallery/index.html

- 漏洞信息

25231
Invision Gallery post.php album Parameter SQL Injection
Remote / Network Access Information Disclosure, Input Manipulation
Loss of Confidentiality, Loss of Integrity
Vendor Verified

- 漏洞描述

Invision Gallery contains a flaw that may allow an attacker to carry out an SQL injection attack. The issue is due to the post.php script not properly sanitizing user-supplied input to the 'album' variable. This may allow an attacker to inject or manipulate SQL queries in the back-end database.

- 时间线

2006-05-02 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 2.0.7 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站