CVE-2006-2188
CVSS6.8
发布时间 :2006-05-04 08:38:00
修订时间 :2008-09-05 17:03:53
NMCOS    

[原文]Multiple cross-site scripting (XSS) vulnerabilities in CMScout 1.10 and earlier allow remote attackers to inject arbitrary web script or HTML via (1) the Body field of a private message (PM), (2) BBCode, or (3) a forum post.


[CNNVD]CMScout 多个跨站脚本攻击(XSS) 漏洞(CNNVD-200605-060)

        CMScout 1.10及之前版本存在多个跨站脚本攻击(XSS) 漏洞。 远程攻击者可以借助(1) 私人信息 (PM)中的Body字段, (2) BBCode或(3) 论坛帖子,注入任意 web 脚本或HTML 。

- CVSS (基础分值)

CVSS分值: 6.8 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: NETWORK [攻击者不需要获取内网访问权或本地访问权]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-2188
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-2188
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200605-060
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/17796
(PATCH)  BID  17796
http://www.osvdb.org/25247
(PATCH)  OSVDB  25247
http://www.osvdb.org/25246
(PATCH)  OSVDB  25246
http://www.securityfocus.com/archive/1/archive/1/432725/100/0/threaded
(VENDOR_ADVISORY)  BUGTRAQ  20060502 Cmscout <= V1.10 multiple XSS attack vectors
http://securitytracker.com/id?1016023
(UNKNOWN)  SECTRACK  1016023
http://secunia.com/advisories/19933
(VENDOR_ADVISORY)  SECUNIA  19933
http://xforce.iss.net/xforce/xfdb/26223
(UNKNOWN)  XF  cmscout-messageform-xss(26223)
http://securityreason.com/securityalert/838
(UNKNOWN)  SREASON  838

- 漏洞信息

CMScout 多个跨站脚本攻击(XSS) 漏洞
中危 跨站脚本
2006-05-04 00:00:00 2007-01-05 00:00:00
远程  
        CMScout 1.10及之前版本存在多个跨站脚本攻击(XSS) 漏洞。 远程攻击者可以借助(1) 私人信息 (PM)中的Body字段, (2) BBCode或(3) 论坛帖子,注入任意 web 脚本或HTML 。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复这个安全问题,补丁下载链接:
        CMScout CMScout 1.10
        CMScout cmscout1.21.zip
        http://www.cmscout.za.net/index.php?page=downloads&id=36&action=down&c
        atid=1

- 漏洞信息

25246
CMScout Message Body XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public Vendor Verified

- 漏洞描述

CMScout contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate user-supplied input upon submission to the forum posts or private messages. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2006-05-02 Unknow
2006-05-02 Unknow

- 解决方案

Upgrade to version 1.21 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

- 漏洞信息

CmScout Multiple HTML Injection Vulnerabilities
Input Validation Error 17796
Yes No
2006-05-02 12:00:00 2006-07-27 11:17:00
Nomenumbra is credited with the discovery of this vulnerability.

- 受影响的程序版本

CMScout CMScout 1.10
CMScout CMScout 1.21

- 不受影响的程序版本

CMScout CMScout 1.21

- 漏洞讨论

CmScout is prone to multiple HTML-injection vulnerabilities because the application fails to properly sanitize user-supplied input before using it in dynamically generated content.

Attacker-supplied HTML and script code would be executed in the context of the affected website, potentially allowing an attacker to steal cookie-based authentication credentials or to control how the site is rendered to the user; other attacks are also possible.

Versions 1.10 and prior are vulnerable; other versions may also be affected.

- 漏洞利用

Attackers can exploit this issue via a web client.

- 解决方案

The vendor has released version 1.21 to address these issues.


CMScout CMScout 1.10

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站