CVE-2006-2164
CVSS7.5
发布时间 :2006-05-04 08:38:00
修订时间 :2008-11-03 01:19:19
NMCO    

[原文]Multiple SQL injection vulnerabilities in Avactis Shopping Cart 0.1.2 and earlier allow remote attackers to execute arbitrary SQL commands via the (1) category_id parameter in (a) store_special_offers.php and (b) store.php, and (2) prod_id parameter in (c) cart.php and (d) product_info.php. NOTE: this issue also produces resultant full path disclosure from invalid SQL queries.


[CNNVD]Avactis Shopping Cart 多个SQL注入漏洞(CNNVD-200605-065)

        Avactis Shopping Cart 存在多个SQL注入漏洞。 远程攻击者可以借助 (a) store_special_offers.php 和 (b) store.php中的(1) category_id 参数,以及(c) cart.php和(d) product_info.php中的(2) prod_id参数,执行任意SQL指令。 注意: 此问题还会因无效SQL查询而导致完整路径泄露。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-2164
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-2164
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200605-065
(官方数据源) CNNVD

- 其它链接及资源

http://xforce.iss.net/xforce/xfdb/26178
(UNKNOWN)  XF  avactis-multiple-scripts-sql-injection(26178)
http://www.osvdb.org/25640
(UNKNOWN)  OSVDB  25640
http://www.osvdb.org/25639
(UNKNOWN)  OSVDB  25639
http://www.osvdb.org/25638
(UNKNOWN)  OSVDB  25638
http://www.osvdb.org/25637
(UNKNOWN)  OSVDB  25637
http://pridels0.blogspot.com/2006/05/avactis-shopping-cart-vuln.html
(UNKNOWN)  MISC  http://pridels0.blogspot.com/2006/05/avactis-shopping-cart-vuln.html

- 漏洞信息

Avactis Shopping Cart 多个SQL注入漏洞
高危 SQL注入
2006-05-04 00:00:00 2006-05-04 00:00:00
远程  
        Avactis Shopping Cart 存在多个SQL注入漏洞。 远程攻击者可以借助 (a) store_special_offers.php 和 (b) store.php中的(1) category_id 参数,以及(c) cart.php和(d) product_info.php中的(2) prod_id参数,执行任意SQL指令。 注意: 此问题还会因无效SQL查询而导致完整路径泄露。

- 公告与补丁

        

- 漏洞信息

25637
Avactis Shopping Cart store_special_offers.php category_id Parameter SQL Injection
Remote / Network Access Information Disclosure, Input Manipulation
Loss of Confidentiality, Loss of Integrity

- 漏洞描述

Avactis Shopping Cart contains a flaw that may allow an attacker to carry out an SQL injection attack. The issue is due to the 'store_special_offers.php' script not properly sanitizing user-supplied input to the 'category_id' variable. This may allow an attacker to inject or manipulate SQL queries in the back-end database.

- 时间线

2006-05-01 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 0.1.3 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站