CVE-2006-2162
CVSS5.0
发布时间 :2006-05-03 17:02:00
修订时间 :2011-03-07 21:35:28
NMCOPS    

[原文]Buffer overflow in CGI scripts in Nagios 1.x before 1.4 and 2.x before 2.3 allows remote attackers to execute arbitrary code via a negative content length (Content-Length) HTTP header.


[CNNVD]Nagios CGI脚本 缓冲区溢出漏洞(CNNVD-200605-048)

        Nagios 中的CGI脚本存在缓冲区溢出。远程攻击者可以借助负内容长度的 (Content-Length)HTTP标头,执行任意代码。

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:nagios:nagios:2.2
cpe:/a:nagios:nagios:1.3

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-2162
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-2162
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200605-048
(官方数据源) CNNVD

- 其它链接及资源

https://sourceforge.net/mailarchive/forum.php?thread_id=10297806&forum_id=7890
(UNKNOWN)  CONFIRM  https://sourceforge.net/mailarchive/forum.php?thread_id=10297806&forum_id=7890
http://www.vupen.com/english/advisories/2006/1662
(UNKNOWN)  VUPEN  ADV-2006-1662
http://www.nagios.org/development/changelog.php
(UNKNOWN)  CONFIRM  http://www.nagios.org/development/changelog.php
http://xforce.iss.net/xforce/xfdb/26253
(UNKNOWN)  XF  nagios-multiple-scripts-bo(26253)
http://www.ubuntulinux.org/support/documentation/usn/usn-282-1
(UNKNOWN)  UBUNTU  USN-282-1
http://www.securityfocus.com/bid/17879
(UNKNOWN)  BID  17879
http://www.novell.com/linux/security/advisories/2006_05_19.html
(UNKNOWN)  SUSE  SUSE-SR:2006:011
http://www.gentoo.org/security/en/glsa/glsa-200605-07.xml
(UNKNOWN)  GENTOO  GLSA-200605-07
http://www.debian.org/security/2006/dsa-1072
(UNKNOWN)  DEBIAN  DSA-1072
http://secunia.com/advisories/20247
(UNKNOWN)  SECUNIA  20247
http://secunia.com/advisories/20215
(UNKNOWN)  SECUNIA  20215
http://secunia.com/advisories/20013
(UNKNOWN)  SECUNIA  20013
http://secunia.com/advisories/19998
(UNKNOWN)  SECUNIA  19998
http://secunia.com/advisories/19991
(UNKNOWN)  SECUNIA  19991

- 漏洞信息

Nagios CGI脚本 缓冲区溢出漏洞
中危 缓冲区溢出
2006-05-03 00:00:00 2006-05-03 00:00:00
远程  
        Nagios 中的CGI脚本存在缓冲区溢出。远程攻击者可以借助负内容长度的 (Content-Length)HTTP标头,执行任意代码。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复这个安全问题,补丁下载链接:
        Nagios Nagios 2.2
        Nagios nagios-2.3.tar.gz
        http://prdownloads.sourceforge.net/nagios/nagios-2.3.tar.gz?download
        Nagios Nagios 1.3
        Debian nagios-common_1.3-cvs.20050402-2.sarge.2_all.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/n/nagios/nagios-common_1. 3-cvs.20050402-2.sarge.2_all.deb
        Debian nagios-mysql_1.3-cvs.20050402-2.sarge.2_alpha.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/n/nagios/nagios-mysql_1.3 -cvs.20050402-2.sarge.2_alpha.deb
        Debian nagios-mysql_1.3-cvs.20050402-2.sarge.2_amd64.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/n/nagios/nagios-mysql_1.3 -cvs.20050402-2.sarge.2_amd64.deb
        Debian nagios-mysql_1.3-cvs.20050402-2.sarge.2_arm.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/n/nagios/nagios-mysql_1.3 -cvs.20050402-2.sarge.2_arm.deb
        Debian nagios-mysql_1.3-cvs.20050402-2.sarge.2_hppa.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/n/nagios/nagios-mysql_1.3 -cvs.20050402-2.sarge.2_hppa.deb
        Debian nagios-mysql_1.3-cvs.20050402-2.sarge.2_i386.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/n/nagios/nagios-mysql_1.3 -cvs.20050402-2.sarge.2_i386.deb
        Debian nagios-mysql_1.3-cvs.20050402-2.sarge.2_ia64.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/n/nagios/nagios-mysql_1.3 -cvs.20050402-2.sarge.2_ia64.deb
        Debian nagios-mysql_1.3-cvs.20050402-2.sarge.2_m68k.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/n/nagios/nagios-mysql_1.3 -cvs.20050402-2.sarge.2_m68k.deb
        Debian nagios-mysql_1.3-cvs.20050402-2.sarge.2_mips.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/n/nagios/nagios-mysql_1.3 -cvs.20050402-2.sarge.2_mips.deb
        Debian nagios-mysql_1.3-cvs.20050402-2.sarge.2_mipsel.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/n/nagios/nagios-mysql_1.3 -cvs.20050402-2.sarge.2_mipsel.deb
        Debian nagios-mysql_1.3-cvs.20050402-2.sarge.2_powerpc.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/n/nagios/nagios-mysql_1.3 -cvs.20050402-2.sarge.2_powerpc.deb
        Debian nagios-mysql_1.3-cvs.20050402-2.sarge.2_s390.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/n/nagios/nagios-mysql_1.3 -cvs.20050402-2.sarge.2_s390.deb
        Debian nagios-mysql_1.3-cvs.20050402-2.sarge.2_sparc.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/n/nagios/nagios-mysql_1.3 -cvs.20050402-2.sarge.2_sparc.deb
        Debian nagios-pgsql_1.3-cvs.20050402-2.sarge.2_alpha.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/n/nagios/nagios-pgsql_1.3 -cvs.20050402-2.sarge.2_alpha.deb
        Debian nagios-pgsql_1.3-cvs.20050402-2.sarge.2_amd64.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/n/nagios/nagios-pgsql_1.3 -cvs.20050402-2.sarge.2_amd64.deb
        Debian nagios-pgsql_1.3-cvs.20050402-2.sarge.2_arm.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/n/nagios/nagios-pgsql_1.3 -cvs.20050402-2.sarge.2_arm.deb
        Debian nagios-pgsql_1.3-cvs.20050402-2.sarge.2_hppa.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/n/nagios/nagios-pgsql_1.3 -cvs.20050402-2.sarge.2_hppa.deb
        Debian nagios-pgsql_1.3-cvs.20050402-2.sarge.2_i386.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/n/nagios/nagios-pgsql_1.3 -cvs.20050402-2.sarge.2_i386.deb
        Debian nagios-pgsql_1.3-cvs.20050402-2.sarge.2_ia64.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/n/nagios/nagios-pgsql_1.3 -cvs.20050402-2.sarge.2_ia64.deb
        Debian nagios-pgsql_1.3-cvs.20050402-2.sarge.2_m68k.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/n/nagios/nagios-pgsql_1.3 -cvs.20050402-2.sarge.2_m68k

- 漏洞信息 (F46613)

Debian Linux Security Advisory 1072-1 (PacketStormID:F46613)
2006-05-24 00:00:00
Debian  debian.org
advisory,remote,overflow,arbitrary
linux,debian
CVE-2006-2162,CVE-2006-2489
[点击下载]

Debian Security Advisory 1072-1 - A buffer overflow has been discovered in nagios, a host, service and network monitoring and management system, that could be exploited by remote attackers to execute arbitrary code.

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

- --------------------------------------------------------------------------
Debian Security Advisory DSA 1072-1                    security@debian.org
http://www.debian.org/security/                             Martin Schulze
May 22nd, 2006                          http://www.debian.org/security/faq
- --------------------------------------------------------------------------

Package        : nagios
Vulnerability  : buffer overflow
Problem type   : remote
Debian-specific: no
CVE IDs        : CVE-2006-2162 CVE-2006-2489
BugTraq ID     : 17879
Debian Bugs    : 366682 366683 368193

A buffer overflow has been discovered in nagios, a host, service and
network monitoring and management system, that could be exploited by
remote attackers to execute arbitrary code.

The old stable distribution (woody) does not contain nagios packages.

For the stable distribution (sarge) this problem has been fixed in
version 1.3-cvs.20050402-2.sarge.2.

For the unstable distribution (sid) this problem has been fixed in
version 1.4-1 and 2.3-1.

We recommend that you upgrade your nagios package.


Upgrade Instructions
- --------------------

wget url
        will fetch the file for you
dpkg -i file.deb
        will install the referenced file.

If you are using the apt-get package manager, use the line for
sources.list as given below:

apt-get update
        will update the internal database
apt-get upgrade
        will install corrected packages

You may use an automated update by adding the resources from the
footer to the proper configuration.


Debian GNU/Linux 3.1 alias sarge
- --------------------------------

  Source archives:

    http://security.debian.org/pool/updates/main/n/nagios/nagios_1.3-cvs.20050402-2.sarge.2.dsc
      Size/MD5 checksum:     1039 694c98817377c2543f7cbb2394393bd0
    http://security.debian.org/pool/updates/main/n/nagios/nagios_1.3-cvs.20050402-2.sarge.2.diff.gz
      Size/MD5 checksum:    66757 72ca6d7f396866977e652382a6bfcf98
    http://security.debian.org/pool/updates/main/n/nagios/nagios_1.3-cvs.20050402.orig.tar.gz
      Size/MD5 checksum:  1621251 0f92b7b8e705411b7881d3650cbb5d56

  Architecture independent components:

    http://security.debian.org/pool/updates/main/n/nagios/nagios-common_1.3-cvs.20050402-2.sarge.2_all.deb
      Size/MD5 checksum:  1219662 6a21c58772ac08522c2531d8c5ecca4a

  Alpha architecture:

    http://security.debian.org/pool/updates/main/n/nagios/nagios-mysql_1.3-cvs.20050402-2.sarge.2_alpha.deb
      Size/MD5 checksum:  1147460 7fcd6546d3a0206f18b93462920ea29c
    http://security.debian.org/pool/updates/main/n/nagios/nagios-pgsql_1.3-cvs.20050402-2.sarge.2_alpha.deb
      Size/MD5 checksum:  1157992 065ebde50a7b7f0a6710b6d689f387e5
    http://security.debian.org/pool/updates/main/n/nagios/nagios-text_1.3-cvs.20050402-2.sarge.2_alpha.deb
      Size/MD5 checksum:  1145660 4353ddbb85f925017e5911a9fa37db63

  AMD64 architecture:

    http://security.debian.org/pool/updates/main/n/nagios/nagios-mysql_1.3-cvs.20050402-2.sarge.2_amd64.deb
      Size/MD5 checksum:   983938 809afc6ce7d9e42166cd3451b4b8542a
    http://security.debian.org/pool/updates/main/n/nagios/nagios-pgsql_1.3-cvs.20050402-2.sarge.2_amd64.deb
      Size/MD5 checksum:   997036 45f0788a6a65507909307afdde5dc60e
    http://security.debian.org/pool/updates/main/n/nagios/nagios-text_1.3-cvs.20050402-2.sarge.2_amd64.deb
      Size/MD5 checksum:   976382 cb90bd0e1d3078134f5d34e18baf69bf

  ARM architecture:

    http://security.debian.org/pool/updates/main/n/nagios/nagios-mysql_1.3-cvs.20050402-2.sarge.2_arm.deb
      Size/MD5 checksum:   913882 6bc1ab8ea6cdfb0e207307667038ef7c
    http://security.debian.org/pool/updates/main/n/nagios/nagios-pgsql_1.3-cvs.20050402-2.sarge.2_arm.deb
      Size/MD5 checksum:   922130 931908b8890d6148cbea6876efe3606d
    http://security.debian.org/pool/updates/main/n/nagios/nagios-text_1.3-cvs.20050402-2.sarge.2_arm.deb
      Size/MD5 checksum:   911846 99440ed7c9864ab25c3a78fa1c0fb7cd

  Intel IA-32 architecture:

    http://security.debian.org/pool/updates/main/n/nagios/nagios-mysql_1.3-cvs.20050402-2.sarge.2_i386.deb
      Size/MD5 checksum:   907244 0fa6e558f7a36bd033de14c7cd6bc0ea
    http://security.debian.org/pool/updates/main/n/nagios/nagios-pgsql_1.3-cvs.20050402-2.sarge.2_i386.deb
      Size/MD5 checksum:   917562 002a0b32645c6908dff16450a736d98b
    http://security.debian.org/pool/updates/main/n/nagios/nagios-text_1.3-cvs.20050402-2.sarge.2_i386.deb
      Size/MD5 checksum:   901784 b4a2969dd4037584e217f0e991fb640d

  Intel IA-64 architecture:

    http://security.debian.org/pool/updates/main/n/nagios/nagios-mysql_1.3-cvs.20050402-2.sarge.2_ia64.deb
      Size/MD5 checksum:  1387896 6a81f88fc00a85e97be3bee098a9dc57
    http://security.debian.org/pool/updates/main/n/nagios/nagios-pgsql_1.3-cvs.20050402-2.sarge.2_ia64.deb
      Size/MD5 checksum:  1397740 d69dee784d63316eb0cb9519c4d583c4
    http://security.debian.org/pool/updates/main/n/nagios/nagios-text_1.3-cvs.20050402-2.sarge.2_ia64.deb
      Size/MD5 checksum:  1393984 dce336118b278ad8f46607a39f4d2d4f

  HP Precision architecture:

    http://security.debian.org/pool/updates/main/n/nagios/nagios-mysql_1.3-cvs.20050402-2.sarge.2_hppa.deb
      Size/MD5 checksum:  1007762 8b0848ce1a8e0841c6cd83c3c50b8772
    http://security.debian.org/pool/updates/main/n/nagios/nagios-pgsql_1.3-cvs.20050402-2.sarge.2_hppa.deb
      Size/MD5 checksum:  1018216 3a5ab06a2d02901f00100b8fc8ea77fa
    http://security.debian.org/pool/updates/main/n/nagios/nagios-text_1.3-cvs.20050402-2.sarge.2_hppa.deb
      Size/MD5 checksum:  1003752 1e8915270658b681255e4f7a79751040

  Motorola 680x0 architecture:

    http://security.debian.org/pool/updates/main/n/nagios/nagios-mysql_1.3-cvs.20050402-2.sarge.2_m68k.deb
      Size/MD5 checksum:   740028 7a12417cac0405e95e630087c4cd9b80
    http://security.debian.org/pool/updates/main/n/nagios/nagios-pgsql_1.3-cvs.20050402-2.sarge.2_m68k.deb
      Size/MD5 checksum:   744576 669c52d43617eca8f4ce7684a8e68b81
    http://security.debian.org/pool/updates/main/n/nagios/nagios-text_1.3-cvs.20050402-2.sarge.2_m68k.deb
      Size/MD5 checksum:   733424 dc5bad1b6f0efc81201c76dc2765f2b1

  Big endian MIPS architecture:

    http://security.debian.org/pool/updates/main/n/nagios/nagios-mysql_1.3-cvs.20050402-2.sarge.2_mips.deb
      Size/MD5 checksum:  1010016 75380f88a537d517b50b58f3f2e8b840
    http://security.debian.org/pool/updates/main/n/nagios/nagios-pgsql_1.3-cvs.20050402-2.sarge.2_mips.deb
      Size/MD5 checksum:  1015648 b5c3babedba38222751251349534e265
    http://security.debian.org/pool/updates/main/n/nagios/nagios-text_1.3-cvs.20050402-2.sarge.2_mips.deb
      Size/MD5 checksum:   998780 e3ff559fc8e53a2e9467fe2c372d8965

  Little endian MIPS architecture:

    http://security.debian.org/pool/updates/main/n/nagios/nagios-mysql_1.3-cvs.20050402-2.sarge.2_mipsel.deb
      Size/MD5 checksum:  1002950 1034cd8b7b0d65870951574aca531f2a
    http://security.debian.org/pool/updates/main/n/nagios/nagios-pgsql_1.3-cvs.20050402-2.sarge.2_mipsel.deb
      Size/MD5 checksum:  1007744 ffdcb52a2be9188f61548cf3deddffff
    http://security.debian.org/pool/updates/main/n/nagios/nagios-text_1.3-cvs.20050402-2.sarge.2_mipsel.deb
      Size/MD5 checksum:   993148 10ed0de7a328d2991320380b2de79a23

  PowerPC architecture:

    http://security.debian.org/pool/updates/main/n/nagios/nagios-mysql_1.3-cvs.20050402-2.sarge.2_powerpc.deb
      Size/MD5 checksum:   993574 d865bb05c0d751afd9ba73733a124202
    http://security.debian.org/pool/updates/main/n/nagios/nagios-pgsql_1.3-cvs.20050402-2.sarge.2_powerpc.deb
      Size/MD5 checksum:  1001728 d1fa961b067fe817cfa36ebd03df0b3b
    http://security.debian.org/pool/updates/main/n/nagios/nagios-text_1.3-cvs.20050402-2.sarge.2_powerpc.deb
      Size/MD5 checksum:   970390 231503ad8b6898462eaa1b7d514779be

  IBM S/390 architecture:

    http://security.debian.org/pool/updates/main/n/nagios/nagios-mysql_1.3-cvs.20050402-2.sarge.2_s390.deb
      Size/MD5 checksum:   883538 c25cce732833d28a634b398416b2f3dd
    http://security.debian.org/pool/updates/main/n/nagios/nagios-pgsql_1.3-cvs.20050402-2.sarge.2_s390.deb
      Size/MD5 checksum:   888666 35e2cfafffbb7658eb4e4d08fe83a6c5
    http://security.debian.org/pool/updates/main/n/nagios/nagios-text_1.3-cvs.20050402-2.sarge.2_s390.deb
      Size/MD5 checksum:   872492 5b07e7ffbc8a61952b65df843607ba3f

  Sun Sparc architecture:

    http://security.debian.org/pool/updates/main/n/nagios/nagios-mysql_1.3-cvs.20050402-2.sarge.2_sparc.deb
      Size/MD5 checksum:   896818 e028db2f37ba703be10be8fd32ef0f74
    http://security.debian.org/pool/updates/main/n/nagios/nagios-pgsql_1.3-cvs.20050402-2.sarge.2_sparc.deb
      Size/MD5 checksum:   904720 47c34b7e42e885958cc88e13a8bebcab
    http://security.debian.org/pool/updates/main/n/nagios/nagios-text_1.3-cvs.20050402-2.sarge.2_sparc.deb
      Size/MD5 checksum:   894698 c0029aa776994f29755686b3ae000b78


  These files will probably be moved into the stable distribution on
  its next update.

- ---------------------------------------------------------------------------------
For apt-get: deb http://security.debian.org/ stable/updates main
For dpkg-ftp: ftp://security.debian.org/debian-security dists/stable/updates/main
Mailing list: debian-security-announce@lists.debian.org
Package info: `apt-cache show <pkg>' and http://packages.debian.org/<pkg>

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.3 (GNU/Linux)

iD8DBQFEcdLgW5ql+IAeqTIRAgnLAJ0ZL3Td5n4vyyYx73flt65mPQrgcgCeKO/c
AMOqGbCfK+y7ist4BSVHS3I=
=EgrY
-----END PGP SIGNATURE-----

    

- 漏洞信息 (F46224)

Ubuntu Security Notice 282-1 (PacketStormID:F46224)
2006-05-09 00:00:00
Ubuntu  security.ubuntu.com
advisory,remote,web,arbitrary,cgi
linux,ubuntu
CVE-2006-2162
[点击下载]

Ubuntu Security Notice 282-1 - The nagios CGI scripts did not sufficiently check the validity of the HTTP Content-Length attribute. By sending a specially crafted HTTP request with a negative Content-Length value to the Nagios server, a remote attacker could exploit this to execute arbitrary code with web server privileges.

===========================================================
Ubuntu Security Notice USN-282-1	       May 08, 2006
nagios vulnerability
CVE-2006-2162
===========================================================

A security issue affects the following Ubuntu releases:

Ubuntu 5.04 (Hoary Hedgehog)
Ubuntu 5.10 (Breezy Badger)

The following packages are affected:

nagios-common

The problem can be corrected by upgrading the affected package to
version 2:1.3-0+pre6ubuntu0.1 (for Ubuntu 5.04), or
2:1.3-cvs.20050402-4ubuntu3.1 (for Ubuntu 5.10).  In general, a
standard system upgrade is sufficient to effect the necessary changes.

Details follow:

The nagios CGI scripts did not sufficiently check the validity of the
HTTP Content-Length attribute. By sending a specially crafted HTTP
request with a negative Content-Length value to the Nagios server, a
remote attacker could exploit this to execute arbitrary code with web
server privileges.

Please note that the Apache 2 web server already checks for valid
Content-Length values, so installations using Apache 2 (the only web
server officially supported in Ubuntu) are not vulnerable to this
flaw.


Updated packages for Ubuntu 5.04:

  Source archives:

    http://security.ubuntu.com/ubuntu/pool/main/n/nagios/nagios_1.3-0+pre6ubuntu0.1.diff.gz
      Size/MD5:    80281 7d71114ea6d8e11edb79133235e94951
    http://security.ubuntu.com/ubuntu/pool/main/n/nagios/nagios_1.3-0+pre6ubuntu0.1.dsc
      Size/MD5:     1010 611221f65f55763d607bd18754f5b46e
    http://security.ubuntu.com/ubuntu/pool/main/n/nagios/nagios_1.3.orig.tar.gz
      Size/MD5:  1625322 414d70e5269d5b8d7c21bf3ee129309f

  Architecture independent packages:

    http://security.ubuntu.com/ubuntu/pool/main/n/nagios/nagios-common_1.3-0+pre6ubuntu0.1_all.deb
      Size/MD5:  1213184 aef209a60989887c5e4828f8c6e5ed22

  amd64 architecture (Athlon64, Opteron, EM64T Xeon)

    http://security.ubuntu.com/ubuntu/pool/main/n/nagios/nagios-mysql_1.3-0+pre6ubuntu0.1_amd64.deb
      Size/MD5:   994148 caee3765a8cb8826cbfb83b6a80a93aa
    http://security.ubuntu.com/ubuntu/pool/main/n/nagios/nagios-pgsql_1.3-0+pre6ubuntu0.1_amd64.deb
      Size/MD5:  1006218 331626a1400801648faa72261f72bc0f
    http://security.ubuntu.com/ubuntu/pool/main/n/nagios/nagios-text_1.3-0+pre6ubuntu0.1_amd64.deb
      Size/MD5:   975952 83b6c5a302ed299866fa717020c30d68

  i386 architecture (x86 compatible Intel/AMD)

    http://security.ubuntu.com/ubuntu/pool/main/n/nagios/nagios-mysql_1.3-0+pre6ubuntu0.1_i386.deb
      Size/MD5:   872306 fcb37a47f0eff94a77d1a1e30205aeec
    http://security.ubuntu.com/ubuntu/pool/main/n/nagios/nagios-pgsql_1.3-0+pre6ubuntu0.1_i386.deb
      Size/MD5:   882042 08b7590825e1d97807445e11859fb487
    http://security.ubuntu.com/ubuntu/pool/main/n/nagios/nagios-text_1.3-0+pre6ubuntu0.1_i386.deb
      Size/MD5:   857596 0feedae7fd082a9b566bdc52c2a69794

  powerpc architecture (Apple Macintosh G3/G4/G5)

    http://security.ubuntu.com/ubuntu/pool/main/n/nagios/nagios-mysql_1.3-0+pre6ubuntu0.1_powerpc.deb
      Size/MD5:  1002618 f7267c0a908b37119bd1cc75a82f691a
    http://security.ubuntu.com/ubuntu/pool/main/n/nagios/nagios-pgsql_1.3-0+pre6ubuntu0.1_powerpc.deb
      Size/MD5:  1010332 cd4882a8adaf882be52ca06c03a9f009
    http://security.ubuntu.com/ubuntu/pool/main/n/nagios/nagios-text_1.3-0+pre6ubuntu0.1_powerpc.deb
      Size/MD5:   969694 61692fa210eac3be4acc0ec31db859df

Updated packages for Ubuntu 5.10:

  Source archives:

    http://security.ubuntu.com/ubuntu/pool/main/n/nagios/nagios_1.3-cvs.20050402-4ubuntu3.1.diff.gz
      Size/MD5:    72940 45eb9bb3f5d319ee26e54911766c3329
    http://security.ubuntu.com/ubuntu/pool/main/n/nagios/nagios_1.3-cvs.20050402-4ubuntu3.1.dsc
      Size/MD5:     1039 38ccfb2a73283d3407b9fe60533f98ff
    http://security.ubuntu.com/ubuntu/pool/main/n/nagios/nagios_1.3-cvs.20050402.orig.tar.gz
      Size/MD5:  1621251 0f92b7b8e705411b7881d3650cbb5d56

  Architecture independent packages:

    http://security.ubuntu.com/ubuntu/pool/main/n/nagios/nagios-common_1.3-cvs.20050402-4ubuntu3.1_all.deb
      Size/MD5:  1221180 8d5b4df9c227530749020ffb466ff2f2

  amd64 architecture (Athlon64, Opteron, EM64T Xeon)

    http://security.ubuntu.com/ubuntu/pool/main/n/nagios/nagios-mysql_1.3-cvs.20050402-4ubuntu3.1_amd64.deb
      Size/MD5:  1029868 c8d76916a6910a2cbfe3ff1ba6ac5719
    http://security.ubuntu.com/ubuntu/pool/main/n/nagios/nagios-pgsql_1.3-cvs.20050402-4ubuntu3.1_amd64.deb
      Size/MD5:  1041510 623c9b4b2e3ab693c9993ede121488a7
    http://security.ubuntu.com/ubuntu/pool/main/n/nagios/nagios-text_1.3-cvs.20050402-4ubuntu3.1_amd64.deb
      Size/MD5:  1025400 d37f7806f75fecda7f4b3d63491e0939

  i386 architecture (x86 compatible Intel/AMD)

    http://security.ubuntu.com/ubuntu/pool/main/n/nagios/nagios-mysql_1.3-cvs.20050402-4ubuntu3.1_i386.deb
      Size/MD5:   878928 9ee514d4b91119f3ba6bfc6c1f62fbea
    http://security.ubuntu.com/ubuntu/pool/main/n/nagios/nagios-pgsql_1.3-cvs.20050402-4ubuntu3.1_i386.deb
      Size/MD5:   887908 f8365be3ee3dd6aa19fbe61e80a51120
    http://security.ubuntu.com/ubuntu/pool/main/n/nagios/nagios-text_1.3-cvs.20050402-4ubuntu3.1_i386.deb
      Size/MD5:   873662 1c9aa6c22a19b705f7a3702b09fe6986

  powerpc architecture (Apple Macintosh G3/G4/G5)

    http://security.ubuntu.com/ubuntu/pool/main/n/nagios/nagios-mysql_1.3-cvs.20050402-4ubuntu3.1_powerpc.deb
      Size/MD5:  1015848 74ebefb823c39c2b1cd54d3c8bcf80f3
    http://security.ubuntu.com/ubuntu/pool/main/n/nagios/nagios-pgsql_1.3-cvs.20050402-4ubuntu3.1_powerpc.deb
      Size/MD5:  1024990 7e1a404b27a63d58644e2faa92f20217
    http://security.ubuntu.com/ubuntu/pool/main/n/nagios/nagios-text_1.3-cvs.20050402-4ubuntu3.1_powerpc.deb
      Size/MD5:   993116 ba19fcb9ba815eb4f47d8c75cebb8ee0
    

- 漏洞信息

25434
Nagios Negative Content-Length HTTP Header Overflow
Input Manipulation
Loss of Integrity
Vendor Verified

- 漏洞描述

Unknown or Incomplete

- 时间线

2006-05-08 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 1.4, 2.3 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Nagios Remote Negative Content-Length Buffer Overflow Vulnerability
Boundary Condition Error 17879
Yes No
2006-05-08 12:00:00 2007-11-15 12:39:00
Discovery is credited to Sebastian Krahmer of the SuSE security team.

- 受影响的程序版本

Ubuntu Ubuntu Linux 5.10 powerpc
Ubuntu Ubuntu Linux 5.10 i386
Ubuntu Ubuntu Linux 5.10 amd64
Ubuntu Ubuntu Linux 5.0 4 powerpc
Ubuntu Ubuntu Linux 5.0 4 i386
Ubuntu Ubuntu Linux 5.0 4 amd64
Nagios Nagios 1.0 b4
- Debian Linux 2.2 sparc
- Debian Linux 2.2 powerpc
- Debian Linux 2.2 IA-32
- Debian Linux 2.2 arm
- Debian Linux 2.2 alpha
- Debian Linux 2.2 68k
- Mandriva Linux Mandrake 8.2
- Mandriva Linux Mandrake 8.1
- Mandriva Linux Mandrake 8.0
- Mandriva Linux Mandrake 7.2
- RedHat Linux 7.3 i386
- RedHat Linux 7.2 ia64
- RedHat Linux 7.2 i386
- RedHat Linux 7.2 alpha
- RedHat Linux 7.1 ia64
- RedHat Linux 7.1 i386
- RedHat Linux 7.1 alpha
- RedHat Linux 7.0 sparc
- RedHat Linux 7.0 i386
- RedHat Linux 7.0 alpha
- S.u.S.E. Linux 8.0 i386
- S.u.S.E. Linux 7.3 sparc
- S.u.S.E. Linux 7.3 ppc
- S.u.S.E. Linux 7.3 i386
- S.u.S.E. Linux 7.2 i386
- S.u.S.E. Linux 7.1 x86
- S.u.S.E. Linux 7.1 sparc
- S.u.S.E. Linux 7.1 ppc
- S.u.S.E. Linux 7.1 alpha
- S.u.S.E. Linux 7.0 sparc
- S.u.S.E. Linux 7.0 ppc
- S.u.S.E. Linux 7.0 i386
- S.u.S.E. Linux 7.0 alpha
Nagios Nagios 1.0 b3
- Debian Linux 2.2 sparc
- Debian Linux 2.2 powerpc
- Debian Linux 2.2 IA-32
- Debian Linux 2.2 arm
- Debian Linux 2.2 alpha
- Debian Linux 2.2 68k
- Mandriva Linux Mandrake 8.2
- Mandriva Linux Mandrake 8.1
- Mandriva Linux Mandrake 8.0
- Mandriva Linux Mandrake 7.2
- RedHat Linux 7.3 i386
- RedHat Linux 7.2 ia64
- RedHat Linux 7.2 i386
- RedHat Linux 7.2 alpha
- RedHat Linux 7.1 ia64
- RedHat Linux 7.1 i386
- RedHat Linux 7.1 alpha
- RedHat Linux 7.0 sparc
- RedHat Linux 7.0 i386
- RedHat Linux 7.0 alpha
- S.u.S.E. Linux 8.0 i386
- S.u.S.E. Linux 7.3 sparc
- S.u.S.E. Linux 7.3 ppc
- S.u.S.E. Linux 7.3 i386
- S.u.S.E. Linux 7.2 i386
- S.u.S.E. Linux 7.1 x86
- S.u.S.E. Linux 7.1 sparc
- S.u.S.E. Linux 7.1 ppc
- S.u.S.E. Linux 7.1 alpha
- S.u.S.E. Linux 7.0 sparc
- S.u.S.E. Linux 7.0 ppc
- S.u.S.E. Linux 7.0 i386
- S.u.S.E. Linux 7.0 alpha
Nagios Nagios 1.0 b2
- Debian Linux 2.2 sparc
- Debian Linux 2.2 powerpc
- Debian Linux 2.2 IA-32
- Debian Linux 2.2 arm
- Debian Linux 2.2 alpha
- Debian Linux 2.2 68k
- Mandriva Linux Mandrake 8.2
- Mandriva Linux Mandrake 8.1
- Mandriva Linux Mandrake 8.0
- Mandriva Linux Mandrake 7.2
- RedHat Linux 7.3 i386
- RedHat Linux 7.2 ia64
- RedHat Linux 7.2 i386
- RedHat Linux 7.2 alpha
- RedHat Linux 7.1 ia64
- RedHat Linux 7.1 i386
- RedHat Linux 7.1 alpha
- RedHat Linux 7.0 sparc
- RedHat Linux 7.0 i386
- RedHat Linux 7.0 alpha
- S.u.S.E. Linux 8.0 i386
- S.u.S.E. Linux 7.3 sparc
- S.u.S.E. Linux 7.3 ppc
- S.u.S.E. Linux 7.3 i386
- S.u.S.E. Linux 7.2 i386
- S.u.S.E. Linux 7.1 x86
- S.u.S.E. Linux 7.1 sparc
- S.u.S.E. Linux 7.1 ppc
- S.u.S.E. Linux 7.1 alpha
- S.u.S.E. Linux 7.0 sparc
- S.u.S.E. Linux 7.0 ppc
- S.u.S.E. Linux 7.0 i386
- S.u.S.E. Linux 7.0 alpha
Nagios Nagios 1.0 b1
- Debian Linux 2.2 sparc
- Debian Linux 2.2 powerpc
- Debian Linux 2.2 IA-32
- Debian Linux 2.2 arm
- Debian Linux 2.2 alpha
- Debian Linux 2.2 68k
- Mandriva Linux Mandrake 8.2
- Mandriva Linux Mandrake 8.1
- Mandriva Linux Mandrake 8.0
- Mandriva Linux Mandrake 7.2
- RedHat Linux 7.3 i386
- RedHat Linux 7.2 ia64
- RedHat Linux 7.2 i386
- RedHat Linux 7.2 alpha
- RedHat Linux 7.1 ia64
- RedHat Linux 7.1 i386
- RedHat Linux 7.1 alpha
- RedHat Linux 7.0 sparc
- RedHat Linux 7.0 i386
- RedHat Linux 7.0 alpha
- S.u.S.E. Linux 8.0 i386
- S.u.S.E. Linux 7.3 sparc
- S.u.S.E. Linux 7.3 ppc
- S.u.S.E. Linux 7.3 i386
- S.u.S.E. Linux 7.2 i386
- S.u.S.E. Linux 7.1 x86
- S.u.S.E. Linux 7.1 sparc
- S.u.S.E. Linux 7.1 ppc
- S.u.S.E. Linux 7.1 alpha
- S.u.S.E. Linux 7.0 sparc
- S.u.S.E. Linux 7.0 ppc
- S.u.S.E. Linux 7.0 i386
- S.u.S.E. Linux 7.0 alpha
Nagios Nagios 2.2
Nagios Nagios 1.3
Nagios Nagios 0
Gentoo Linux
Debian Linux 3.1 sparc
Debian Linux 3.1 s/390
Debian Linux 3.1 ppc
Debian Linux 3.1 mipsel
Debian Linux 3.1 mips
Debian Linux 3.1 m68k
Debian Linux 3.1 ia-64
Debian Linux 3.1 ia-32
Debian Linux 3.1 hppa
Debian Linux 3.1 arm
Debian Linux 3.1 amd64
Debian Linux 3.1 alpha
Debian Linux 3.1
Nagios Nagios 2.3
Nagios Nagios 1.4

- 不受影响的程序版本

Nagios Nagios 2.3
Nagios Nagios 1.4

- 漏洞讨论

Nagios is susceptible to a remote buffer-overflow vulnerability. This issue is due to the application's failure to properly bounds-check user-supplied input before copying it to an insufficiently sized memory buffer.

This issue allows remote attackers to execute arbitrary machine code in the context of hosting webservers.

Nagios versions prior to 2.3 in the 2.x series, and versions prior to 1.4 in the 1.x series are vulnerable to this issue.

- 漏洞利用

Currently we are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com

- 解决方案

The vendor has released versions 1.4 and 2.3 of Nagios to address this issue.

Please see the referenced advisories for further information on obtaining and applying fixes.


Nagios Nagios 2.2

Nagios Nagios 1.3

Nagios Nagios 0

Nagios Nagios 1.0 b2

Nagios Nagios 1.0 b3

Nagios Nagios 1.0 b4

Nagios Nagios 1.0 b1

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站