CVE-2006-2148
CVSS7.5
发布时间 :2006-05-02 17:06:00
修订时间 :2011-03-07 21:35:26
NMCOPS    

[原文]Multiple buffer overflows in client.c in CGI:IRC (CGIIRC) before 0.5.8 might allow remote attackers to execute arbitrary code via (1) cookies or (2) the query string.


[CNNVD]CGI:IRC Client.C 多个远程缓冲区溢出漏洞 (CNNVD-200605-031)

        CGI:IRC (CGIIRC) 0.5.8 之前版本的client.c中存在多个缓冲区溢出。远程攻击者可以借助(1) cookies或(2) 查询字符串,执行任意代码。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:cgiirc:cgiirc:0.5.4
cpe:/a:cgiirc:cgiirc:0.5.7

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-2148
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-2148
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200605-031
(官方数据源) CNNVD

- 其它链接及资源

http://secunia.com/advisories/19922
(VENDOR_ADVISORY)  SECUNIA  19922
http://cvs.cgiirc.org/chngview?cn=263
(PATCH)  CONFIRM  http://cvs.cgiirc.org/chngview?cn=263
http://www.vupen.com/english/advisories/2006/1607
(UNKNOWN)  VUPEN  ADV-2006-1607
http://cvs.cgiirc.org/timeline?d=300&e=2006-Apr-30&c=2&px=&s=0&dm=1&x=1&m=1
(UNKNOWN)  CONFIRM  http://cvs.cgiirc.org/timeline?d=300&e=2006-Apr-30&c=2&px=&s=0&dm=1&x=1&m=1
http://cvs.cgiirc.org/chngview?cn=283
(UNKNOWN)  CONFIRM  http://cvs.cgiirc.org/chngview?cn=283
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=365680
(UNKNOWN)  CONFIRM  http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=365680
http://xforce.iss.net/xforce/xfdb/26173
(UNKNOWN)  XF  cgiirc-client-bo(26173)
http://www.securityfocus.com/bid/17799
(UNKNOWN)  BID  17799
http://www.debian.org/security/2006/dsa-1052
(UNKNOWN)  DEBIAN  DSA-1052
http://secunia.com/advisories/19985
(UNKNOWN)  SECUNIA  19985

- 漏洞信息

CGI:IRC Client.C 多个远程缓冲区溢出漏洞
高危 缓冲区溢出
2006-05-02 00:00:00 2006-05-03 00:00:00
远程  
        CGI:IRC (CGIIRC) 0.5.8 之前版本的client.c中存在多个缓冲区溢出。远程攻击者可以借助(1) cookies或(2) 查询字符串,执行任意代码。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复这个安全问题,补丁下载链接:
        CGI:IRC CGI:IRC 0.5.4
        Debian cgiirc_0.5.4-6sarge1_alpha.debDebian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/c/cgiirc/cgiirc_0.5.4-6sa
        rge1_alpha.deb
        Debian cgiirc_0.5.4-6sarge1_amd64.debDebian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/c/cgiirc/cgiirc_0.5.4-6sa
        rge1_amd64.deb
        Debian cgiirc_0.5.4-6sarge1_arm.debDebian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/c/cgiirc/cgiirc_0.5.4-6sa
        rge1_arm.deb
        Debian cgiirc_0.5.4-6sarge1_hppa.debDebian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/c/cgiirc/cgiirc_0.5.4-6sa
        rge1_hppa.deb
        Debian cgiirc_0.5.4-6sarge1_i386.debDebian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/c/cgiirc/cgiirc_0.5.4-6sa
        rge1_i386.deb
        Debian cgiirc_0.5.4-6sarge1_ia64.debDebian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/c/cgiirc/cgiirc_0.5.4-6sa
        rge1_ia64.deb
        Debian cgiirc_0.5.4-6sarge1_m68k.debDebian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/c/cgiirc/cgiirc_0.5.4-6sa
        rge1_m68k.deb
        Debian cgiirc_0.5.4-6sarge1_mips.debDebian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/c/cgiirc/cgiirc_0.5.4-6sa
        rge1_mips.deb
        Debian cgiirc_0.5.4-6sarge1_mipsel.debDebian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/c/cgiirc/cgiirc_0.5.4-6sa
        rge1_mipsel.deb
        Debian cgiirc_0.5.4-6sarge1_powerpc.debDebian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/c/cgiirc/cgiirc_0.5.4-6sa
        rge1_powerpc.deb
        Debian cgiirc_0.5.4-6sarge1_s390.debDebian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/c/cgiirc/cgiirc_0.5.4-6sa
        rge1_s390.deb
        Debian cgiirc_0.5.4-6sarge1_sparc.debDebian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/c/cgiirc/cgiirc_0.5.4-6sa
        rge1_sparc.deb

- 漏洞信息 (F46217)

Debian Linux Security Advisory 1052-1 (PacketStormID:F46217)
2006-05-09 00:00:00
Debian  debian.org
advisory,web,overflow,arbitrary
linux,debian
CVE-2006-2148
[点击下载]

Debian Security Advisory 1052-1 - Several buffer overflows have been discovered in cgiirc, a web-based IRC client, which could be exploited to execute arbitrary code.

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

- --------------------------------------------------------------------------
Debian Security Advisory DSA 1052-1                    security@debian.org
http://www.debian.org/security/                             Martin Schulze
May 8th, 2006                           http://www.debian.org/security/faq
- --------------------------------------------------------------------------

Package        : cgiirc
Vulnerability  : buffer overflows
Problem type   : remote
Debian-specific: no
CVE ID         : CVE-2006-2148
Debian Bug     : 365680

Several buffer overflows have been discovered in cgiirc, a web-based
IRC client, which could be exploited to execute arbitrary code.

The old stable distribution (woody) does not contain cgiirc packages.

For the stable distribution (sarge) these problems have been fixed in
version 0.5.4-6sarge1.

For the unstable distribution (sid) these problems have been fixed in
version 0.5.4-6sarge1.

We recommend that you upgrade your cgiirc package.


Upgrade Instructions
- --------------------

wget url
        will fetch the file for you
dpkg -i file.deb
        will install the referenced file.

If you are using the apt-get package manager, use the line for
sources.list as given below:

apt-get update
        will update the internal database
apt-get upgrade
        will install corrected packages

You may use an automated update by adding the resources from the
footer to the proper configuration.


Debian GNU/Linux 3.1 alias sarge
- --------------------------------

  Source archives:

    http://security.debian.org/pool/updates/main/c/cgiirc/cgiirc_0.5.4-6sarge1.dsc
      Size/MD5 checksum:      590 daed94ad35a0ac4935086bfd1379c20f
    http://security.debian.org/pool/updates/main/c/cgiirc/cgiirc_0.5.4-6sarge1.diff.gz
      Size/MD5 checksum:    13507 a885a3704d8313920548f156d764dec6
    http://security.debian.org/pool/updates/main/c/cgiirc/cgiirc_0.5.4.orig.tar.gz
      Size/MD5 checksum:   127545 c32ce6514626729ef8cf30cf7bd1a51e

  Alpha architecture:

    http://security.debian.org/pool/updates/main/c/cgiirc/cgiirc_0.5.4-6sarge1_alpha.deb
      Size/MD5 checksum:   122974 55a573eb356b35cb32b651ca570d76f6

  AMD64 architecture:

    http://security.debian.org/pool/updates/main/c/cgiirc/cgiirc_0.5.4-6sarge1_amd64.deb
      Size/MD5 checksum:   122526 25977ad46ac501c8c81de1347dac8cc9

  ARM architecture:

    http://security.debian.org/pool/updates/main/c/cgiirc/cgiirc_0.5.4-6sarge1_arm.deb
      Size/MD5 checksum:   122004 594434fc3222bd093b4b202e2e9df1ec

  Intel IA-32 architecture:

    http://security.debian.org/pool/updates/main/c/cgiirc/cgiirc_0.5.4-6sarge1_i386.deb
      Size/MD5 checksum:   122082 e5d18578977303524a6d9c92a314b0cf

  Intel IA-64 architecture:

    http://security.debian.org/pool/updates/main/c/cgiirc/cgiirc_0.5.4-6sarge1_ia64.deb
      Size/MD5 checksum:   123546 b91e34892993e4d176d3fa8ff970f123

  HP Precision architecture:

    http://security.debian.org/pool/updates/main/c/cgiirc/cgiirc_0.5.4-6sarge1_hppa.deb
      Size/MD5 checksum:   122868 96f3c61fa95509d03277209d5549a037

  Motorola 680x0 architecture:

    http://security.debian.org/pool/updates/main/c/cgiirc/cgiirc_0.5.4-6sarge1_m68k.deb
      Size/MD5 checksum:   121960 e6a1341cee535289a78ef0e2ca33badd

  Big endian MIPS architecture:

    http://security.debian.org/pool/updates/main/c/cgiirc/cgiirc_0.5.4-6sarge1_mips.deb
      Size/MD5 checksum:   123686 ebebe98b959b9985581338ffa5f60857

  Little endian MIPS architecture:

    http://security.debian.org/pool/updates/main/c/cgiirc/cgiirc_0.5.4-6sarge1_mipsel.deb
      Size/MD5 checksum:   123688 0004985ff0018cad8ff54630b4b96e7d

  PowerPC architecture:

    http://security.debian.org/pool/updates/main/c/cgiirc/cgiirc_0.5.4-6sarge1_powerpc.deb
      Size/MD5 checksum:   122502 d2b6b1cbd8d05baebdbd7febd16edc39

  IBM S/390 architecture:

    http://security.debian.org/pool/updates/main/c/cgiirc/cgiirc_0.5.4-6sarge1_s390.deb
      Size/MD5 checksum:   122504 833f9eb5d35ec6baac52ceec8193422d

  Sun Sparc architecture:

    http://security.debian.org/pool/updates/main/c/cgiirc/cgiirc_0.5.4-6sarge1_sparc.deb
      Size/MD5 checksum:   122060 e611d3c02896f065d3989a3182cd4fd7


  These files will probably be moved into the stable distribution on
  its next update.

- ---------------------------------------------------------------------------------
For apt-get: deb http://security.debian.org/ stable/updates main
For dpkg-ftp: ftp://security.debian.org/debian-security dists/stable/updates/main
Mailing list: debian-security-announce@lists.debian.org
Package info: `apt-cache show <pkg>' and http://packages.debian.org/<pkg>

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2.2 (GNU/Linux)

iD8DBQFEXsnNW5ql+IAeqTIRAjWpAJkBbElPsELgjtCrhNAdFaBy36HL0gCeNhsG
+Nf9+YmBr8FFk3zrMSobAEk=
=dM6k
-----END PGP SIGNATURE-----

    

- 漏洞信息

25189
CGI:IRC client.c Cookie Handling Overflows
Input Manipulation
Loss of Integrity Upgrade
Vendor Verified

- 漏洞描述

Unknown or Incomplete

- 时间线

2006-04-30 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 0.5.8 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

CGI:IRC Client.C Remote Buffer Overflow and Denial Of Service Vulnerabilities
Unknown 17799
Yes No
2006-05-02 12:00:00 2006-12-01 07:59:00
The vendor disclosed these vulnerabilities.

- 受影响的程序版本

Debian Linux 3.1 sparc
Debian Linux 3.1 s/390
Debian Linux 3.1 ppc
Debian Linux 3.1 mipsel
Debian Linux 3.1 mips
Debian Linux 3.1 m68k
Debian Linux 3.1 ia-64
Debian Linux 3.1 ia-32
Debian Linux 3.1 hppa
Debian Linux 3.1 arm
Debian Linux 3.1 amd64
Debian Linux 3.1 alpha
Debian Linux 3.1
CGI:IRC CGI:IRC 0.5.7
CGI:IRC CGI:IRC 0.5.4
CGI:IRC CGI:IRC 0.5.8

- 不受影响的程序版本

CGI:IRC CGI:IRC 0.5.8

- 漏洞讨论

CGI:IRC is susceptible to multiple remote vulnerabilities.

A buffer-overflow vulnerability and denial-of-service vulnerability affect CGI:IRC, and potentially allow remote attackers to execute arbitrary machine code and to crash the affected application.

Version 0.5.7 is vulnerable to these issues; other versions may also be affected.

- 漏洞利用

This issue can be exploited through a web client.

Currently we are not aware of any exploits for these issues. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.commailto:vuldb@securityfocus.com

- 解决方案

The vendor has released version 0.5.8 to address this issue; please see the reference section for further details.

Please see the referenced advisories for further information on obtaining and applying fixes.


CGI:IRC CGI:IRC 0.5.4

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站