CVE-2006-2110
CVSS2.1
发布时间 :2006-05-01 15:06:00
修订时间 :2011-03-07 21:35:16
NMCOPS    

[原文]Virtual Private Server (Vserver) 2.0.x before 2.0.2-rc18 and 2.1.x before 2.1.1-rc18 provides certain context capabilities (ccaps) that allow local guest users to perform operations that were only intended to be allowed by the guest-root.


[CNNVD]Linux-VServer ccaps 输入验证漏洞(CNNVD-200605-004)

        Virtual Private Server (Vserver) 2.0.2-rc18之前的2.0.x和2.1.1-rc18 之前的2.1.x版本提供特定的上下文能力(ccaps),使本地guest用户可以执行只能由guest-root允许的操作。

- CVSS (基础分值)

CVSS分值: 2.1 [轻微(LOW)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: NONE [不会对系统完整性产生影响]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:virtual_private_server:vserver:2.0.2
cpe:/a:virtual_private_server:vserver:2.1.1

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-2110
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-2110
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200605-004
(官方数据源) CNNVD

- 其它链接及资源

http://list.linux-vserver.org/archive/vserver/msg13167.html
(PATCH)  MLIST  [Vserver] 20060428 [SECURITY] ccaps not limited to root inside a guest
http://dev.croup.de/proj/gentoo-vps/browser/vserver-sources/2.0.1-r4/4915_vs2.0.1-vxcapable-fix.patch
(PATCH)  CONFIRM  http://dev.croup.de/proj/gentoo-vps/browser/vserver-sources/2.0.1-r4/4915_vs2.0.1-vxcapable-fix.patch
http://www.vupen.com/english/advisories/2006/1661
(UNKNOWN)  VUPEN  ADV-2006-1661
http://xforce.iss.net/xforce/xfdb/26285
(UNKNOWN)  XF  linux-vserver-ccaps-privilege-escalation(26285)
http://www.securityfocus.com/bid/17842
(UNKNOWN)  BID  17842
http://www.debian.org/security/2006/dsa-1060
(UNKNOWN)  DEBIAN  DSA-1060
http://secunia.com/advisories/20206
(UNKNOWN)  SECUNIA  20206
http://secunia.com/advisories/19961
(UNKNOWN)  SECUNIA  19961

- 漏洞信息

Linux-VServer ccaps 输入验证漏洞
低危 设计错误
2006-05-01 00:00:00 2006-05-01 00:00:00
本地  
        Virtual Private Server (Vserver) 2.0.2-rc18之前的2.0.x和2.1.1-rc18 之前的2.1.x版本提供特定的上下文能力(ccaps),使本地guest用户可以执行只能由guest-root允许的操作。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复这个安全问题,补丁下载链接:
        VServer Linux-VServer 2.0-rc2
        VServer delta-vxcapable-fix01a.diff
        http://vserver.13thfloor.at/Stuff/delta-vxcapable-fix01a.diff
        VServer Linux-VServer 2.0-rc1
        VServer delta-vxcapable-fix01a.diff
        http://vserver.13thfloor.at/Stuff/delta-vxcapable-fix01a.diff
        VServer Linux-VServer 1.9.1
        VServer delta-vxcapable-fix01a.diff
        http://vserver.13thfloor.at/Stuff/delta-vxcapable-fix01a.diff
        VServer Linux-VServer 2.0
        VServer delta-vxcapable-fix01a.diff
        >
        http://vserver.13thfloor.at/Stuff/delta-vxcapable-fix01a.diff
        VServer Linux-VServer 2.0.1
        VServer delta-vxcapable-fix01a.diff
        http://vserver.13thfloor.at/Stuff/delta-vxcapable-fix01a.diffr 2.1
        VServer delta-vxcapable-fix01a.diff
        http://vserver.13thfloor.at/Stuff/delta-vxcapable-fix01a.diff

- 漏洞信息 (F46499)

Debian Linux Security Advisory 1060-1 (PacketStormID:F46499)
2006-05-22 00:00:00
Debian  debian.org
advisory,kernel,root
linux,debian
CVE-2006-2110
[点击下载]

Debian Security Advisory 1060-1 - Jan Rekorajski discovered that the kernel patch for virtual private servers does not limit context capabilities to the root user within the virtual server, which might lead to privilege escalation for some virtual server specific operations.

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

- --------------------------------------------------------------------------
Debian Security Advisory DSA 1060-1                    security@debian.org
http://www.debian.org/security/                         Moritz Muehlenhoff
May 19th, 2006                          http://www.debian.org/security/faq
- --------------------------------------------------------------------------

Package        : kernel-patch-vserver
Vulnerability  : programming error
Problem-Type   : local
Debian-specific: no
CVE ID         : CVE-2006-2110

Jan Rekorajski discovered that the kernel patch for virtual private servers
does not limit context capabilities to the root user within the virtual
server, which might lead to privilege escalation for some virtual server
specific operations.

The old stable distribution (woody) does not contain kernel-patch-vserver
packages.

For the stable distribution (sarge) this problem has been fixed in
version 1.9.5.6.

For the unstable distribution (sid) this problem has been fixed in
version 2:2.0.1-4.

We recommend that you upgrade your kernel-patch-vserver package and
rebuild your kernel immediately.


Upgrade Instructions
- --------------------

wget url
        will fetch the file for you
dpkg -i file.deb
        will install the referenced file.

If you are using the apt-get package manager, use the line for
sources.list as given below:

apt-get update
        will update the internal database
apt-get upgrade
        will install corrected packages

You may use an automated update by adding the resources from the
footer to the proper configuration.


Debian GNU/Linux 3.1 alias sarge
- --------------------------------

  Source archives:

    http://security.debian.org/pool/updates/main/k/kernel-patch-vserver/kernel-patch-vserver_1.9.5.6.dsc
      Size/MD5 checksum:      635 512748c6aad20c132cbdf85c5e4fd72a
    http://security.debian.org/pool/updates/main/k/kernel-patch-vserver/kernel-patch-vserver_1.9.5.6.tar.gz
      Size/MD5 checksum:   945398 671ed0151cf315be316024c8a946afe9

  Architecture independent components:

    http://security.debian.org/pool/updates/main/k/kernel-patch-vserver/kernel-patch-vserver_1.9.5.6_all.deb
      Size/MD5 checksum:   431900 02b2d5ba6d4144b8f45056d30100db30


  These files will probably be moved into the stable distribution on
  its next update.

- ---------------------------------------------------------------------------------
For apt-get: deb http://security.debian.org/ stable/updates main
For dpkg-ftp: ftp://security.debian.org/debian-security dists/stable/updates/main
Mailing list: debian-security-announce@lists.debian.org
Package info: `apt-cache show <pkg>' and http://packages.debian.org/<pkg>
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.3 (GNU/Linux)

iD8DBQFEbgtMXm3vHE4uyloRAkYTAKDAtiRkB7JiCSPHKR/55Zdj4vk7MACeOxWo
B16F6yY81DMC1UmWQqLo9SM=
=9TBi
-----END PGP SIGNATURE-----

    

- 漏洞信息

25248
Linux-VServer Context Capabilities (ccaps) Sub User Permission Weakness

- 漏洞描述

Unknown or Incomplete

- 时间线

2006-04-28 Unknow
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Linux-VServer Local Insecure Guest Context Capabilities Vulnerability
Design Error 17842
No Yes
2006-05-04 12:00:00 2006-05-19 09:48:00
Jan Rekorajski reported this issue to the vendor.

- 受影响的程序版本

VServer Linux-VServer 2.1
VServer Linux-VServer 2.0.1
VServer Linux-VServer 2.0
VServer Linux-VServer 1.9.1
VServer Linux-VServer 0.9.12
VServer Linux-VServer 0.9.10
VServer Linux-VServer 2.0-rc2
VServer Linux-VServer 2.0-rc1
Debian Linux 3.1 sparc
Debian Linux 3.1 s/390
Debian Linux 3.1 ppc
Debian Linux 3.1 mipsel
Debian Linux 3.1 mips
Debian Linux 3.1 m68k
Debian Linux 3.1 ia-64
Debian Linux 3.1 ia-32
Debian Linux 3.1 hppa
Debian Linux 3.1 arm
Debian Linux 3.1 amd64
Debian Linux 3.1 alpha
Debian Linux 3.1
VServer Linux-VServer 2.1.1 -rc18
VServer Linux-VServer 2.0.2 -rc18

- 不受影响的程序版本

VServer Linux-VServer 2.1.1 -rc18
VServer Linux-VServer 2.0.2 -rc18

- 漏洞讨论

The Linux-VServer package is susceptible to a vulnerability regarding insecure guest-context capabilities. This issue is due to the kernel's failure to properly enforce security restrictions in guest hosts.

This issue allows unprivileged users in guest hosts to perform various operations that should be restricted to superusers. By exploiting this issue, attackers can launch various attacks in guest hosts.

Note that this issue allows attackers to execute privileged operations only in the guest context, not in the host context.

- 漏洞利用

Attackers exploit this issue by using standard systems-administration utilities.

- 解决方案

The vendor has released a patch to address this issue.

Versions 2.0.2-rc18 and 2.1.1-rc18 are also available; they contain this fix.

Please see the references for more information, fixes, and vendor advisories.


VServer Linux-VServer 2.0-rc2

VServer Linux-VServer 2.0-rc1

VServer Linux-VServer 1.9.1

VServer Linux-VServer 2.0

VServer Linux-VServer 2.0.1

VServer Linux-VServer 2.1

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站