CVE-2006-2069
CVSS5.0
发布时间 :2006-04-27 09:34:00
修订时间 :2011-06-16 00:00:00
NMCOS    

[原文]The recursor in PowerDNS before 3.0.1 allows remote attackers to cause a denial of service (application crash) via malformed EDNS0 packets.


[CNNVD]PowerDNS畸形EDNS0报文远程拒绝服务漏洞(CNNVD-200604-538)

        PowerDNS是一款高效的名称服务器。
        PowerDNS的递归程序在解析某些DNS报文时存在拒绝服务漏洞,攻击者可以发送畸形的EDNS0报文导致递归程序崩溃。

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: NONE [不会对系统完整性产生影响]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: NETWORK [攻击者不需要获取内网访问权或本地访问权]
身份认证: NONE [漏洞利用无需身份认证]

- CWE (弱点类目)

CWE-399 [资源管理错误]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-2069
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-2069
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200604-538
(官方数据源) CNNVD

- 其它链接及资源

http://secunia.com/advisories/19831
(VENDOR_ADVISORY)  SECUNIA  19831
http://xforce.iss.net/xforce/xfdb/26100
(UNKNOWN)  XF  powerdns-recursor-ednso-dos(26100)
http://www.vupen.com/english/advisories/2006/1527
(VENDOR_ADVISORY)  VUPEN  ADV-2006-1527
http://www.securityfocus.com/bid/17711
(UNKNOWN)  BID  17711
http://secunia.com/advisories/20117
(VENDOR_ADVISORY)  SECUNIA  20117
http://lists.suse.com/archive/suse-security-announce/2006-May/0004.html
(UNKNOWN)  SUSE  SUSE-SR:2006:010
http://doc.powerdns.com/changelog.html#CHANGELOG-RECURSOR-3-0-1
(UNKNOWN)  CONFIRM  http://doc.powerdns.com/changelog.html#CHANGELOG-RECURSOR-3-0-1

- 漏洞信息

PowerDNS畸形EDNS0报文远程拒绝服务漏洞
中危 其他
2006-04-27 00:00:00 2007-08-13 00:00:00
远程  
        PowerDNS是一款高效的名称服务器。
        PowerDNS的递归程序在解析某些DNS报文时存在拒绝服务漏洞,攻击者可以发送畸形的EDNS0报文导致递归程序崩溃。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复这个安全问题,补丁下载链接:
        http://www.powerdns.com/en/downloads.aspx

- 漏洞信息

40107
PowerDNS Malformed EDNS0 Packet Remote DoS
Remote / Network Access Denial of Service
Loss of Availability Upgrade
Vendor Verified

- 漏洞描述

- 时间线

2006-04-26 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 3.0.1 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

PowerDNS Malformed EDNS0 Packet Remote Denial of Service Vulnerability
Failure to Handle Exceptional Conditions 17711
Yes No
2006-04-26 12:00:00 2006-05-15 10:19:00
The vendor credits David Gavarret with the discovery of this issue.

- 受影响的程序版本

S.u.S.E. Linux Professional 10.1
S.u.S.E. Linux Personal 10.1
PowerDNS PowerDNS 3.0
PowerDNS PowerDNS 3.0.1

- 不受影响的程序版本

PowerDNS PowerDNS 3.0.1

- 漏洞讨论

A denial-of-service vulnerability affects PowerDNS. This issue is due to the application's failure to properly handle malformed DNS packets.

The vulnerability allows remote attackers from external networks to crash affected DNS servers, denying further service to legitimate users.

PowerDNS version 3.0 is affected by this issue.

- 漏洞利用


Currently we are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com

- 解决方案


Version 3.0.1 of PowerDNS is available to address this issue.

Please see the references for vendor advisories and fixes.


PowerDNS PowerDNS 3.0

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站