CVE-2006-2023
CVSS5.0
发布时间 :2006-04-25 16:06:00
修订时间 :2011-03-07 21:34:48
NMCO    

[原文]Integer overflow in the RTSP_msg_len function in rtsp/RTSP_msg_len.c in Fenice 1.10 and earlier allows remote attackers to cause a denial of service (application crash) via a large HTTP Content-Length value, which leads to an invalid memory access.


[CNNVD]Fenice远程溢出及拒绝服务漏洞(CNNVD-200604-492)

        Fenice是符合IETF标准的多媒体流服务器。
        Fenice的实现上存在多个漏洞,远程攻击者可能利用这些漏洞在服务器上执行任意指令或导致拒绝服务攻击。
        Fenice的RTSP模块使用parse_url函数解析URI中的服务器、端口和文件名。这个函数使用一些strcpy调用填充主函数所传送的服务器和file_name缓冲区,允许攻击者利用缓冲区溢出漏洞执行恶意指令。
        

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: NONE [不会对系统完整性产生影响]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-2023
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-2023
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200604-492
(官方数据源) CNNVD

- 其它链接及资源

http://www.vupen.com/english/advisories/2006/1491
(UNKNOWN)  VUPEN  ADV-2006-1491
http://www.securityfocus.com/bid/17678
(UNKNOWN)  BID  17678
http://www.securityfocus.com/archive/1/archive/1/431870/100/0/threaded
(VENDOR_ADVISORY)  BUGTRAQ  20060423 Buffer-overflow and crash in Fenice OMS 1.10
http://secunia.com/advisories/19770
(VENDOR_ADVISORY)  SECUNIA  19770
http://xforce.iss.net/xforce/xfdb/26080
(UNKNOWN)  XF  fenice-contentlength-dos(26080)
http://www.securityfocus.com/archive/1/archive/1/436256/100/0/threaded
(UNKNOWN)  BUGTRAQ  20060607 Re: Buffer-overflow and crash in Fenice OMS 1.10
http://www.osvdb.org/24882
(UNKNOWN)  OSVDB  24882
http://securityreason.com/securityalert/794
(UNKNOWN)  SREASON  794
http://aluigi.altervista.org/adv/fenicex-adv.txt
(UNKNOWN)  MISC  http://aluigi.altervista.org/adv/fenicex-adv.txt

- 漏洞信息

Fenice远程溢出及拒绝服务漏洞
中危 缓冲区溢出
2006-04-25 00:00:00 2013-01-08 00:00:00
远程  
        Fenice是符合IETF标准的多媒体流服务器。
        Fenice的实现上存在多个漏洞,远程攻击者可能利用这些漏洞在服务器上执行任意指令或导致拒绝服务攻击。
        Fenice的RTSP模块使用parse_url函数解析URI中的服务器、端口和文件名。这个函数使用一些strcpy调用填充主函数所传送的服务器和file_name缓冲区,允许攻击者利用缓冲区溢出漏洞执行恶意指令。
        

- 公告与补丁

        目前厂商还没有提供补丁或者升级程序,我们建议使用此软件的用户随时关注厂商的主页以获取最新版本:
        http://streaming.polito.it/server

- 漏洞信息

24882
Fenice OMS Server HTTP RTSP_msg_len Negative Value DoS
Remote / Network Access Denial of Service, Input Manipulation
Loss of Availability
Exploit Public

- 漏洞描述

Fenice contains a flaw that may allow a remote denial of service. The issue is triggered when a Content-Length HTTP header with a big value such as 2147483647 is sent, and will result in loss of availability for the service.

- 时间线

2006-04-23 Unknow
2006-04-23 Unknow

- 解决方案

Upgrade to version 1.11 (svn r353 - 2006-06-06) or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站