发布时间 :2006-04-25 16:06:00
修订时间 :2011-03-07 21:34:48

[原文]Absolute path traversal vulnerability in recordings/misc/audio.php in the Asterisk Recording Interface (ARI) web interface in Asterisk@Home before 2.8 allows remote attackers to read arbitrary MP3, WAV, and GSM files via a full pathname in the recording parameter. NOTE: this issue can also be used to determine existence of files.

[CNNVD]Asterisk Recording Interface Audio.PHP 信息泄露漏洞 (CNNVD-200604-452)

        Asterisk@Home 2.8之前的版本中的Asterisk录音接口 (ARI) web界面中的recordings/misc/audio.php存在绝对路径遍历漏洞。这使得远程攻击者可以借助于recording参数中的完整路径名读取任意MP3、WAV和GSM文件。

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: NONE [不会对系统完整性产生影响]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(PATCH)  BID  17641
(UNKNOWN)  VUPEN  ADV-2006-1457
(UNKNOWN)  BUGTRAQ  20060421 [SecuriWeb 2006.1] directory traversal in Asterisk@Home and ARI
(UNKNOWN)  XF  asterisk-audio-directory-traversal(25996)

- 漏洞信息

Asterisk Recording Interface Audio.PHP 信息泄露漏洞
中危 输入验证
2006-04-25 00:00:00 2006-04-26 00:00:00
        Asterisk@Home 2.8之前的版本中的Asterisk录音接口 (ARI) web界面中的recordings/misc/audio.php存在绝对路径遍历漏洞。这使得远程攻击者可以借助于recording参数中的完整路径名读取任意MP3、WAV和GSM文件。

- 公告与补丁

        Dan Littlejohn Asterisk Recording Interface 0.7.15
        Dan Littlejohn ari_00.10.00.tar.gz

- 漏洞信息

Asterisk Recording Interface (ARI) misc/audio.php recording Parameter Traversal Arbitrary File Access
Remote / Network Access Input Manipulation
Loss of Confidentiality
Exploit Public

- 漏洞描述

Asterisk Recording Interface contains a flaw that allows a remote attacker to access other user's voice mail. The issue is due to the '/recordings/misc/audio.php' script not properly sanitizing user input, specifically directory traversal style attacks (../../) supplied via the 'recording' variable. This may lead to a loss of confidentiality of '.mp3', '.wav' and '.gsm' voice mail messages. In addition, attackers might be able to determine the existence of files of other files within the remote file system.

- 时间线

2006-04-20 Unknow
2006-04-20 Unknow

- 解决方案

Upgrade to version 0.10.00 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者