CVE-2006-2016
CVSS2.6
发布时间 :2006-04-25 08:50:00
修订时间 :2011-03-07 21:34:48
NMCOS    

[原文]Multiple cross-site scripting (XSS) vulnerabilities in phpLDAPadmin 0.9.8 and earlier allow remote attackers to inject arbitrary web script or HTML via the (1) dn parameter in (a) compare_form.php, (b) copy_form.php, (c) rename_form.php, (d) template_engine.php, and (e) delete_form.php; (2) scope parameter in (f) search.php; and (3) Container DN, (4) Machine Name, and (5) UID Number fields in (g) template_engine.php.


[CNNVD]PHPLDAPAdmin 多个跨站脚本攻击漏洞 (CNNVD-200604-441)

        phpLDAPadmin 0.9.8及早期版本中存在多个跨站脚本攻击漏洞。这使得远程攻击者可以借助于(a) compare_form.php、(b) copy_form.php、(c) rename_form.php、(d) template_engine.php和(e) delete_form.php中的(1)dn参数,(f) search.php中的(2)scope参数,以及(g) template_engine.php中的(3) Container DN、(4) Machine Name和(5) UID Number字段注入任意Web脚本或HTML。

- CVSS (基础分值)

CVSS分值: 2.6 [轻微(LOW)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: HIGH [漏洞利用存在特定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:phpldapadmin:phpldapadmin:0.9.7.2
cpe:/a:phpldapadmin:phpldapadmin:0.9.4a
cpe:/a:phpldapadmin:phpldapadmin:0.9.6c
cpe:/a:phpldapadmin:phpldapadmin:0.9.2
cpe:/a:phpldapadmin:phpldapadmin:0.9.8
cpe:/a:phpldapadmin:phpldapadmin:0.9.7.1
cpe:/a:phpldapadmin:phpldapadmin:0.9.0
cpe:/a:phpldapadmin:phpldapadmin:0.9.4b
cpe:/a:phpldapadmin:phpldapadmin:0.9.4
cpe:/a:phpldapadmin:phpldapadmin:0.9.7
cpe:/a:phpldapadmin:phpldapadmin:0.9.6
cpe:/a:phpldapadmin:phpldapadmin:0.9.3
cpe:/a:phpldapadmin:phpldapadmin:0.9.5
cpe:/a:phpldapadmin:phpldapadmin:0.9.1

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-2016
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-2016
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200604-441
(官方数据源) CNNVD

- 其它链接及资源

http://www.vupen.com/english/advisories/2006/1450
(UNKNOWN)  VUPEN  ADV-2006-1450
http://www.securityfocus.com/bid/17643
(UNKNOWN)  BID  17643
http://www.osvdb.org/24794
(UNKNOWN)  OSVDB  24794
http://www.osvdb.org/24793
(UNKNOWN)  OSVDB  24793
http://www.osvdb.org/24792
(UNKNOWN)  OSVDB  24792
http://www.osvdb.org/24790
(UNKNOWN)  OSVDB  24790
http://www.osvdb.org/24789
(UNKNOWN)  OSVDB  24789
http://www.osvdb.org/24788
(UNKNOWN)  OSVDB  24788
http://secunia.com/advisories/19747
(VENDOR_ADVISORY)  SECUNIA  19747
http://xforce.iss.net/xforce/xfdb/25959
(UNKNOWN)  XF  phpldapadmin-templateengine-xss(25959)
http://xforce.iss.net/xforce/xfdb/25958
(UNKNOWN)  XF  phpldapadmin-scope-dn-xss(25958)
http://www.debian.org/security/2006/dsa-1057
(UNKNOWN)  DEBIAN  DSA-1057
http://secunia.com/advisories/20124
(UNKNOWN)  SECUNIA  20124
http://pridels0.blogspot.com/2006/04/phpldapadmin-multiple-vuln.html
(UNKNOWN)  MISC  http://pridels0.blogspot.com/2006/04/phpldapadmin-multiple-vuln.html

- 漏洞信息

PHPLDAPAdmin 多个跨站脚本攻击漏洞
低危 跨站脚本
2006-04-25 00:00:00 2006-04-26 00:00:00
远程  
        phpLDAPadmin 0.9.8及早期版本中存在多个跨站脚本攻击漏洞。这使得远程攻击者可以借助于(a) compare_form.php、(b) copy_form.php、(c) rename_form.php、(d) template_engine.php和(e) delete_form.php中的(1)dn参数,(f) search.php中的(2)scope参数,以及(g) template_engine.php中的(3) Container DN、(4) Machine Name和(5) UID Number字段注入任意Web脚本或HTML。

- 公告与补丁

        暂无数据

- 漏洞信息

24788
phpLDAPadmin compare_form.php dn Parameter XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

phpLDAPadmin contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate the 'dn' variable upon submission to the compare_form.php script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2006-04-21 Unknow
2006-04-21 Unknow

- 解决方案

Currently, there are no known upgrades, patches, or workarounds available to correct this issue.

- 相关参考

- 漏洞作者

- 漏洞信息

PHPLDAPAdmin Multiple Input Validation Vulnerabilities
Input Validation Error 17643
Yes No
2006-04-21 12:00:00 2006-07-18 08:03:00
r0t is credited with the discovery of these vulnerabilities.

- 受影响的程序版本

phpldapadmin phpldapadmin 0.9.8
FreeBSD FreeBSD -current
Debian Linux 3.1 sparc
Debian Linux 3.1 s/390
Debian Linux 3.1 ppc
Debian Linux 3.1 mipsel
Debian Linux 3.1 mips
Debian Linux 3.1 m68k
Debian Linux 3.1 ia-64
Debian Linux 3.1 ia-32
Debian Linux 3.1 hppa
Debian Linux 3.1 arm
Debian Linux 3.1 amd64
Debian Linux 3.1 alpha
Debian Linux 3.1

- 漏洞讨论

PHPLDAPAdmin is prone to multiple input-validation vulnerabilities. These issues are due to a failure in the application to properly sanitize user-supplied input.

An attacker can exploit these issues to execute arbitrary HTML and script code in the browser of a victim user in the context of the affected website. This may allow the attacker to steal cookie-based authentication credentials, to control how the site is rendered to the user, and to launch other attacks.

- 漏洞利用

Attackers can exploit these issues via a web client.

The following HTML file contains an example URI sufficient to demonstrate the cross-site scripting vulnerabilities:

- 解决方案

Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or if you are aware of more recent information, please mail us at: vuldb@securityfocus.commailto:vuldb@securityfocus.com.

Please see the references for vendor advisories and more information.

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站