CVE-2006-1983
CVSS6.4
发布时间 :2006-04-21 18:02:00
修订时间 :2011-03-07 00:00:00
NMCO    

[原文]Multiple heap-based buffer overflows in Mac OS X 10.4.6 and earlier allow remote attackers to cause a denial of service and possibly execute arbitrary code via the (1) PredictorVSetField function for TIFF or (2) CFAllocatorAllocate function for GIF, as used in applications that use ImageIO or AppKit. NOTE: the BMP vector has been re-assigned to CVE-2006-2238 because it affects a separate product family.


[CNNVD]Apple Mac OS X多个堆溢出漏洞(CNNVD-200604-413)

        Apple Mac OS X是苹果家族机器所使用的操作系统。
        Apple Mac OS X中存在多个安全漏洞,如下:
        1 在解析畸形的.tiff图形文件时,LZWDecodeVector()、_cg_TIFFSetField ()或PredictorVSetField ()函数都没有正确的解析畸形的数据,导致打开该图形的应用程序崩溃。该漏洞是核心.tiff解析引擎触发的,因此Preview、Finder、QuickTime和Safari都可能成为攻击载体。
        2 在解压特制的.zip文件时,BOMStackPop ()函数没有正确的解析畸形数据,导致堆溢出漏洞。
        3 Safari的KWQListIteratorImpl::KWQListIteratorImpl()、QPainter::drawText()和objc_msgSend_rtp()中的漏洞可导致浏览器拒绝服务或执行任意代码。
        4 在解压特制的.bmp文件时,ReadBMP ()函数没有正确的解析畸形数据,导致堆溢出漏洞。
        5 在解压特制的.gif文件时,CFAllocatorAllocate ()函数没有正确的解析畸形数据,导致堆溢出漏洞。

- CVSS (基础分值)

CVSS分值: 6.4 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CWE (弱点类目)

CWE-119 [内存缓冲区边界内操作的限制不恰当]

- CPE (受影响的平台与产品)

cpe:/o:apple:mac_os_x:10.3.9Apple Mac OS X 10.3.9
cpe:/o:apple:mac_os_x:10.3.1Apple Mac OS X 10.3.1
cpe:/o:apple:mac_os_x:10.4.2Apple Mac OS X 10.4.2
cpe:/o:apple:mac_os_x:10.4.6Apple Mac OS X 10.4.6
cpe:/o:apple:mac_os_x_server:10.4.4Apple Mac OS X Server 10.4.4
cpe:/o:apple:mac_os_x_server:10.3.5Apple Mac OS X Server 10.3.5
cpe:/o:apple:mac_os_x:10.4.1Apple Mac OS X 10.4.1
cpe:/o:apple:mac_os_x_server:10.4.1Apple Mac OS X Server 10.4.1
cpe:/o:apple:mac_os_x_server:10.4.3Apple Mac OS X Server 10.4.3
cpe:/o:apple:mac_os_x:10.3.3Apple Mac OS X 10.3.3
cpe:/o:apple:mac_os_x_server:10.4.2Apple Mac OS X Server 10.4.2
cpe:/o:apple:mac_os_x:10.4.5Apple Mac OS X 10.4.5
cpe:/o:apple:mac_os_x_server:10.4.5Apple Mac OS X Server 10.4.5
cpe:/o:apple:mac_os_x:10.4Apple Mac OS X 10.4
cpe:/o:apple:mac_os_x_server:10.3.3Apple Mac OS X Server 10.3.3
cpe:/o:apple:mac_os_x_server:10.3.4Apple Mac OS X Server 10.3.4
cpe:/o:apple:mac_os_x_server:10.4Apple Mac OS X Server 10.4
cpe:/o:apple:mac_os_x:10.3.6Apple Mac OS X 10.3.6
cpe:/o:apple:mac_os_x:10.3.2Apple Mac OS X 10.3.2
cpe:/o:apple:mac_os_x:10.3.8Apple Mac OS X 10.3.8
cpe:/o:apple:mac_os_x_server:10.3.1Apple Mac OS X Server 10.3.1
cpe:/o:apple:mac_os_x:10.3.4Apple Mac OS X 10.3.4
cpe:/o:apple:mac_os_x_server:10.3.2Apple Mac OS X Server 10.3.2
cpe:/o:apple:mac_os_x_server:10.3Apple Mac OS X Server 10.3
cpe:/o:apple:mac_os_x:10.3.7Apple Mac OS X 10.3.7
cpe:/o:apple:mac_os_x_server:10.3.8Apple Mac OS X Server 10.3.8
cpe:/o:apple:mac_os_x:10.3.5Apple Mac OS X 10.3.5
cpe:/o:apple:mac_os_x_server:10.3.7Apple Mac OS X Server 10.3.7
cpe:/o:apple:mac_os_x:10.3Apple Mac OS X 10.3
cpe:/o:apple:mac_os_x:10.4.3Apple Mac OS X 10.4.3
cpe:/o:apple:mac_os_x_server:10.4.6Apple Mac OS X Server 10.4.6
cpe:/o:apple:mac_os_x_server:10.3.6Apple Mac OS X Server 10.3.6
cpe:/o:apple:mac_os_x_server:10.3.9Apple Mac OS X Server 10.3.9
cpe:/o:apple:mac_os_x:10.4.4Apple Mac OS X 10.4.4

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-1983
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-1983
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200604-413
(官方数据源) CNNVD

- 其它链接及资源

http://www.us-cert.gov/cas/techalerts/TA06-132A.html
(VENDOR_ADVISORY)  CERT  TA06-132A
http://securitytracker.com/id?1016067
(PATCH)  SECTRACK  1016067
http://secunia.com/advisories/20077
(VENDOR_ADVISORY)  SECUNIA  20077
http://lists.apple.com/archives/security-announce/2006/May/msg00003.html
(PATCH)  APPLE  APPLE-SA-2006-05-11
http://xforce.iss.net/xforce/xfdb/25951
(UNKNOWN)  XF  macosx-predictorvsetfield-bo(25951)
http://xforce.iss.net/xforce/xfdb/25949
(UNKNOWN)  XF  macosx-cfallocatorallocate-bo(25949)
http://www.vupen.com/english/advisories/2006/1779
(VENDOR_ADVISORY)  VUPEN  ADV-2006-1779
http://www.vupen.com/english/advisories/2006/1452
(VENDOR_ADVISORY)  VUPEN  ADV-2006-1452
http://www.securityfocus.com/bid/17951
(UNKNOWN)  BID  17951
http://www.securityfocus.com/bid/17634
(UNKNOWN)  BID  17634
http://www.security-protocols.com/sp-x30-advisory.php
(VENDOR_ADVISORY)  MISC  http://www.security-protocols.com/sp-x30-advisory.php
http://www.security-protocols.com/sp-x28-advisory.php
(VENDOR_ADVISORY)  MISC  http://www.security-protocols.com/sp-x28-advisory.php
http://www.security-protocols.com/modules.php?name=News&file=article&sid=3233
(UNKNOWN)  MISC  http://www.security-protocols.com/modules.php?name=News&file=article&sid=3233
http://www.osvdb.org/24822
(UNKNOWN)  OSVDB  24822
http://www.osvdb.org/24821
(UNKNOWN)  OSVDB  24821
http://secunia.com/advisories/19686
(VENDOR_ADVISORY)  SECUNIA  19686

- 漏洞信息

Apple Mac OS X多个堆溢出漏洞
中危 缓冲区溢出
2006-04-21 00:00:00 2006-05-16 00:00:00
远程  
        Apple Mac OS X是苹果家族机器所使用的操作系统。
        Apple Mac OS X中存在多个安全漏洞,如下:
        1 在解析畸形的.tiff图形文件时,LZWDecodeVector()、_cg_TIFFSetField ()或PredictorVSetField ()函数都没有正确的解析畸形的数据,导致打开该图形的应用程序崩溃。该漏洞是核心.tiff解析引擎触发的,因此Preview、Finder、QuickTime和Safari都可能成为攻击载体。
        2 在解压特制的.zip文件时,BOMStackPop ()函数没有正确的解析畸形数据,导致堆溢出漏洞。
        3 Safari的KWQListIteratorImpl::KWQListIteratorImpl()、QPainter::drawText()和objc_msgSend_rtp()中的漏洞可导致浏览器拒绝服务或执行任意代码。
        4 在解压特制的.bmp文件时,ReadBMP ()函数没有正确的解析畸形数据,导致堆溢出漏洞。
        5 在解压特制的.gif文件时,CFAllocatorAllocate ()函数没有正确的解析畸形数据,导致堆溢出漏洞。

- 公告与补丁

        目前厂商还没有提供补丁或者升级程序,我们建议使用此软件的用户随时关注厂商的主页以获取最新版本:
        http://www.apple.com

- 漏洞信息

24821
Apple Mac OS X .gif Processing CFAllocatorAllocate() Function Overflow
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Unknown

- 漏洞描述

A remote overflow exists in the Mac OS X default handler for files with a '.gif' extension. The 'CFAllocatorAllocate' function fails to properly validate input, resulting in a heap overflow. With a specially crafted file, an attacker can cause the applicaton to crash and potentially execute arbitrary code on the victim's system, resulting in a loss of integrity.

- 时间线

2006-04-19 Unknow
Unknow Unknow

- 解决方案

Currently, there are no known upgrades, patches, or workarounds available to correct this issue.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站