发布时间 :2006-04-21 06:02:00
修订时间 :2008-09-05 17:03:20

[原文]Cross-site scripting (XSS) vulnerability in addRequest.php in Prayer Request Board (PRB) Beta 1 before 20060320 allows remote attackers to inject arbitrary web script or HTML via the Request field.

[CNNVD]Prayer Request Board (PRB) Beta addRequest.php 跨站脚本攻击漏洞(CNNVD-200604-399)

        20060320之前的Prayer Request Board (PRB) Beta 1中的addRequest.php存在跨站脚本攻击漏洞。这使得远程攻击者可以借助于Request字段注入任意Web脚本或HTML。

- CVSS (基础分值)

CVSS分值: 2.6 [轻微(LOW)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: HIGH [漏洞利用存在特定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(PATCH)  OSVDB  23958

- 漏洞信息

Prayer Request Board (PRB) Beta addRequest.php 跨站脚本攻击漏洞
低危 跨站脚本
2006-04-21 00:00:00 2006-04-25 00:00:00
        20060320之前的Prayer Request Board (PRB) Beta 1中的addRequest.php存在跨站脚本攻击漏洞。这使得远程攻击者可以借助于Request字段注入任意Web脚本或HTML。

- 公告与补丁


- 漏洞信息

Prayer Request Board (PRB) addRequest.php Request Field XSS
Remote / Network Access Input Manipulation
Loss of Integrity Upgrade
Exploit Public RBS Confirmed

- 漏洞描述

Prayer Request Board (PRB) contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate the 'Request' field upon submission to the addRequest.php script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2006-03-19 2006-03-19
2006-03-19 Unknow

- 解决方案

Upgrade to version Beta 1 or higher, as it has been reported to fix this vulnerability. Note that this flaw was fixed in the 2006-03-20 release without a change in version number. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者