发布时间 :2006-04-20 18:02:00
修订时间 :2008-11-03 01:18:10

[原文]Cross-site scripting (XSS) vulnerability in in AWStats 6.5 and earlier allows remote attackers to inject arbitrary web script or HTML via the config parameter. NOTE: this might be the same core issue as CVE-2005-2732.

[CNNVD]AWStats AWstats.PL 跨站脚本攻击漏洞 (CNNVD-200604-330)

        AWStats 6.5及早期版本的awstats.pl存在跨站脚本攻击漏洞。这使得远程攻击者可以借助于config参数注入任意Web脚本或HTML。

- CVSS (基础分值)

CVSS分值: 2.6 [轻微(LOW)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: HIGH [漏洞利用存在特定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(UNKNOWN)  BID  17621

- 漏洞信息

AWStats AWstats.PL 跨站脚本攻击漏洞
低危 跨站脚本
2006-04-20 00:00:00 2006-04-25 00:00:00
        AWStats 6.5及早期版本的awstats.pl存在跨站脚本攻击漏洞。这使得远程攻击者可以借助于config参数注入任意Web脚本或HTML。

- 公告与补丁

        AWStats AWStats 6.3
        Ubuntu awstats_6.3-1ubuntu0.4_all.deb
        Ubuntu 5.04: ntu0.4_all.deb
        AWStats AWStats 6.4
        Ubuntu awstats_6.4-1ubuntu1.3_all.deb
        Ubuntu 5.10: ntu1.3_all.deb

- 漏洞信息

AWStats Multiple Parameter XSS
Remote / Network Access Input Manipulation
Loss of Integrity Solution Unknown
Exploit Public Uncoordinated Disclosure

- 漏洞描述

- 时间线

2006-04-18 Unknow
2006-04-18 Unknow

- 解决方案


Unknown or Incomplete

- 相关参考

- 漏洞作者

- 漏洞信息

AWStats AWstats.PL Multiple Cross-Site Scripting Vulnerabilities
Input Validation Error 17621
Yes No
2006-04-19 12:00:00 2006-12-19 07:42:00
r0t is credited with the discovery of this vulnerability.

- 受影响的程序版本

Ubuntu Ubuntu Linux 5.10 sparc
Ubuntu Ubuntu Linux 5.10 powerpc
Ubuntu Ubuntu Linux 5.10 i386
Ubuntu Ubuntu Linux 5.10 amd64
Ubuntu Ubuntu Linux 5.0 4 powerpc
Ubuntu Ubuntu Linux 5.0 4 i386
Ubuntu Ubuntu Linux 5.0 4 amd64
Ubuntu Ubuntu Linux 6.06 LTS sparc
Ubuntu Ubuntu Linux 6.06 LTS powerpc
Ubuntu Ubuntu Linux 6.06 LTS i386
Ubuntu Ubuntu Linux 6.06 LTS amd64
Gentoo Linux
AWStats AWStats 6.4
AWStats AWStats 6.3
AWStats AWStats 6.2
AWStats AWStats 6.1
AWStats AWStats 6.0
AWStats AWStats 5.9
AWStats AWStats 5.8
AWStats AWStats 5.7
AWStats AWStats 5.6
AWStats AWStats 5.5
AWStats AWStats 5.4
AWStats AWStats 5.3
AWStats AWStats 5.2
AWStats AWStats 5.1
AWStats AWStats 5.0
AWStats AWStats 4.0
+ Debian Linux 3.0 sparc
+ Debian Linux 3.0 s/390
+ Debian Linux 3.0 ppc
+ Debian Linux 3.0 mipsel
+ Debian Linux 3.0 mips
+ Debian Linux 3.0 m68k
+ Debian Linux 3.0 ia-64
+ Debian Linux 3.0 ia-32
+ Debian Linux 3.0 hppa
+ Debian Linux 3.0 arm
+ Debian Linux 3.0 alpha
+ Debian Linux 3.0
AWStats AWStats 6.5.0 build 1.857

- 漏洞讨论

AWStats is prone to multiple cross-site scripting vulnerabilities. These issues are due to a failure in the application to properly sanitize user-supplied input.

An attacker may leverage these issues to have arbitrary script code executed in the browser of an unsuspecting user in the context of the affected site. This may help the attacker steal cookie-based authentication credentials and launch other attacks.

AWStats version 6.5 (build 1.857) and prior are vulnerable to these issues.

- 漏洞利用

This issue can be exploited through a web client.

The following proofs-of-concept URI are available:[XSS]&refererpagesfilterex=&output=refererpages&[XSS]&output=refererpages&[XSS]&output=urlentry&[XSS]&urlfilterex=&output=urlentry&[XSS]&hostfilterex=&output=allhosts&[XSS]&output=allhosts&

- 解决方案

Currently we are not aware of any official vendor-supplied patches for this issue. If you feel we are in error or if you are aware of more recent information, please mail us at:

Please see the referenced advisories for more information.

AWStats AWStats 6.3

AWStats AWStats 6.4

- 相关参考