CVE-2006-1924
CVSS6.4
发布时间 :2006-04-20 14:06:00
修订时间 :2011-03-07 21:34:33
NMCO    

[原文]SQL injection vulnerability in functions/db_api.php in LinPHA 1.1.1 allows remote attackers to execute arbitrary SQL commands via unknown vectors.


[CNNVD]LinPHA functions/db_api.php SQL注入漏洞(CNNVD-200604-331)

        LinPHA 1.1.1 中的functions/db_api.php存在SQL注入漏洞。这使得远程攻击者可以借助于未知向量执行任意SQL命令。

- CVSS (基础分值)

CVSS分值: 6.4 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:linpha:linpha:1.1.0
cpe:/a:linpha:linpha:1.0

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-1924
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-1924
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200604-331
(官方数据源) CNNVD

- 其它链接及资源

http://secunia.com/advisories/19719
(VENDOR_ADVISORY)  SECUNIA  19719
http://www.vupen.com/english/advisories/2006/1424
(UNKNOWN)  VUPEN  ADV-2006-1424
http://xforce.iss.net/xforce/xfdb/26268
(UNKNOWN)  XF  linpha-functionsdbapi-sql-injection(26268)
http://www.securityfocus.com/bid/17619
(UNKNOWN)  BID  17619
http://www.osvdb.org/24817
(UNKNOWN)  OSVDB  24817
http://attrition.org/pipermail/vim/2006-April/000709.html
(UNKNOWN)  VIM  20060420 LinPHA provenance/acknowledgement

- 漏洞信息

LinPHA functions/db_api.php SQL注入漏洞
中危 SQL注入
2006-04-20 00:00:00 2006-04-24 00:00:00
远程  
        LinPHA 1.1.1 中的functions/db_api.php存在SQL注入漏洞。这使得远程攻击者可以借助于未知向量执行任意SQL命令。

- 公告与补丁

        目前厂商还没有提供补丁或者升级程序,建议使用此软件的用户随时关注厂商的主页以获取最新版本:
        http://linpha.sourceforge.net/
        

- 漏洞信息

24817
LinPHA functions/db_api.php SQL Injection
Remote / Network Access Information Disclosure, Input Manipulation
Loss of Confidentiality, Loss of Integrity

- 漏洞描述

LinPHA contains a flaw that may allow an attacker to carry out an SQL injection attack. The issue is due to the functions/db_api.php script not properly sanitizing user-supplied input to unknown or unspecified variables. This may allow an attacker to inject or manipulate SQL queries in the back-end database.

- 时间线

2006-04-19 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 1.1.1 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站