发布时间 :2006-04-21 19:06:00
修订时间 :2011-02-04 00:00:00

[原文]Argument injection vulnerability in Beagle before 0.2.5 allows attackers to execute arbitrary commands via crafted filenames that inject command line arguments when Beagle launches external helper applications while indexing.

[CNNVD]Beagle 参数注入漏洞(CNNVD-200604-400)

        Beagle 0.2.5之前的版本中存在参数注入漏洞。这使得,当Beagle在标引过程中启动外部帮助应用时,远程攻击者可以借助于注入命令行参数的精心设计的文件名执行任意命令。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: NETWORK [攻击者不需要获取内网访问权或本地访问权]
身份认证: NONE [漏洞利用无需身份认证]

- CWE (弱点类目)

CWE-94 [对生成代码的控制不恰当(代码注入)]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(UNKNOWN)  XF  beagle-indexing-command-execution(26104)
(UNKNOWN)  BID  17611

- 漏洞信息

Beagle 参数注入漏洞
高危 输入验证
2006-04-21 00:00:00 2007-08-13 00:00:00
        Beagle 0.2.5之前的版本中存在参数注入漏洞。这使得,当Beagle在标引过程中启动外部帮助应用时,远程攻击者可以借助于注入命令行参数的精心设计的文件名执行任意命令。

- 公告与补丁


- 漏洞信息

Beagle External Helper Commandline Argument Injection
Local Access Required Input Manipulation
Loss of Integrity
Exploit Unknown Vendor Verified

- 漏洞描述

Beagle contains a flaw that may allow a malicious user to pass argbitrary arguments to helper applications. The issue is triggered when Beagle, during its indexing process, launches helper applications. It is possible that the flaw may allow arbitrary code exection, resulting in a loss of integrity.

- 时间线

2006-04-25 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 0.2.5 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

- 漏洞信息

Beagle Helper Applications Arbitrary Code Execution Vulnerability
Input Validation Error 17611
Yes Yes
2006-04-19 12:00:00 2006-04-28 10:10:00
Chris Evans discovered this vulnerability.

- 受影响的程序版本

S.u.S.E. Linux Professional 10.0 OSS
S.u.S.E. Linux Professional 10.0
S.u.S.E. Linux Professional 9.3 x86_64
S.u.S.E. Linux Professional 9.3
S.u.S.E. Linux Personal 10.0 OSS
S.u.S.E. Linux Personal 9.3 x86_64
S.u.S.E. Linux Personal 9.3
Red Hat Fedora Core5
Beagle Beagle 0.2.4

- 漏洞讨论

Beagle is susceptible to an insecure indexing issue when dealing with helper applications. This can lead to arbitrary code execution.

An attacker can exploit this issue to execute arbitrary code with the privileges of the user running the vulnerable application.

- 漏洞利用

An exploit is not required.

- 解决方案

This issue has been addressed in the latest CVS repository for the application.

Please see the references for vendor advisories and more information.

- 相关参考