发布时间 :2006-04-19 12:06:00
修订时间 :2011-03-07 21:34:23

[原文]PHP remote file inclusion vulnerability in language.php in PHP Album, when register_globals is enabled, allows remote attackers to execute arbitrary code via an FTP URL in the data_dir parameter, which satisfies the file_exists function call.

[CNNVD]PHPAlbum Language.PHP 远程文件包含漏洞 (CNNVD-200604-301)

        当启用register_globals时,PHP Album中的language.php中的PHP 远程文件包含漏洞允许远程攻击者借助于data_dir参数中的FTP URL(满足了file_exists函数调用)执行任意代码。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(UNKNOWN)  VUPEN  ADV-2006-1382
(UNKNOWN)  BUGTRAQ  20060415 PHP Album <= remote commnads execution
(UNKNOWN)  XF  phpalbum-language-file-include(25846)
(UNKNOWN)  BID  17526

- 漏洞信息

PHPAlbum Language.PHP 远程文件包含漏洞
高危 输入验证
2006-04-19 00:00:00 2006-04-20 00:00:00
        当启用register_globals时,PHP Album中的language.php中的PHP 远程文件包含漏洞允许远程攻击者借助于data_dir参数中的FTP URL(满足了file_exists函数调用)执行任意代码。

- 公告与补丁


- 漏洞信息

PHP Album language.php data_dir Parameter Remote File Inclusion
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

PHP Album contains a flaw that may allow a remote attacker to execute arbitrary commands. The issue is due to language.php not properly sanitizing user input supplied to the 'data_dir' variable. This may allow an attacker to include a file from a remote host that contains arbitrary commands which will be executed by the vulnerable script.

- 时间线

2006-04-15 Unknow
2006-04-15 Unknow

- 解决方案

Currently, there are no known upgrades, patches, or workarounds available to correct this issue.

- 相关参考

- 漏洞作者

- 漏洞信息

PHPAlbum Language.PHP File Include Vulnerability
Input Validation Error 17526
Yes No
2006-04-15 12:00:00 2008-11-05 05:05:00
rgod is credited with the discovery of this vulnerability.

- 受影响的程序版本 phpalbum 0.3.2 .3 phpalbum 0.2.3 phpalbum 4.1 phpalbum 4.1.14

- 不受影响的程序版本 phpalbum 4.1.14

- 漏洞讨论

phpAlbum is prone to a remote file-include vulnerability because it fails to properly sanitize user-supplied input.

An attacker can exploit this issue to execute arbitrary remote PHP code on an affected computer with the privileges of the webserver process. This may facilitate unauthorized access.

phpAlbum and prior versions are affected.

- 漏洞利用

No exploit is required.

The following proof of concept is available:

- 解决方案

The vendor released an update to address this issue. Please see the references for more information.

- 相关参考