发布时间 :2006-04-18 06:02:00
修订时间 :2011-03-07 21:34:08

[原文]Cross-site scripting (XSS) vulnerability in sql.php in phpMyAdmin 2.7.0-pl1 allows remote attackers to inject arbitrary web script or HTML via the sql_query parameter.

[CNNVD]PHPMyAdmin SQL.PHP跨站脚本攻击漏洞 (CNNVD-200604-277)

        phpMyAdmin 2.7.0-pl1中的sql.php存在跨站脚本攻击漏洞。这使得远程攻击者可以借助于sql_query参数注入任意Web脚本或HTML。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(UNKNOWN)  VUPEN  ADV-2006-1372
(UNKNOWN)  BID  17487
(UNKNOWN)  BUGTRAQ  20060414 Re: phpMyAdmin 2.7.0-pl1
(UNKNOWN)  BUGTRAQ  20060412 phpMyAdmin 2.7.0-pl1
(UNKNOWN)  XF  phpmyadmin-sql-xss(25796)

- 漏洞信息

PHPMyAdmin SQL.PHP跨站脚本攻击漏洞
中危 跨站脚本
2006-04-18 00:00:00 2006-04-18 00:00:00
        phpMyAdmin 2.7.0-pl1中的sql.php存在跨站脚本攻击漏洞。这使得远程攻击者可以借助于sql_query参数注入任意Web脚本或HTML。

- 公告与补丁


- 漏洞信息

phpMyAdmin sql.php sql_query Parameter XSS
Remote / Network Access Input Manipulation
Loss of Integrity

- 漏洞描述

Unknown or Incomplete

- 时间线

2006-04-12 Unknow
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

PHPMyAdmin SQL.PHP Cross-Site Scripting Vulnerability
Input Validation Error 17487
Yes No
2005-10-31 12:00:00 2006-04-28 09:40:00
p0w3r is credited with the discovery of this vulnerability.

- 受影响的程序版本

S.u.S.E. Linux Professional 10.0 OSS
S.u.S.E. Linux Professional 10.0
S.u.S.E. Linux Professional 9.3 x86_64
S.u.S.E. Linux Professional 9.3
S.u.S.E. Linux Professional 9.2 x86_64
S.u.S.E. Linux Professional 9.2
S.u.S.E. Linux Professional 9.1 x86_64
S.u.S.E. Linux Professional 9.1
S.u.S.E. Linux Professional 9.0 x86_64
S.u.S.E. Linux Professional 9.0
S.u.S.E. Linux Personal 10.0 OSS
S.u.S.E. Linux Personal 9.3 x86_64
S.u.S.E. Linux Personal 9.3
S.u.S.E. Linux Personal 9.2 x86_64
S.u.S.E. Linux Personal 9.2
S.u.S.E. Linux Personal 9.1 x86_64
S.u.S.E. Linux Personal 9.1
S.u.S.E. Linux Personal 9.0 x86_64
S.u.S.E. Linux Personal 9.0
phpMyAdmin phpMyAdmin 2.7 -pl1

- 漏洞讨论

PHPMyAdmin is prone to a cross-site scripting vulnerability. This issue is due to a failure in the application to properly sanitize user-supplied input.

An attacker may leverage this issue to have arbitrary script code executed in the browser of an unsuspecting user in the context of the affected site. This may help the attacker steal cookie-based authentication credentials and launch other attacks.

- 漏洞利用

This issue can be exploited via a web client.

The following proof-of-concept URI is available:

- 解决方案

Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at:

SUSE Linux has released a security summary report addressing this and other issues.

- 相关参考