CVE-2006-1788
CVSS2.6
发布时间 :2006-04-13 18:02:00
修订时间 :2011-03-07 21:34:07
NMCO    

[原文]Adobe Document Server for Reader Extensions 6.0, during log on, provides different error messages depending on whether the user ID is valid or invalid, which allows remote attackers to more easily identify valid user IDs via brute force attacks.


[CNNVD]Adobe Document Server for Reader Extensions多个远程漏洞(CNNVD-200604-211)

        Adobe Document Server for Reader Extensions允许用户与外部组织和人员共享交互式与智能型的Adobe PDF文件。
        Adobe Document Server for Reader Extensions中存在多个漏洞,可能允许恶意用户绕过一些安全限制并执行脚本注入攻击,或获取敏感信息或执行跨站脚本攻击。
        1) Adobe Document Server for Reader Extensions(ads-readerext)缺少访问控制限制,可能允许已认证用户通过actionID和pageID参数访问本不应访问的功能。
        成功攻击允许拥有Draft权限的低权限用户创建新的管理用户帐号。
        2) ads-readerext没有正确地过滤"Update Download Site"中对ReaderURL变量的输入。攻击者可以利用这个漏洞注入有"ftp://" 或"http://" 前缀的任意脚本代码,然后在管理用户登录时在用户浏览器会话中执行该代码。
        正常情况下编辑这个字段要求管理权限,但如果结合上一个漏洞的话任何有效用户都可以利用这个漏洞。
        3) 在返回给用户之前没有正确过滤ads-readerext中对"actionID"参数的输入;以及Adobe Server Web Services(AlterCast)中对"op"参数的输入,可能导致在有漏洞站点环境下在用户浏览器会话中执行任意HTML和脚本代码。
        4) 在试图登录到ads-readerext时会返回不同的错误消息,具体取决于是否存在所提供的用户名。攻击者可以利用这个漏洞枚举有效帐号。
        5) ads-readerext的用户会话ID传送给了URL的"jsessionid"参数并在"Referer:"首部中泄漏给其他站点。
        
        

- CVSS (基础分值)

CVSS分值: 2.6 [轻微(LOW)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: NONE [不会对系统完整性产生影响]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: HIGH [漏洞利用存在特定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-1788
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-1788
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200604-211
(官方数据源) CNNVD

- 其它链接及资源

http://www.adobe.com/support/techdocs/331917.html
(VENDOR_ADVISORY)  CONFIRM  http://www.adobe.com/support/techdocs/331917.html
http://www.vupen.com/english/advisories/2006/1342
(UNKNOWN)  VUPEN  ADV-2006-1342
http://secunia.com/secunia_research/2005-68/advisory/
(VENDOR_ADVISORY)  MISC  http://secunia.com/secunia_research/2005-68/advisory/
http://secunia.com/advisories/15924
(VENDOR_ADVISORY)  SECUNIA  15924
http://xforce.iss.net/xforce/xfdb/25772
(UNKNOWN)  XF  adobe-error-account-enumeration(25772)
http://www.securityfocus.com/bid/17500
(UNKNOWN)  BID  17500
http://www.securityfocus.com/archive/1/archive/1/430869/100/0/threaded
(UNKNOWN)  BUGTRAQ  20060413 Secunia Research: Adobe Document Server for Reader ExtensionsMultiple Vulnerabilities

- 漏洞信息

Adobe Document Server for Reader Extensions多个远程漏洞
低危 资料不足
2006-04-13 00:00:00 2006-04-15 00:00:00
远程  
        Adobe Document Server for Reader Extensions允许用户与外部组织和人员共享交互式与智能型的Adobe PDF文件。
        Adobe Document Server for Reader Extensions中存在多个漏洞,可能允许恶意用户绕过一些安全限制并执行脚本注入攻击,或获取敏感信息或执行跨站脚本攻击。
        1) Adobe Document Server for Reader Extensions(ads-readerext)缺少访问控制限制,可能允许已认证用户通过actionID和pageID参数访问本不应访问的功能。
        成功攻击允许拥有Draft权限的低权限用户创建新的管理用户帐号。
        2) ads-readerext没有正确地过滤"Update Download Site"中对ReaderURL变量的输入。攻击者可以利用这个漏洞注入有"ftp://" 或"http://" 前缀的任意脚本代码,然后在管理用户登录时在用户浏览器会话中执行该代码。
        正常情况下编辑这个字段要求管理权限,但如果结合上一个漏洞的话任何有效用户都可以利用这个漏洞。
        3) 在返回给用户之前没有正确过滤ads-readerext中对"actionID"参数的输入;以及Adobe Server Web Services(AlterCast)中对"op"参数的输入,可能导致在有漏洞站点环境下在用户浏览器会话中执行任意HTML和脚本代码。
        4) 在试图登录到ads-readerext时会返回不同的错误消息,具体取决于是否存在所提供的用户名。攻击者可以利用这个漏洞枚举有效帐号。
        5) ads-readerext的用户会话ID传送给了URL的"jsessionid"参数并在"Referer:"首部中泄漏给其他站点。
        
        

- 公告与补丁

        目前厂商已经发布了升级补丁以修复这个安全问题,补丁下载链接:
        http://www.adobe.com/support/products/enterprise/

- 漏洞信息

24591
Adobe Document Server for Reader Extensions ads-readerext Error Message Account Enumeration
Remote / Network Access Information Disclosure
Loss of Confidentiality Upgrade
Exploit Public RBS Confirmed, Vendor Verified, Coordinated Disclosure

- 漏洞描述

Adobe Document Server for Reader Extensions contains a flaw related to the 'ads-readerext' script as different error messages are returned when a remote attacker attempts to log in, allowing enumeration of valid accounts.

- 时间线

2006-04-13 2005-07-26
2006-04-13 Unknow

- 解决方案

Upgrade to version 6.1 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站